HOWTO: Install PHP7 on CentOS 7 Topic is solved

Questions regarding the Web Server
Apache + Nginx, Nginx + PHP5-FPM
SS88
Posts: 298
Joined: Thu Nov 19, 2015 12:40 pm

Re: HOWTO: Install PHP7 on CentOS 7

Postby SS88 » Wed Jan 11, 2017 2:52 pm

desolator wrote:After installing did you reboot?

Your errors tell me what it couldn't start nginx because something (probably nginx) is already listening on port 80.


Yes i rebooted

I used this for installation since got a seperate email server

Code: Select all

bash vst-install.sh --nginx yes --phpfpm yes --apache no --vsftpd yes --proftpd no --exim no --dovecot no --spamassassin no --clamav no --named yes --iptables yes --fail2ban no --mysql yes --postgresql no --remi no --quota no


I followed the steps 1 by 1 without error but nginx does not start

Error message on Nginx Restart

Code: Select all

[root@host ~]# service nginx restart
Redirecting to /bin/systemctl restart  nginx.service
Job for nginx.service failed because the control process exited with error code. See "systemctl status nginx.service" and "journalctl -xe" for details.


PHP Installation details

Code: Select all

[root@host ~]# service php-fpm stop
Redirecting to /bin/systemctl stop  php-fpm.service
[root@host~]# yum -y --enablerepo=remi install php70-php php70-php-pear php70-php-bcmath php70-php-pecl-jsond-devel php70-php-mysqlnd php70-php-gd php70-php-common php70-php-fpm php70-php-intl php70-php-cli php70-php php70-php-xml php70-php-opcache php70-php-pecl-apcu php70-php-pecl-jsond php70-php-pdo php70-php-gmp php70-php-process php70-php-pecl-imagick php70-php-devel php70-php-mbstring
No package php70-php-pecl-jsond-devel available.
No package php70-php-pecl-jsond available.
Resolving Dependencies
--> Running transaction check
---> Package php70-php.x86_64 0:7.0.14-1.el7.remi will be installed
---> Package php70-php-bcmath.x86_64 0:7.0.14-1.el7.remi will be installed
---> Package php70-php-cli.x86_64 0:7.0.14-1.el7.remi will be installed
---> Package php70-php-common.x86_64 0:7.0.14-1.el7.remi will be installed
--> Processing Dependency: php70-php-json(x86-64) = 7.0.14-1.el7.remi for package: php70-php-common-7.0.14-1.el7.remi.x86_64
--> Processing Dependency: php70-runtime for package: php70-php-common-7.0.14-1.el7.remi.x86_64
---> Package php70-php-devel.x86_64 0:7.0.14-1.el7.remi will be installed
--> Processing Dependency: pcre-devel(x86-64) >= 8.20 for package: php70-php-devel-7.0.14-1.el7.remi.x86_64
--> Processing Dependency: automake for package: php70-php-devel-7.0.14-1.el7.remi.x86_64
--> Processing Dependency: autoconf for package: php70-php-devel-7.0.14-1.el7.remi.x86_64
---> Package php70-php-fpm.x86_64 0:7.0.14-1.el7.remi will be installed
---> Package php70-php-gd.x86_64 0:7.0.14-1.el7.remi will be installed
--> Processing Dependency: gd-last(x86-64) >= 2.1.1 for package: php70-php-gd-7.0.14-1.el7.remi.x86_64
--> Processing Dependency: libgd.so.3()(64bit) for package: php70-php-gd-7.0.14-1.el7.remi.x86_64
---> Package php70-php-gmp.x86_64 0:7.0.14-1.el7.remi will be installed
---> Package php70-php-intl.x86_64 0:7.0.14-1.el7.remi will be installed
--> Processing Dependency: libicuuc.so.50()(64bit) for package: php70-php-intl-7.0.14-1.el7.remi.x86_64
--> Processing Dependency: libicuio.so.50()(64bit) for package: php70-php-intl-7.0.14-1.el7.remi.x86_64
--> Processing Dependency: libicui18n.so.50()(64bit) for package: php70-php-intl-7.0.14-1.el7.remi.x86_64
--> Processing Dependency: libicudata.so.50()(64bit) for package: php70-php-intl-7.0.14-1.el7.remi.x86_64
---> Package php70-php-mbstring.x86_64 0:7.0.14-1.el7.remi will be installed
---> Package php70-php-mysqlnd.x86_64 0:7.0.14-1.el7.remi will be installed
---> Package php70-php-opcache.x86_64 0:7.0.14-1.el7.remi will be installed
---> Package php70-php-pdo.x86_64 0:7.0.14-1.el7.remi will be installed
---> Package php70-php-pear.noarch 1:1.10.1-7.el7.remi will be installed
---> Package php70-php-pecl-apcu.x86_64 0:5.1.7-1.el7.remi will be installed
--> Processing Dependency: php70-php-pecl-apcu-bc(x86-64) for package: php70-php-pecl-apcu-5.1.7-1.el7.remi.x86_64
---> Package php70-php-pecl-imagick.x86_64 0:3.4.3-0.4.RC1.el7.remi will be installed
--> Processing Dependency: ImageMagick6-libs(x86-64) >= 6.9.6 for package: php70-php-pecl-imagick-3.4.3-0.4.RC1.el7.remi.x86_64
--> Processing Dependency: libMagickWand-6.Q16.so.3()(64bit) for package: php70-php-pecl-imagick-3.4.3-0.4.RC1.el7.remi.x86_64
--> Processing Dependency: libMagickCore-6.Q16.so.3()(64bit) for package: php70-php-pecl-imagick-3.4.3-0.4.RC1.el7.remi.x86_64
---> Package php70-php-process.x86_64 0:7.0.14-1.el7.remi will be installed
---> Package php70-php-xml.x86_64 0:7.0.14-1.el7.remi will be installed
--> Running transaction check
---> Package ImageMagick6-libs.x86_64 0:6.9.7.3-1.el7.remi will be installed
--> Processing Dependency: libwebp.so.4()(64bit) for package: ImageMagick6-libs-6.9.7.3-1.el7.remi.x86_64
--> Processing Dependency: libgvc.so.6()(64bit) for package: ImageMagick6-libs-6.9.7.3-1.el7.remi.x86_64
--> Processing Dependency: libfftw3.so.3()(64bit) for package: ImageMagick6-libs-6.9.7.3-1.el7.remi.x86_64
--> Processing Dependency: libcgraph.so.6()(64bit) for package: ImageMagick6-libs-6.9.7.3-1.el7.remi.x86_64
--> Processing Dependency: libcdt.so.5()(64bit) for package: ImageMagick6-libs-6.9.7.3-1.el7.remi.x86_64
---> Package autoconf.noarch 0:2.69-11.el7 will be installed
---> Package automake.noarch 0:1.13.4-3.el7 will be installed
--> Processing Dependency: perl(Thread::Queue) for package: automake-1.13.4-3.el7.noarch
--> Processing Dependency: perl(TAP::Parser) for package: automake-1.13.4-3.el7.noarch
---> Package gd-last.x86_64 0:2.2.3-1.el7.remi will be installed
---> Package libicu.x86_64 0:50.1.2-15.el7 will be installed
---> Package pcre-devel.x86_64 0:8.32-15.el7_2.1 will be installed
---> Package php70-php-json.x86_64 0:7.0.14-1.el7.remi will be installed
---> Package php70-php-pecl-apcu-bc.x86_64 0:1.0.3-1.el7.remi will be installed
---> Package php70-runtime.x86_64 0:1.0-5.el7.remi will be installed
--> Processing Dependency: scl-utils for package: php70-runtime-1.0-5.el7.remi.x86_64
--> Processing Dependency: environment-modules for package: php70-runtime-1.0-5.el7.remi.x86_64
--> Processing Dependency: /usr/sbin/semanage for package: php70-runtime-1.0-5.el7.remi.x86_64
--> Running transaction check
---> Package environment-modules.x86_64 0:3.2.10-10.el7 will be installed
---> Package fftw-libs-double.x86_64 0:3.3.3-8.el7 will be installed
---> Package graphviz.x86_64 0:2.30.1-19.el7 will be installed
--> Processing Dependency: libgtk-x11-2.0.so.0()(64bit) for package: graphviz-2.30.1-19.el7.x86_64
--> Processing Dependency: libgdk-x11-2.0.so.0()(64bit) for package: graphviz-2.30.1-19.el7.x86_64
--> Processing Dependency: libatk-1.0.so.0()(64bit) for package: graphviz-2.30.1-19.el7.x86_64
--> Processing Dependency: libXmu.so.6()(64bit) for package: graphviz-2.30.1-19.el7.x86_64
--> Processing Dependency: libXaw.so.7()(64bit) for package: graphviz-2.30.1-19.el7.x86_64
---> Package libwebp.x86_64 0:0.3.0-3.el7 will be installed
---> Package perl-Test-Harness.noarch 0:3.28-3.el7 will be installed
---> Package perl-Thread-Queue.noarch 0:3.02-2.el7 will be installed
---> Package policycoreutils-python.x86_64 0:2.5-9.el7 will be installed
--> Processing Dependency: setools-libs >= 3.3.8-1 for package: policycoreutils-python-2.5-9.el7.x86_64
--> Processing Dependency: libsemanage-python >= 2.5-4 for package: policycoreutils-python-2.5-9.el7.x86_64
--> Processing Dependency: audit-libs-python >= 2.1.3-4 for package: policycoreutils-python-2.5-9.el7.x86_64
--> Processing Dependency: python-IPy for package: policycoreutils-python-2.5-9.el7.x86_64
--> Processing Dependency: libqpol.so.1(VERS_1.4)(64bit) for package: policycoreutils-python-2.5-9.el7.x86_64
--> Processing Dependency: libqpol.so.1(VERS_1.2)(64bit) for package: policycoreutils-python-2.5-9.el7.x86_64
--> Processing Dependency: libcgroup for package: policycoreutils-python-2.5-9.el7.x86_64
--> Processing Dependency: libapol.so.4(VERS_4.0)(64bit) for package: policycoreutils-python-2.5-9.el7.x86_64
--> Processing Dependency: checkpolicy for package: policycoreutils-python-2.5-9.el7.x86_64
--> Processing Dependency: libqpol.so.1()(64bit) for package: policycoreutils-python-2.5-9.el7.x86_64
--> Processing Dependency: libapol.so.4()(64bit) for package: policycoreutils-python-2.5-9.el7.x86_64
---> Package scl-utils.x86_64 0:20130529-17.el7_1 will be installed
--> Running transaction check
---> Package atk.x86_64 0:2.14.0-1.el7 will be installed
---> Package audit-libs-python.x86_64 0:2.6.5-3.el7 will be installed
---> Package checkpolicy.x86_64 0:2.5-4.el7 will be installed
---> Package gtk2.x86_64 0:2.24.28-8.el7 will be installed
--> Processing Dependency: libXrandr >= 1.2.99.4-2 for package: gtk2-2.24.28-8.el7.x86_64
--> Processing Dependency: hicolor-icon-theme for package: gtk2-2.24.28-8.el7.x86_64
--> Processing Dependency: libXrandr.so.2()(64bit) for package: gtk2-2.24.28-8.el7.x86_64
--> Processing Dependency: libXinerama.so.1()(64bit) for package: gtk2-2.24.28-8.el7.x86_64
--> Processing Dependency: libXi.so.6()(64bit) for package: gtk2-2.24.28-8.el7.x86_64
--> Processing Dependency: libXcursor.so.1()(64bit) for package: gtk2-2.24.28-8.el7.x86_64
--> Processing Dependency: libXcomposite.so.1()(64bit) for package: gtk2-2.24.28-8.el7.x86_64
---> Package libXaw.x86_64 0:1.0.12-5.el7 will be installed
---> Package libXmu.x86_64 0:1.1.2-2.el7 will be installed
---> Package libcgroup.x86_64 0:0.41-11.el7 will be installed
---> Package libsemanage-python.x86_64 0:2.5-4.el7 will be installed
---> Package python-IPy.noarch 0:0.75-6.el7 will be installed
---> Package setools-libs.x86_64 0:3.3.8-1.1.el7 will be installed
--> Running transaction check
---> Package hicolor-icon-theme.noarch 0:0.12-7.el7 will be installed
---> Package libXcomposite.x86_64 0:0.4.4-4.1.el7 will be installed
---> Package libXcursor.x86_64 0:1.1.14-2.1.el7 will be installed
---> Package libXi.x86_64 0:1.7.4-2.el7 will be installed
---> Package libXinerama.x86_64 0:1.1.3-2.1.el7 will be installed
---> Package libXrandr.x86_64 0:1.4.2-2.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

====================================================================================================
 Package                        Arch           Version                        Repository       Size
====================================================================================================
Installing:
 php70-php                      x86_64         7.0.14-1.el7.remi              remi            1.3 M
 php70-php-bcmath               x86_64         7.0.14-1.el7.remi              remi             63 k
 php70-php-cli                  x86_64         7.0.14-1.el7.remi              remi            2.6 M
 php70-php-common               x86_64         7.0.14-1.el7.remi              remi            585 k
 php70-php-devel                x86_64         7.0.14-1.el7.remi              remi            633 k
 php70-php-fpm                  x86_64         7.0.14-1.el7.remi              remi            1.4 M
 php70-php-gd                   x86_64         7.0.14-1.el7.remi              remi             66 k
 php70-php-gmp                  x86_64         7.0.14-1.el7.remi              remi             60 k
 php70-php-intl                 x86_64         7.0.14-1.el7.remi              remi            169 k
 php70-php-mbstring             x86_64         7.0.14-1.el7.remi              remi            524 k
 php70-php-mysqlnd              x86_64         7.0.14-1.el7.remi              remi            171 k
 php70-php-opcache              x86_64         7.0.14-1.el7.remi              remi            120 k
 php70-php-pdo                  x86_64         7.0.14-1.el7.remi              remi            102 k
 php70-php-pear                 noarch         1:1.10.1-7.el7.remi            remi            354 k
 php70-php-pecl-apcu            x86_64         5.1.7-1.el7.remi               remi             70 k
 php70-php-pecl-imagick         x86_64         3.4.3-0.4.RC1.el7.remi         remi            122 k
 php70-php-process              x86_64         7.0.14-1.el7.remi              remi             65 k
 php70-php-xml                  x86_64         7.0.14-1.el7.remi              remi            163 k
Installing for dependencies:
 ImageMagick6-libs              x86_64         6.9.7.3-1.el7.remi             remi            2.2 M
 atk                            x86_64         2.14.0-1.el7                   base            251 k
 audit-libs-python              x86_64         2.6.5-3.el7                    base             70 k
 autoconf                       noarch         2.69-11.el7                    base            701 k
 automake                       noarch         1.13.4-3.el7                   base            679 k
 checkpolicy                    x86_64         2.5-4.el7                      base            290 k
 environment-modules            x86_64         3.2.10-10.el7                  base            107 k
 fftw-libs-double               x86_64         3.3.3-8.el7                    base            759 k
 gd-last                        x86_64         2.2.3-1.el7.remi               remi            131 k
 graphviz                       x86_64         2.30.1-19.el7                  base            1.3 M
 gtk2                           x86_64         2.24.28-8.el7                  base            3.4 M
 hicolor-icon-theme             noarch         0.12-7.el7                     base             42 k
 libXaw                         x86_64         1.0.12-5.el7                   base            190 k
 libXcomposite                  x86_64         0.4.4-4.1.el7                  base             22 k
 libXcursor                     x86_64         1.1.14-2.1.el7                 base             30 k
 libXi                          x86_64         1.7.4-2.el7                    base             40 k
 libXinerama                    x86_64         1.1.3-2.1.el7                  base             14 k
 libXmu                         x86_64         1.1.2-2.el7                    base             71 k
 libXrandr                      x86_64         1.4.2-2.el7                    base             26 k
 libcgroup                      x86_64         0.41-11.el7                    base             65 k
 libicu                         x86_64         50.1.2-15.el7                  base            6.9 M
 libsemanage-python             x86_64         2.5-4.el7                      base            103 k
 libwebp                        x86_64         0.3.0-3.el7                    base            170 k
 pcre-devel                     x86_64         8.32-15.el7_2.1                base            479 k
 perl-Test-Harness              noarch         3.28-3.el7                     base            302 k
 perl-Thread-Queue              noarch         3.02-2.el7                     base             17 k
 php70-php-json                 x86_64         7.0.14-1.el7.remi              remi             56 k
 php70-php-pecl-apcu-bc         x86_64         1.0.3-1.el7.remi               remi             14 k
 php70-runtime                  x86_64         1.0-5.el7.remi                 remi            1.1 M
 policycoreutils-python         x86_64         2.5-9.el7                      updates         444 k
 python-IPy                     noarch         0.75-6.el7                     base             32 k
 scl-utils                      x86_64         20130529-17.el7_1              base             24 k
 setools-libs                   x86_64         3.3.8-1.1.el7                  base            612 k

Transaction Summary
====================================================================================================
Install  18 Packages (+33 Dependent packages)

Total download size: 29 M
Installed size: 96 M
Downloading packages:
(1/51): audit-libs-python-2.6.5-3.el7.x86_64.rpm                             |  70 kB  00:00:00     
(2/51): autoconf-2.69-11.el7.noarch.rpm                                      | 701 kB  00:00:00     
(3/51): atk-2.14.0-1.el7.x86_64.rpm                                          | 251 kB  00:00:00     
(4/51): checkpolicy-2.5-4.el7.x86_64.rpm                                     | 290 kB  00:00:00     
(5/51): automake-1.13.4-3.el7.noarch.rpm                                     | 679 kB  00:00:00     
(6/51): environment-modules-3.2.10-10.el7.x86_64.rpm                         | 107 kB  00:00:00     
(7/51): fftw-libs-double-3.3.3-8.el7.x86_64.rpm                              | 759 kB  00:00:00     
(8/51): gtk2-2.24.28-8.el7.x86_64.rpm                                        | 3.4 MB  00:00:00     
(9/51): hicolor-icon-theme-0.12-7.el7.noarch.rpm                             |  42 kB  00:00:00     
(10/51): libXaw-1.0.12-5.el7.x86_64.rpm                                      | 190 kB  00:00:00     
(11/51): libXcomposite-0.4.4-4.1.el7.x86_64.rpm                              |  22 kB  00:00:00     
(12/51): graphviz-2.30.1-19.el7.x86_64.rpm                                   | 1.3 MB  00:00:00     
(13/51): libXcursor-1.1.14-2.1.el7.x86_64.rpm                                |  30 kB  00:00:00     
(14/51): libXinerama-1.1.3-2.1.el7.x86_64.rpm                                |  14 kB  00:00:00     
(15/51): libXi-1.7.4-2.el7.x86_64.rpm                                        |  40 kB  00:00:00     
(16/51): libXmu-1.1.2-2.el7.x86_64.rpm                                       |  71 kB  00:00:00     
(17/51): libXrandr-1.4.2-2.el7.x86_64.rpm                                    |  26 kB  00:00:00     
(18/51): libcgroup-0.41-11.el7.x86_64.rpm                                    |  65 kB  00:00:00     
(19/51): libsemanage-python-2.5-4.el7.x86_64.rpm                             | 103 kB  00:00:00     
(20/51): libwebp-0.3.0-3.el7.x86_64.rpm                                      | 170 kB  00:00:00     
(21/51): pcre-devel-8.32-15.el7_2.1.x86_64.rpm                               | 479 kB  00:00:00     
(22/51): perl-Test-Harness-3.28-3.el7.noarch.rpm                             | 302 kB  00:00:00     
(23/51): perl-Thread-Queue-3.02-2.el7.noarch.rpm                             |  17 kB  00:00:00     
warning: /var/cache/yum/x86_64/7/remi/packages/gd-last-2.2.3-1.el7.remi.x86_64.rpm: Header V4 DSA/SHA1 Signature, key ID 00e96f52: NOKEY
Public key for gd-last-2.2.3-1.el7.remi.x86_64.rpm is not installed
(24/51): gd-last-2.2.3-1.el7.remi.x86_64.rpm                                 | 131 kB  00:00:00     
(25/51): libicu-50.1.2-15.el7.x86_64.rpm                                     | 6.9 MB  00:00:00     
(26/51): php70-php-bcmath-7.0.14-1.el7.remi.x86_64.rpm                       |  63 kB  00:00:00     
(27/51): php70-php-common-7.0.14-1.el7.remi.x86_64.rpm                       | 585 kB  00:00:00     
(28/51): php70-php-devel-7.0.14-1.el7.remi.x86_64.rpm                        | 633 kB  00:00:00     
(29/51): php70-php-fpm-7.0.14-1.el7.remi.x86_64.rpm                          | 1.4 MB  00:00:00     
(30/51): php70-php-gmp-7.0.14-1.el7.remi.x86_64.rpm                          |  60 kB  00:00:00     
(31/51): php70-php-intl-7.0.14-1.el7.remi.x86_64.rpm                         | 169 kB  00:00:00     
(32/51): php70-php-json-7.0.14-1.el7.remi.x86_64.rpm                         |  56 kB  00:00:00     
(33/51): php70-php-gd-7.0.14-1.el7.remi.x86_64.rpm                           |  66 kB  00:00:00     
(34/51): php70-php-mbstring-7.0.14-1.el7.remi.x86_64.rpm                     | 524 kB  00:00:00     
(35/51): php70-php-opcache-7.0.14-1.el7.remi.x86_64.rpm                      | 120 kB  00:00:00     
(36/51): php70-php-pdo-7.0.14-1.el7.remi.x86_64.rpm                          | 102 kB  00:00:00     
(37/51): php70-php-7.0.14-1.el7.remi.x86_64.rpm                              | 1.3 MB  00:00:01     
(38/51): php70-php-mysqlnd-7.0.14-1.el7.remi.x86_64.rpm                      | 171 kB  00:00:00     
(39/51): php70-php-pecl-apcu-5.1.7-1.el7.remi.x86_64.rpm                     |  70 kB  00:00:00     
(40/51): php70-php-pecl-apcu-bc-1.0.3-1.el7.remi.x86_64.rpm                  |  14 kB  00:00:00     
(41/51): php70-php-pecl-imagick-3.4.3-0.4.RC1.el7.remi.x86_64.rpm            | 122 kB  00:00:00     
(42/51): php70-php-process-7.0.14-1.el7.remi.x86_64.rpm                      |  65 kB  00:00:00     
(43/51): php70-php-xml-7.0.14-1.el7.remi.x86_64.rpm                          | 163 kB  00:00:00     
(44/51): policycoreutils-python-2.5-9.el7.x86_64.rpm                         | 444 kB  00:00:00     
(45/51): python-IPy-0.75-6.el7.noarch.rpm                                    |  32 kB  00:00:00     
(46/51): scl-utils-20130529-17.el7_1.x86_64.rpm                              |  24 kB  00:00:00     
(47/51): setools-libs-3.3.8-1.1.el7.x86_64.rpm                               | 612 kB  00:00:00     
(48/51): php70-php-pear-1.10.1-7.el7.remi.noarch.rpm                         | 354 kB  00:00:00     
(49/51): php70-runtime-1.0-5.el7.remi.x86_64.rpm                             | 1.1 MB  00:00:00     
(50/51): php70-php-cli-7.0.14-1.el7.remi.x86_64.rpm                          | 2.6 MB  00:00:02     
(51/51): ImageMagick6-libs-6.9.7.3-1.el7.remi.x86_64.rpm                     | 2.2 MB  00:00:04     
----------------------------------------------------------------------------------------------------
Total                                                               6.9 MB/s |  29 MB  00:00:04     
Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Importing GPG key 0x00F97F56:
 Userid     : "Remi Collet <RPMS@FamilleCollet.com>"
 Fingerprint: 1ee0 4cce 88a4 ae4a a29a 5df5 004e 6f47 00f9 7f56
 Package    : remi-release-7.2-1.el7.remi.noarch (installed)
 From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-remi
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
Warning: RPMDB altered outside of yum.
  Installing : libwebp-0.3.0-3.el7.x86_64                                                      1/51
  Installing : autoconf-2.69-11.el7.noarch                                                     2/51
  Installing : libXmu-1.1.2-2.el7.x86_64                                                       3/51
  Installing : atk-2.14.0-1.el7.x86_64                                                         4/51
  Installing : libXaw-1.0.12-5.el7.x86_64                                                      5/51
  Installing : gd-last-2.2.3-1.el7.remi.x86_64                                                 6/51
  Installing : setools-libs-3.3.8-1.1.el7.x86_64                                               7/51
  Installing : checkpolicy-2.5-4.el7.x86_64                                                    8/51
  Installing : scl-utils-20130529-17.el7_1.x86_64                                              9/51
  Installing : libcgroup-0.41-11.el7.x86_64                                                   10/51
  Installing : libXi-1.7.4-2.el7.x86_64                                                       11/51
  Installing : libXcursor-1.1.14-2.1.el7.x86_64                                               12/51
  Installing : fftw-libs-double-3.3.3-8.el7.x86_64                                            13/51
  Installing : libXcomposite-0.4.4-4.1.el7.x86_64                                             14/51
  Installing : audit-libs-python-2.6.5-3.el7.x86_64                                           15/51
  Installing : hicolor-icon-theme-0.12-7.el7.noarch                                           16/51
  Installing : python-IPy-0.75-6.el7.noarch                                                   17/51
  Installing : perl-Thread-Queue-3.02-2.el7.noarch                                            18/51
  Installing : perl-Test-Harness-3.28-3.el7.noarch                                            19/51
  Installing : automake-1.13.4-3.el7.noarch                                                   20/51
  Installing : libXrandr-1.4.2-2.el7.x86_64                                                   21/51
  Installing : libsemanage-python-2.5-4.el7.x86_64                                            22/51
  Installing : policycoreutils-python-2.5-9.el7.x86_64                                        23/51
  Installing : pcre-devel-8.32-15.el7_2.1.x86_64                                              24/51
  Installing : environment-modules-3.2.10-10.el7.x86_64                                       25/51
  Installing : php70-runtime-1.0-5.el7.remi.x86_64                                            26/51
  Installing : php70-php-json-7.0.14-1.el7.remi.x86_64                                        27/51
  Installing : php70-php-common-7.0.14-1.el7.remi.x86_64                                      28/51
  Installing : php70-php-cli-7.0.14-1.el7.remi.x86_64                                         29/51
  Installing : php70-php-pecl-apcu-bc-1.0.3-1.el7.remi.x86_64                                 30/51
  Installing : php70-php-pecl-apcu-5.1.7-1.el7.remi.x86_64                                    31/51
  Installing : php70-php-xml-7.0.14-1.el7.remi.x86_64                                         32/51
  Installing : php70-php-process-7.0.14-1.el7.remi.x86_64                                     33/51
  Installing : php70-php-pdo-7.0.14-1.el7.remi.x86_64                                         34/51
  Installing : libXinerama-1.1.3-2.1.el7.x86_64                                               35/51
  Installing : gtk2-2.24.28-8.el7.x86_64                                                      36/51
  Installing : graphviz-2.30.1-19.el7.x86_64                                                  37/51
  Installing : ImageMagick6-libs-6.9.7.3-1.el7.remi.x86_64                                    38/51
  Installing : libicu-50.1.2-15.el7.x86_64                                                    39/51
  Installing : php70-php-intl-7.0.14-1.el7.remi.x86_64                                        40/51
  Installing : php70-php-pecl-imagick-3.4.3-0.4.RC1.el7.remi.x86_64                           41/51
  Installing : php70-php-mysqlnd-7.0.14-1.el7.remi.x86_64                                     42/51
  Installing : 1:php70-php-pear-1.10.1-7.el7.remi.noarch                                      43/51
  Installing : php70-php-7.0.14-1.el7.remi.x86_64                                             44/51
  Installing : php70-php-devel-7.0.14-1.el7.remi.x86_64                                       45/51
  Installing : php70-php-opcache-7.0.14-1.el7.remi.x86_64                                     46/51
  Installing : php70-php-fpm-7.0.14-1.el7.remi.x86_64                                         47/51
  Installing : php70-php-gd-7.0.14-1.el7.remi.x86_64                                          48/51
  Installing : php70-php-bcmath-7.0.14-1.el7.remi.x86_64                                      49/51
  Installing : php70-php-gmp-7.0.14-1.el7.remi.x86_64                                         50/51
  Installing : php70-php-mbstring-7.0.14-1.el7.remi.x86_64                                    51/51
  Verifying  : graphviz-2.30.1-19.el7.x86_64                                                   1/51
  Verifying  : libicu-50.1.2-15.el7.x86_64                                                     2/51
  Verifying  : php70-php-pecl-apcu-5.1.7-1.el7.remi.x86_64                                     3/51
  Verifying  : libXinerama-1.1.3-2.1.el7.x86_64                                                4/51
  Verifying  : php70-php-mysqlnd-7.0.14-1.el7.remi.x86_64                                      5/51
  Verifying  : environment-modules-3.2.10-10.el7.x86_64                                        6/51
  Verifying  : php70-php-opcache-7.0.14-1.el7.remi.x86_64                                      7/51
  Verifying  : pcre-devel-8.32-15.el7_2.1.x86_64                                               8/51
  Verifying  : automake-1.13.4-3.el7.noarch                                                    9/51
  Verifying  : libXaw-1.0.12-5.el7.x86_64                                                     10/51
  Verifying  : libsemanage-python-2.5-4.el7.x86_64                                            11/51
  Verifying  : php70-runtime-1.0-5.el7.remi.x86_64                                            12/51
  Verifying  : policycoreutils-python-2.5-9.el7.x86_64                                        13/51
  Verifying  : php70-php-fpm-7.0.14-1.el7.remi.x86_64                                         14/51
  Verifying  : libXrandr-1.4.2-2.el7.x86_64                                                   15/51
  Verifying  : php70-php-intl-7.0.14-1.el7.remi.x86_64                                        16/51
  Verifying  : php70-php-gd-7.0.14-1.el7.remi.x86_64                                          17/51
  Verifying  : perl-Test-Harness-3.28-3.el7.noarch                                            18/51
  Verifying  : php70-php-bcmath-7.0.14-1.el7.remi.x86_64                                      19/51
  Verifying  : perl-Thread-Queue-3.02-2.el7.noarch                                            20/51
  Verifying  : php70-php-xml-7.0.14-1.el7.remi.x86_64                                         21/51
  Verifying  : python-IPy-0.75-6.el7.noarch                                                   22/51
  Verifying  : atk-2.14.0-1.el7.x86_64                                                        23/51
  Verifying  : php70-php-pecl-imagick-3.4.3-0.4.RC1.el7.remi.x86_64                           24/51
  Verifying  : php70-php-gmp-7.0.14-1.el7.remi.x86_64                                         25/51
  Verifying  : php70-php-7.0.14-1.el7.remi.x86_64                                             26/51
  Verifying  : php70-php-process-7.0.14-1.el7.remi.x86_64                                     27/51
  Verifying  : hicolor-icon-theme-0.12-7.el7.noarch                                           28/51
  Verifying  : php70-php-devel-7.0.14-1.el7.remi.x86_64                                       29/51
  Verifying  : php70-php-pdo-7.0.14-1.el7.remi.x86_64                                         30/51
  Verifying  : audit-libs-python-2.6.5-3.el7.x86_64                                           31/51
  Verifying  : php70-php-json-7.0.14-1.el7.remi.x86_64                                        32/51
  Verifying  : gd-last-2.2.3-1.el7.remi.x86_64                                                33/51
  Verifying  : libXmu-1.1.2-2.el7.x86_64                                                      34/51
  Verifying  : libXcomposite-0.4.4-4.1.el7.x86_64                                             35/51
  Verifying  : gtk2-2.24.28-8.el7.x86_64                                                      36/51
  Verifying  : fftw-libs-double-3.3.3-8.el7.x86_64                                            37/51
  Verifying  : 1:php70-php-pear-1.10.1-7.el7.remi.noarch                                      38/51
  Verifying  : libXcursor-1.1.14-2.1.el7.x86_64                                               39/51
  Verifying  : libXi-1.7.4-2.el7.x86_64                                                       40/51
  Verifying  : autoconf-2.69-11.el7.noarch                                                    41/51
  Verifying  : php70-php-mbstring-7.0.14-1.el7.remi.x86_64                                    42/51
  Verifying  : php70-php-cli-7.0.14-1.el7.remi.x86_64                                         43/51
  Verifying  : php70-php-common-7.0.14-1.el7.remi.x86_64                                      44/51
  Verifying  : ImageMagick6-libs-6.9.7.3-1.el7.remi.x86_64                                    45/51
  Verifying  : libcgroup-0.41-11.el7.x86_64                                                   46/51
  Verifying  : php70-php-pecl-apcu-bc-1.0.3-1.el7.remi.x86_64                                 47/51
  Verifying  : scl-utils-20130529-17.el7_1.x86_64                                             48/51
  Verifying  : checkpolicy-2.5-4.el7.x86_64                                                   49/51
  Verifying  : libwebp-0.3.0-3.el7.x86_64                                                     50/51
  Verifying  : setools-libs-3.3.8-1.1.el7.x86_64                                              51/51

Installed:
  php70-php.x86_64 0:7.0.14-1.el7.remi                                                             
  php70-php-bcmath.x86_64 0:7.0.14-1.el7.remi                                                       
  php70-php-cli.x86_64 0:7.0.14-1.el7.remi                                                         
  php70-php-common.x86_64 0:7.0.14-1.el7.remi                                                       
  php70-php-devel.x86_64 0:7.0.14-1.el7.remi                                                       
  php70-php-fpm.x86_64 0:7.0.14-1.el7.remi                                                         
  php70-php-gd.x86_64 0:7.0.14-1.el7.remi                                                           
  php70-php-gmp.x86_64 0:7.0.14-1.el7.remi                                                         
  php70-php-intl.x86_64 0:7.0.14-1.el7.remi                                                         
  php70-php-mbstring.x86_64 0:7.0.14-1.el7.remi                                                     
  php70-php-mysqlnd.x86_64 0:7.0.14-1.el7.remi                                                     
  php70-php-opcache.x86_64 0:7.0.14-1.el7.remi                                                     
  php70-php-pdo.x86_64 0:7.0.14-1.el7.remi                                                         
  php70-php-pear.noarch 1:1.10.1-7.el7.remi                                                         
  php70-php-pecl-apcu.x86_64 0:5.1.7-1.el7.remi                                                     
  php70-php-pecl-imagick.x86_64 0:3.4.3-0.4.RC1.el7.remi                                           
  php70-php-process.x86_64 0:7.0.14-1.el7.remi                                                     
  php70-php-xml.x86_64 0:7.0.14-1.el7.remi                                                         

Dependency Installed:
  ImageMagick6-libs.x86_64 0:6.9.7.3-1.el7.remi   atk.x86_64 0:2.14.0-1.el7                         
  audit-libs-python.x86_64 0:2.6.5-3.el7          autoconf.noarch 0:2.69-11.el7                     
  automake.noarch 0:1.13.4-3.el7                  checkpolicy.x86_64 0:2.5-4.el7                   
  environment-modules.x86_64 0:3.2.10-10.el7      fftw-libs-double.x86_64 0:3.3.3-8.el7             
  gd-last.x86_64 0:2.2.3-1.el7.remi               graphviz.x86_64 0:2.30.1-19.el7                   
  gtk2.x86_64 0:2.24.28-8.el7                     hicolor-icon-theme.noarch 0:0.12-7.el7           
  libXaw.x86_64 0:1.0.12-5.el7                    libXcomposite.x86_64 0:0.4.4-4.1.el7             
  libXcursor.x86_64 0:1.1.14-2.1.el7              libXi.x86_64 0:1.7.4-2.el7                       
  libXinerama.x86_64 0:1.1.3-2.1.el7              libXmu.x86_64 0:1.1.2-2.el7                       
  libXrandr.x86_64 0:1.4.2-2.el7                  libcgroup.x86_64 0:0.41-11.el7                   
  libicu.x86_64 0:50.1.2-15.el7                   libsemanage-python.x86_64 0:2.5-4.el7             
  libwebp.x86_64 0:0.3.0-3.el7                    pcre-devel.x86_64 0:8.32-15.el7_2.1               
  perl-Test-Harness.noarch 0:3.28-3.el7           perl-Thread-Queue.noarch 0:3.02-2.el7             
  php70-php-json.x86_64 0:7.0.14-1.el7.remi       php70-php-pecl-apcu-bc.x86_64 0:1.0.3-1.el7.remi 
  php70-runtime.x86_64 0:1.0-5.el7.remi           policycoreutils-python.x86_64 0:2.5-9.el7         
  python-IPy.noarch 0:0.75-6.el7                  scl-utils.x86_64 0:20130529-17.el7_1             
  setools-libs.x86_64 0:3.3.8-1.1.el7 



The script is not built to be modified as certain parts of the script modify code to Exim, Dovecot, and SpamAssassin. You also enabled "iptables" when CSF is installed by this script so it doesn't need "iptables".

You need to focus on these errors:

Code: Select all

Jan 11 09:31:46 server.host.com nginx[3251]: nginx: [emerg] bind() to XXX.XX.XXX.XXX:80 failed (98: Address already in use)
Jan 11 09:31:47 server.host nginx[3251]: nginx: [emerg] bind() to XXX.XX.XXX.XXX:80 failed (98: Address already in use)
Jan 11 09:31:47 server.host nginx[3251]: nginx: [emerg] bind() to XXX.XX.XXX.XXX:80 failed (98: Address already in use)
Jan 11 09:31:48 server.host nginx[3251]: nginx: [emerg] bind() to XXX.XX.XXX.XXX:80 failed (98: Address already in use)
Jan 11 09:31:48 server.host nginx[3251]: nginx: [emerg] bind() to XXX.XX.XXX.XXX:80 failed (98: Address already in use)


but I can't help you because you've made a custom install.

desolator
Posts: 4
Joined: Wed Jan 11, 2017 8:42 am

Re: HOWTO: Install PHP7 on CentOS 7

Postby desolator » Wed Jan 11, 2017 3:23 pm

The script is not built to be modified as certain parts of the script modify code to Exim, Dovecot, and SpamAssassin. You also enabled "iptables" when CSF is installed by this script so it doesn't need "iptables".

You need to focus on these errors:

Code: Select all

Jan 11 09:31:46 server.host.com nginx[3251]: nginx: [emerg] bind() to XXX.XX.XXX.XXX:80 failed (98: Address already in use)
Jan 11 09:31:47 server.host nginx[3251]: nginx: [emerg] bind() to XXX.XX.XXX.XXX:80 failed (98: Address already in use)
Jan 11 09:31:47 server.host nginx[3251]: nginx: [emerg] bind() to XXX.XX.XXX.XXX:80 failed (98: Address already in use)
Jan 11 09:31:48 server.host nginx[3251]: nginx: [emerg] bind() to XXX.XX.XXX.XXX:80 failed (98: Address already in use)
Jan 11 09:31:48 server.host nginx[3251]: nginx: [emerg] bind() to XXX.XX.XXX.XXX:80 failed (98: Address already in use)


but I can't help you because you've made a custom install.




Thank you i will try to find the solution-if anyone has any input please pm

desolator
Posts: 4
Joined: Wed Jan 11, 2017 8:42 am

Re: HOWTO: Install PHP7 on CentOS 7

Postby desolator » Wed Jan 18, 2017 6:42 pm

Can you please post the script you used for the installation before the php7 update procedure

Thank you

joem
Posts: 373
Joined: Thu Nov 13, 2014 8:33 am
Location: New York
Contact:

Re: HOWTO: Install PHP7 on CentOS 7

Postby joem » Thu Jan 19, 2017 12:28 am

desolator wrote:
The script is not built to be modified as certain parts of the script modify code to Exim, Dovecot, and SpamAssassin. You also enabled "iptables" when CSF is installed by this script so it doesn't need "iptables".

You need to focus on these errors:

Code: Select all

Jan 11 09:31:46 server.host.com nginx[3251]: nginx: [emerg] bind() to XXX.XX.XXX.XXX:80 failed (98: Address already in use)
Jan 11 09:31:47 server.host nginx[3251]: nginx: [emerg] bind() to XXX.XX.XXX.XXX:80 failed (98: Address already in use)
Jan 11 09:31:47 server.host nginx[3251]: nginx: [emerg] bind() to XXX.XX.XXX.XXX:80 failed (98: Address already in use)
Jan 11 09:31:48 server.host nginx[3251]: nginx: [emerg] bind() to XXX.XX.XXX.XXX:80 failed (98: Address already in use)
Jan 11 09:31:48 server.host nginx[3251]: nginx: [emerg] bind() to XXX.XX.XXX.XXX:80 failed (98: Address already in use)


but I can't help you because you've made a custom install.




Thank you i will try to find the solution-if anyone has any input please pm


I have these errors in centos7 without updating to php7 just using the basic vesta installation. I think this is a vesta bug.

mariad
Posts: 28
Joined: Fri Feb 17, 2017 5:34 am

Re: HOWTO: Install PHP7 on CentOS 7

Postby mariad » Tue Feb 28, 2017 7:53 am

Thanks for the guide.

SS88
Posts: 298
Joined: Thu Nov 19, 2015 12:40 pm

Re: HOWTO: Install PHP7 on CentOS 7

Postby SS88 » Tue Feb 28, 2017 11:02 am

desolator wrote:Can you please post the script you used for the installation before the php7 update procedure

Thank you


Hi,

You have the option to not install PHP7 during the installation.

ServerHost
Posts: 15
Joined: Fri May 05, 2017 12:18 am

Re: HOWTO: Install PHP7 on CentOS 7

Postby ServerHost » Tue May 23, 2017 1:14 am

I followed the tutorial

PHP 7 worked perfectly, but vesta does not find. See https://prnt.sc/fayyk4
How do I make the dashboard work with php 7?

sifur
Posts: 24
Joined: Mon Dec 28, 2015 10:43 pm

Re: HOWTO: Install PHP7 on CentOS 7

Postby sifur » Wed Jun 07, 2017 9:03 pm

Hi, after installing this, I'm getting PHP warning,

Code: Select all

PHP Warning:  Zend OPcache huge_code_pages: madvise(HUGEPAGE) failed: Invalid argument (22) in Unknown on line 0
PHP 7.0.20 (cli) (built: Jun  7 2017 06:56:00) ( NTS )
Copyright (c) 1997-2017 The PHP Group
Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies
    with Zend OPcache v7.0.20, Copyright (c) 1999-2017, by Zend Technologies


Is it OK please?

mariad
Posts: 28
Joined: Fri Feb 17, 2017 5:34 am

Re: HOWTO: Install PHP7 on CentOS 7

Postby mariad » Fri Jun 16, 2017 12:00 pm

ServerHost wrote:I followed the tutorial

PHP 7 worked perfectly, but vesta does not find. See https://prnt.sc/fayyk4
How do I make the dashboard work with php 7?


You mean it is not synced together.

KuJoe
Posts: 8
Joined: Wed Mar 04, 2015 11:51 am

Re: HOWTO: Install PHP7 on CentOS 7

Postby KuJoe » Sun Aug 06, 2017 12:55 pm

For those interested in getting RoundCube working with PHP 7 in CentOS 7 here you go:

Remove all traces of PHP 5.x (including RoundCube):

Code: Select all

yum remove php


Now install PHP 7.0 using the code in the first post (also follow all of the steps in the first post, this is just here for completeness sake):

Code: Select all

yum -y --enablerepo=remi install php70 php70-php php70-php-pear php70-php-bcmath php70-php-pecl-jsond-devel php70-php-mysqlnd php70-php-gd php70-php-common php70-php-fpm php70-php-intl php70-php-cli php70-php php70-php-xml php70-php-opcache php70-php-pecl-apcu php70-php-pecl-jsond php70-php-pdo php70-php-gmp php70-php-process php70-php-pecl-imagick php70-php-devel php70-php-mbstring


Now download the latest version of the RoundCube RPM (as of this post):

Code: Select all

wget ftp://195.220.108.108/linux/remi/enterprise/7/test/x86_64/roundcubemail-1.3.0-2.el7.remi.noarch.rpm


Now install RoundCube:

Code: Select all

rpm -i --nodeps roundcubemail-1.3.0-2.el7.remi.noarch.rpm


Run these commands (the version in the URLs will most likely change so make sure it matches the current version of VestaCP):

Code: Select all

wget c.vestacp.com/0.9.8/rhel/httpd-webmail.conf -O /etc/httpd/conf.d/roundcubemail.conf
wget c.vestacp.com/0.9.8/rhel/roundcube-main.conf -O /etc/roundcubemail/main.inc.php
wget c.vestacp.com/0.9.8/rhel/roundcube-db.conf -O /etc/roundcubemail/db.inc.php
wget c.vestacp.com/0.9.8/rhel/roundcube-driver.php -O  /usr/share/roundcubemail/plugins/password/drivers/vesta.php
wget c.vestacp.com/0.9.8/rhel/roundcube-pw.conf -O /usr/share/roundcubemail/plugins/password/config.inc.php
chmod a+r /etc/roundcubemail/*


Now just restart Apache and nginx (not sure if both are needed but it can't hurt):

Code: Select all

service httpd restart;service nginx restart


And RoundCube is working again. Enjoy! :D


Return to “Web Server”



Who is online

Users browsing this forum: No registered users and 7 guests

cron