500 Internal Server Error, Websites/Vestacp works, all /phpmyadmin /webmail etc don't

Questions regarding the Web Server
Apache + Nginx, Nginx + PHP5-FPM
StopSpazzing
Posts: 7
Joined: Sun Nov 12, 2017 6:18 am

500 Internal Server Error, Websites/Vestacp works, all /phpmyadmin /webmail etc don't

Postby StopSpazzing » Sun Nov 12, 2017 6:35 am

Having issue with blank pages. There are no errors in Apache config syntax. None of the /phpmyadmin /webmail etc work and all return 500 errors. I also have weird issue of mail not working unknown if it related. I'm going to provide as much upfront info as possible to get this resolved as fast as possible.

Code: Select all

root@vps1:~# php -v
PHP 7.1.11-1+ubuntu16.04.1+deb.sury.org+1 (cli) (built: Oct 27 2017 13:49:56) ( NTS )
Copyright (c) 1997-2017 The PHP Group
Zend Engine v3.1.0, Copyright (c) 1998-2017 Zend Technologies
    with Zend OPcache v7.1.11-1+ubuntu16.04.1+deb.sury.org+1, Copyright (c) 1999-2017, by Zend Technologies
root@vps1:~#


Code: Select all

root@vps1:~# apache2 -v
Server version: Apache/2.4.18 (Ubuntu)
Server built:   2017-09-18T15:09:02


Code: Select all

root@vps1:~# nginx -v
nginx version: nginx/1.13.6


Code: Select all

Vesta package 0.9.8 (amd64)   
Release:17


Code: Select all

root@vps1:~# apachectl configtest
Syntax OK


Code: Select all

netstat -tulpn | grep apache

    root@vps1:~# netstat -tulpn | grep apache
    tcp 0 0 serverip:8443 0.0.0.0:* LISTEN 20500/apache2
    tcp 0 0 serverip:8080 0.0.0.0:* LISTEN 20500/apache2
    tcp 0 0 127.0.0.1:8081 0.0.0.0:* LISTEN 20500/apache2

Code: Select all

netstat -tulpn | grep nginx

    root@vps1:~# netstat -tulpn | grep nginx
    tcp 0 0 serverip:443 0.0.0.0:* LISTEN 20524/nginx.conf
    tcp 0 0 serverip:80 0.0.0.0:* LISTEN 20524/nginx.conf
    tcp 0 0 0.0.0.0:8083 0.0.0.0:* LISTEN 1090/vesta-nginx
    tcp 0 0 127.0.0.1:8084 0.0.0.0:* LISTEN 20524/nginx.conf

Other weird issue I am unsure if it's related is if I changed nginx from default to cache proxy, creates duplicate entries in vestacp's nginx proxy config file and this causes nginx to fail, after remove dupe, starts without issue.

Also, might as well add this:
Image
I have latest updated Vestacp, yet the word "dayly" is spelled incorrect, I found where it would be in source and is fixed. So my question is why hasn't this been updated on my end?

StopSpazzing
Posts: 7
Joined: Sun Nov 12, 2017 6:18 am

Re: 500 Internal Server Error, Websites/Vestacp works, all /phpmyadmin /webmail etc don't

Postby StopSpazzing » Tue Nov 14, 2017 6:08 am

So found a solution. I reinstall ubuntu on my VPS and starting from scratch. Not installing apache2 ever again, nginx+php-fpm only.


Return to “Web Server”



Who is online

Users browsing this forum: No registered users and 4 guests

cron