Page 1 of 1

DNS Server not responding

Posted: Fri Jan 29, 2016 2:04 pm
by Theophilos
Hi! I want to use vanity nameservers on my self hosted server, but I'm spinning in circles for two days now.
I did the following:
- On godaddy, I created host names (ns1, ns2), both pointing to my ip.
- I set custom nameservers (the ones created earlier) ns1.mydomain.tld, ns2.mydomain.tld
On my server, I installed Ubuntu 14 and VestaCP. I used mydomain.tld as the host name.
For the mydomain.tld, in DNS, I changed the Bind9 Template to "child-ns" and
used ns1.mydomain.com under SOA.
I created 2 A records for ns1 and ns2, pointing to my ip.
I updated @ NS records to ns1.mydomain.tld and ns2.mydomain.tld
I added rule in Firewall for TCP port 53 (default is only UDP, but port checkers showed me the port is closed).
I also updated the "default" package with the newly configured ns1 and ns2.mydomain.tld

Still, it doesn't work. IntoDNS says:

Mismatched NS records WARNING: One or more of your nameservers did not return any of your NS records.
Error DNS servers responded ERROR: One or more of your nameservers did not respond: The ones that did not respond are: x.x.x.x (my ip)

Any ideas?

Re: DNS Server not responding

Posted: Mon Feb 01, 2016 10:36 am
by Elizine
Please refer to the tutorial link below -
http://www.wikihow.com/Fix-DNS-Server-N ... ng-Problem

Re: DNS Server not responding

Posted: Mon Feb 01, 2016 12:05 pm
by valentinalisch
I'm having the same problem here.
I reinstalled Vesta last night and since then the nameservers aren't working anymore.

THIS IS NOT A COMPUTER RELATED PROBLEM.

Re: DNS Server not responding  Topic is solved

Posted: Mon Feb 01, 2016 11:46 pm
by varmedia
Hi Guys,

I had the same problem, I almost lost my entire day today to figure out the problems (I never had a BIND issue before). Finally by consulting /var/log/syslog I find out that there was a permission error on the DBs files ... Probably an BIND update/version on the latest VestaCP Update ...

I found this source:
http://askubuntu.com/questions/172030/h ... -app-armor

So basically:

1. Edit /etc/apparmor.d/local/usr.sbin.named

Code: Select all

vim /etc/apparmor.d/local/usr.sbin.named


2. Add every DB file (can be found in /etc/bind/named.conf ) with an rw comma separated

3. sudo apparmor_parser -r /etc/apparmor.d/usr.sbin.named

Code: Select all

apparmor_parser -r /etc/apparmor.d/usr.sbin.named


4. restart bind (service bind9 restart)

Code: Select all

service bind9 restart


5. Test with dig

Code: Select all

dig domain.com @127.0.0.1


Hope it will help some of you.

Re: DNS Server not responding

Posted: Tue Feb 02, 2016 11:44 am
by valentinalisch
This one works! Thanks a lot — hopefully it's going to be fixed soon though.

Re: DNS Server not responding

Posted: Wed Feb 03, 2016 12:23 am
by Theophilos
varmedia wrote:Hi Guys,
I found this source:
http://askubuntu.com/questions/172030/h ... -app-armor

Thank you very much for your help. I was not able to solve it this way, but I managed by putting apparmour in complain mode for bind.
On a fresh install, before adding domains, I used:

Code: Select all

sudo apt-get install apparmor-utils
sudo aa-complain usr.sbin.named
sudo /etc/init.d/apparmor stop
sudo /etc/init.d/apparmor start
service bind9 restart


And now it's working! I know I shouldn't disable AppArmour, but I hope in the next Vesta update, this problem won't come up.
Thanks again, @varmedia, for putting me on the right track!

Re: DNS Server not responding

Posted: Wed Aug 17, 2016 6:00 pm
by sacredwebsite
varmedia wrote:Hi Guys,

I had the same problem, I almost lost my entire day today to figure out the problems (I never had a BIND issue before). Finally by consulting /var/log/syslog I find out that there was a permission error on the DBs files ... Probably an BIND update/version on the latest VestaCP Update ...

I found this source:
http://askubuntu.com/questions/172030/h ... -app-armor

So basically:

1. Edit /etc/apparmor.d/local/usr.sbin.named

Code: Select all

vim /etc/apparmor.d/local/usr.sbin.named


2. Add every DB file (can be found in /etc/bind/named.conf ) with an rw comma separated

3. sudo apparmor_parser -r /etc/apparmor.d/usr.sbin.named

Code: Select all

apparmor_parser -r /etc/apparmor.d/usr.sbin.named


4. restart bind (service bind9 restart)

Code: Select all

service bind9 restart


5. Test with dig

Code: Select all

dig domain.com @127.0.0.1


Hope it will help some of you.


Thank you for sharing this, seems that when I add the profile db to the apparmor file I am able to resolve on localhost.
My question is why is this not automatically being resolved in Vesta? is this a bug or as expected? I would like to resolve this so that adding new domains to dns does not need manual configuration.

Re: DNS Server not responding

Posted: Sun Aug 06, 2017 9:12 am
by needyamin
Hello,
There is everything ok. then why my domain isn't loaded http://prntscr.com/g4yyjj