named dns server not start

Questions regarding the DNS Server
BIND
kablakar
Posts: 10
Joined: Sun Mar 01, 2015 6:16 pm

named dns server not start

Postby kablakar » Fri May 29, 2015 8:32 pm

today unexpectedly the named dns server not start never, when try to start show error :

if send this command :

Code: Select all

service named status


show this error:

Code: Select all

rndc: connect failed: 127.0.0.1#953: connection refused


if try to start with this command :

Code: Select all

# service named start


show this ( the "++++++" is my domain"):

Code: Select all

service named start
Avvio di named:
Error in named configuration:
zone default.domain/IN: loaded serial 2015052901
zone +++++++++++/IN: has no NS records
zone ++++++++++++/IN: not loaded due to errors.
_default/+++++++++++++/IN: bad zone
zone ++++++++/IN: has no NS records
zone +++++++++++/IN: not loaded due to errors.
_default/++++++++++++/IN: bad zone
zone ++++++++++++++++/IN: has no NS records
zone +++++++++++++++/IN: not loaded due to errors.
_default/+++++++++++/IN: bad zone
zone ++++++++++++++++++/IN: has no NS records
zone ++++++++++++++++++/IN: not loaded due to errors.
_default/+++++++++++++++++++/IN: bad zone
zone ++++++++++++++++++/IN: has no NS records
zone ++++++++++++++++/IN: not loaded due to errors.
_default/++++++++++++++/IN: bad zone
zone ++++++++++++++/IN: loaded serial 2015052901
zone +++++++++++++++/IN: loaded serial 2015052901
zone ++++++++++++/IN: loaded serial 2015052901
                                                           [FALLITO]



how solve ?

skurudo
VestaCP Team
Posts: 7791
Joined: Fri Dec 26, 2014 2:23 pm
Location: Moscow
Contact:

Re: named dns server not start

Postby skurudo » Mon Jun 01, 2015 1:49 pm

chown root:named /etc/rndc.key
chmod 640 /etc/rndc.key

service named restart

zorrobyte
Posts: 7
Joined: Sun Apr 26, 2015 2:34 pm

Re: named dns server not start

Postby zorrobyte » Tue Jun 09, 2015 3:28 pm

Same issue on CentOS 6.6 fresh install.

Installer complains about bind-9 already being installed, going to manually remove from fresh install and try installing VestaCP again

skurudo
VestaCP Team
Posts: 7791
Joined: Fri Dec 26, 2014 2:23 pm
Location: Moscow
Contact:

Re: named dns server not start

Postby skurudo » Tue Jun 09, 2015 6:35 pm

zorrobyte wrote:Same issue on CentOS 6.6 fresh install. Installer complains about bind-9 already being installed, going to manually remove from fresh install and try installing VestaCP again


Nope, this not the same issue. Your may thank your hosting provider for not clean OS from template. It's recommended - install on clean OS withouts other software, all needed soft VestaCP install from repo.

joem
Posts: 373
Joined: Thu Nov 13, 2014 8:33 am
Location: New York
Contact:

Re: named dns server not start

Postby joem » Wed Jun 10, 2015 9:03 am

zorrobyte wrote:Same issue on CentOS 6.6 fresh install.

Installer complains about bind-9 already being installed, going to manually remove from fresh install and try installing VestaCP again


I find this works best when installing Vesta on CentOS

Code: Select all

  yum remove httpd* bind* -y
  yum clean all
  curl -O http://vestacp.com/pub/vst-install.sh
  bash vst-install.sh

EbertonMoraes
Posts: 2
Joined: Wed Nov 09, 2016 11:43 am

Re: named dns server not start

Postby EbertonMoraes » Mon Mar 27, 2017 5:45 pm

Hello, i have exactly the same problem of the topic... Exactly same errors.

Tryied change permissions:
chown root:named /etc/rndc.key
chmod 640 /etc/rndc.key

service named restart


But not works, still having problem... Can help me with that?

fwddev
Posts: 3
Joined: Mon Mar 27, 2017 8:10 pm

Re: named dns server not start

Postby fwddev » Mon Mar 27, 2017 8:16 pm

I'm having the same problem after an auto update that took place over the weekend.
Looks like I'm on version 0.9.8 release 17 for vesta, vesta-php and vesta-nginx.

I made sure the permissions were the same ad mentioned earlier and have rebooted with no dice.

How do I get the Named Service up and Running?

# status named.service
Redirecting to /bin/systemctl status named.service
● named.service - Berkeley Internet Name Domain (DNS)
Loaded: loaded (/usr/lib/systemd/system/named.service; enabled; vendor preset: disabled)
Active: failed (Result: exit-code) since Mon 2017-03-27 15:40:03 EDT; 34min ago
Process: 9679 ExecStartPre=/bin/bash -c if [ ! "$DISABLE_ZONE_CHECKING" == "yes" ]; then /usr/sbin/named-checkconf -z /etc/named.conf; else echo "Checking of zone files is disabled"; fi (code=exited, status=1/FAILURE)

fwddev
Posts: 3
Joined: Mon Mar 27, 2017 8:10 pm

Re: named dns server not start

Postby fwddev » Tue Mar 28, 2017 1:49 pm

I have restored my main.sh and rebuilt my DNS with no change.

My Site works but admin functions are VERY slow and SSHing into the server takes forever.

Any way to get this named DNS service to start?

All this happened after an auto update that happened over the weekend since then I have turned off auto updates as I do not need the extra unplanned headache.


Return to “DNS Server”



Who is online

Users browsing this forum: No registered users and 4 guests

cron