We are starting CHRISTMAS Sale. Get 30% OFF on lifetime licenses with code: FYSKK72

The phpMyAdmin configuration storage is not completely configured Topic is solved

Questions regarding the Database Server
MySQL, PostgreSQL, MariaDB, Percona Server, phpMyAdmin, phpPgAdmin
khampol
Posts: 10
Joined: Sat Jul 30, 2016 7:57 am

The phpMyAdmin configuration storage is not completely configured

Postby khampol » Wed Oct 12, 2016 8:17 am

VestaCP, you have some strange symptom..... :-/ :-/ :-/ ......
ps : frankly, i use also sentora and NEVER get this.... Disturbing.... .....

dpeca
Collaborator
Posts: 239
Joined: Wed Nov 25, 2015 7:30 pm
Location: Serbia

Re: The phpMyAdmin configuration storage is not completely configured  Topic is solved

Postby dpeca » Wed Oct 12, 2016 10:55 am

What linux distribution you are using?

khampol
Posts: 10
Joined: Sat Jul 30, 2016 7:57 am

Re: The phpMyAdmin configuration storage is not completely configured

Postby khampol » Wed Oct 12, 2016 11:11 am

dpeca wrote:What linux distribution you are using?


I use ubuntu server 14.04

dpeca
Collaborator
Posts: 239
Joined: Wed Nov 25, 2015 7:30 pm
Location: Serbia

Re: The phpMyAdmin configuration storage is not completely configured

Postby dpeca » Wed Oct 12, 2016 11:24 am

Hmmm, not sure how to fix it on Ubuntu, but here is how I'm fixing this on Debian:
(maybe the same command works)

Open file /etc/phpmyadmin/config.inc.php
FIND

Code: Select all

    /* Optional: Advanced phpMyAdmin features */
    $cfg['Servers'][$i]['pmadb'] = $dbname;
    $cfg['Servers'][$i]['bookmarktable'] = 'pma_bookmark';
    $cfg['Servers'][$i]['relation'] = 'pma_relation';
    $cfg['Servers'][$i]['table_info'] = 'pma_table_info';
    $cfg['Servers'][$i]['table_coords'] = 'pma_table_coords';
    $cfg['Servers'][$i]['pdf_pages'] = 'pma_pdf_pages';
    $cfg['Servers'][$i]['column_info'] = 'pma_column_info';
    $cfg['Servers'][$i]['history'] = 'pma_history';
    $cfg['Servers'][$i]['table_uiprefs'] = 'pma_table_uiprefs';
    $cfg['Servers'][$i]['designer_coords'] = 'pma_designer_coords';
    $cfg['Servers'][$i]['tracking'] = 'pma_tracking';
    $cfg['Servers'][$i]['userconfig'] = 'pma_userconfig';
    $cfg['Servers'][$i]['recent'] = 'pma_recent';

REPLACE TO

Code: Select all

    /* Optional: Advanced phpMyAdmin features */
    $cfg['Servers'][$i]['pmadb'] = $dbname;
    $cfg['Servers'][$i]['bookmarktable'] = 'pma__bookmark';
    $cfg['Servers'][$i]['relation'] = 'pma__relation';
    $cfg['Servers'][$i]['table_info'] = 'pma__table_info';
    $cfg['Servers'][$i]['table_coords'] = 'pma__table_coords';
    $cfg['Servers'][$i]['pdf_pages'] = 'pma__pdf_pages';
    $cfg['Servers'][$i]['column_info'] = 'pma__column_info';
    $cfg['Servers'][$i]['history'] = 'pma__history';
    $cfg['Servers'][$i]['table_uiprefs'] = 'pma__table_uiprefs';
    $cfg['Servers'][$i]['designer_coords'] = 'pma__designer_coords';
    $cfg['Servers'][$i]['tracking'] = 'pma__tracking';
    $cfg['Servers'][$i]['userconfig'] = 'pma__userconfig';
    $cfg['Servers'][$i]['recent'] = 'pma__recent';
    $cfg['Servers'][$i]['users'] = 'pma__users';
    $cfg['Servers'][$i]['usergroups'] = 'pma__usergroups';
    $cfg['Servers'][$i]['navigationhiding'] = 'pma__navigationhiding';
    $cfg['Servers'][$i]['savedsearches'] = 'pma__savedsearches';


In SSH (as root) run:

Code: Select all

dpkg-reconfigure -plow phpmyadmin

(choose to reinstall database, choose 'unix socket', take mysql user and pass from /usr/local/vesta/conf/mysql.conf, and choose to configure Apache2)

khampol
Posts: 10
Joined: Sat Jul 30, 2016 7:57 am

Re: The phpMyAdmin configuration storage is not completely configured

Postby khampol » Wed Oct 12, 2016 11:35 am

Hi Thx for reply. I just install it for some test. ...
Question : If I install vestaCP on centOS server(6.8..?) Do u think it can help ? ... Vestacp with "no problem"... ?

khampol
Posts: 10
Joined: Sat Jul 30, 2016 7:57 am

Re: The phpMyAdmin configuration storage is not completely configured

Postby khampol » Thu Oct 13, 2016 2:46 am

Ok. Just reinstall on CentOS 6.8 and no issue...
Vesta should say EXACTLY the OS required and stop to say ex. Ubuntu 14.x .... Not "eniterely" compatible...


Return to “Database Server”



Who is online

Users browsing this forum: No registered users and 3 guests

cron