lets encrypt error

Questions regarding the Web Interface
GUI
paunescumihai
Posts: 2
Joined: Sat Jan 07, 2017 11:19 pm

lets encrypt error

Postby paunescumihai » Wed Jan 11, 2017 10:41 am

I have this problem also, please help!

[root@test-server bin]# ./v-add-letsencrypt-user exclusivest my-real-email@gmail.com
Error: LetsEncrypt account registration 400
[root@test-server bin]#


I have already vim installed..
I tried putting:

curl -I https://acme-v01.api.letsencrypt.org/terms 2>/dev/null | grep "Location:"

this on v-add-letsencrypt-user

Location: https://letsencrypt.org/documents/LE-SA ... 1-2016.pdf

#agreement=$(curl -s -I "$api/terms" |grep Location |cut -f 2 -d \ |tr -d '\r\n')
agreement='https://letsencrypt.org/documents/LE-SA-v1.1.1-August-1-2016.pdf'


but still i have the same error..


Edit 1:
Other domains are working, just checked and i they work spotless...
Edit 2:
/usr/local/vesta/bin/v-add-letsencrypt-domain exclusivest real-domain.tld www.real-domain.tld no
Error: LetsEncrypt account registration 400
Same error...
Domain works, but without https... other domains on same server work perfectly, i used certbot to generate on same server one ssl for the same domain and it worked, (i deleted that ssl).

If this cannot be done via web interface, how do i generate the ssl manualy and put it in vestacp (to set it and forget it, to automaticaly renew)

Return to “Web Interface”



Who is online

Users browsing this forum: No registered users and 2 guests