Page 1 of 1

lets encrypt: add domains cause Proxy Support to stop

Posted: Thu Feb 09, 2017 4:07 pm
by JuzaoftheClouds
hi
I have a VestaCP 0.9.8-17 installed on a Centos 6 64bit server.

I super appreciate the Let's Encrypt feature, but i found an issue, these are steps to reproduce it:

Preparatory steps:
    * login as "admin"
    * create an user "foo", associate it to a profile with:
    Web Template HTTPD (hosting)
    Proxy Template NGINX (default)
    * login through admin to user "foo"
    * configure a new domain, be sure that it will have:
    Web Template HTTPD -> hosting
    Proxy Support NGINX -> default (be sure it is enabled)
    SSL Lets Encrypt enabled
    * save
    * logout from user "foo"
    * logout from "admin"

Bug steps:
    * login as "foo"
    * enter web section, edit web domain (logged as "foo" you can't view/edit "Proxy Support")
    * add a new domain into "Aliases" field
    * save
    * now from web section, you will see "Proxy Support" crossed out. Return to "admin", login as "foo", go to
    web/domain edit page and you will notice that "Proxy Support NGINX" is disabled!

Anyone suffering this bug too?

Re: lets encrypt: add domains cause Proxy Support to stop

Posted: Wed Feb 15, 2017 5:18 pm
by JuzaoftheClouds
UP!

Unfortunately, I can't report the bug on bug tracker, because it seems under maintenance.

Meanwhile, before a VestaCP update, does anyone know if there is a temporary fix?

Re: lets encrypt: add domains cause Proxy Support to stop

Posted: Tue Feb 21, 2017 12:08 pm
by skurudo
JuzaoftheClouds wrote:Meanwhile, before a VestaCP update, does anyone know if there is a temporary fix?


This? viewtopic.php?f=10&t=13811&p=56429#p56429

Re: lets encrypt: add domains cause Proxy Support to stop

Posted: Tue Feb 21, 2017 12:09 pm
by skurudo
JuzaoftheClouds wrote:Anyone suffering this bug too?


Nope, we check this.
Added - https://bugs.vestacp.com/issues/502

Re: lets encrypt: add domains cause Proxy Support to stop

Posted: Tue Oct 10, 2017 7:38 am
by plutocrat
I just came across this too. The workaround is to login as admin, switch user to non-admin user, enable proxy again. Then you can turn on SSL / Letsencrypt.

The domain should clearly retain the proxy settings as originally set.

Also, shouldn't SSL / Letsencrypt also work with apache only, no proxy?

Re: lets encrypt: add domains cause Proxy Support to stop

Posted: Sat Oct 21, 2017 10:54 am
by skamasle
plutocrat wrote:I just came across this too. The workaround is to login as admin, switch user to non-admin user, enable proxy again. Then you can turn on SSL / Letsencrypt.

The domain should clearly retain the proxy settings as originally set.

Also, shouldn't SSL / Letsencrypt also work with apache only, no proxy?


Please try this:

Code: Select all

cp  /usr/local/vesta/web/templates/user/edit_web.html  /usr/local/vesta/web/templates/user/edit_web.html-bk

curl https://raw.githubusercontent.com/serghey-rodin/vesta/master/web/templates/user/edit_web.html > /usr/local/vesta/web/templates/user/edit_web.html


And sayme is problem persists