lets encrypt: add domains cause Proxy Support to stop

Questions regarding the Web Interface
GUI
JuzaoftheClouds
Posts: 12
Joined: Thu Feb 09, 2017 3:41 pm

lets encrypt: add domains cause Proxy Support to stop

Postby JuzaoftheClouds » Thu Feb 09, 2017 4:07 pm

hi
I have a VestaCP 0.9.8-17 installed on a Centos 6 64bit server.

I super appreciate the Let's Encrypt feature, but i found an issue, these are steps to reproduce it:

Preparatory steps:
    * login as "admin"
    * create an user "foo", associate it to a profile with:
    Web Template HTTPD (hosting)
    Proxy Template NGINX (default)
    * login through admin to user "foo"
    * configure a new domain, be sure that it will have:
    Web Template HTTPD -> hosting
    Proxy Support NGINX -> default (be sure it is enabled)
    SSL Lets Encrypt enabled
    * save
    * logout from user "foo"
    * logout from "admin"

Bug steps:
    * login as "foo"
    * enter web section, edit web domain (logged as "foo" you can't view/edit "Proxy Support")
    * add a new domain into "Aliases" field
    * save
    * now from web section, you will see "Proxy Support" crossed out. Return to "admin", login as "foo", go to
    web/domain edit page and you will notice that "Proxy Support NGINX" is disabled!

Anyone suffering this bug too?

JuzaoftheClouds
Posts: 12
Joined: Thu Feb 09, 2017 3:41 pm

Re: lets encrypt: add domains cause Proxy Support to stop

Postby JuzaoftheClouds » Wed Feb 15, 2017 5:18 pm

UP!

Unfortunately, I can't report the bug on bug tracker, because it seems under maintenance.

Meanwhile, before a VestaCP update, does anyone know if there is a temporary fix?

skurudo
VestaCP Team
Posts: 7783
Joined: Fri Dec 26, 2014 2:23 pm
Location: Moscow
Contact:

Re: lets encrypt: add domains cause Proxy Support to stop

Postby skurudo » Tue Feb 21, 2017 12:08 pm

JuzaoftheClouds wrote:Meanwhile, before a VestaCP update, does anyone know if there is a temporary fix?


This? viewtopic.php?f=10&t=13811&p=56429#p56429
-> DigitalOcean competition - please, support us
-> fix for phpmyadmin - nice and sweet now

skurudo
VestaCP Team
Posts: 7783
Joined: Fri Dec 26, 2014 2:23 pm
Location: Moscow
Contact:

Re: lets encrypt: add domains cause Proxy Support to stop

Postby skurudo » Tue Feb 21, 2017 12:09 pm

JuzaoftheClouds wrote:Anyone suffering this bug too?


Nope, we check this.
Added - https://bugs.vestacp.com/issues/502
-> DigitalOcean competition - please, support us
-> fix for phpmyadmin - nice and sweet now


Return to “Web Interface”



Who is online

Users browsing this forum: No registered users and 2 guests