Page 3 of 3

Re: Let's Encrypt - How to use

Posted: Sat Nov 26, 2016 6:45 am
by Harry77
Hi,
I'm new with ssl and maybe there is something that I don't understand,
today from a clean install of vestacp on centos 6 32 I tried the gui let's encrypt feature,
I click "SSL Support" and "Lets Encrypt Support", I save and I don't get any error but after that I don't get any ssl certificate, the cron job only.
Domain is pointing to the right ip, before I was using this viewtopic.php?f=19&t=12617 without any problem.

what am I missing?

Re: Let's Encrypt - How to use

Posted: Tue Jan 03, 2017 10:59 am
by balinese
nginx + php-fpm, centos 7, latest vesta installed two days ago.

Code: Select all

v-add-letsencrypt-domain admin blabla.com
Error: Invalid response from http://blabla.com/.well-known/acme-challenge/Y3vZMgguMKn-REsTo1DFKb-7FmEApZ1LyPs5A77Eats: \


when try via vesta panel - Error code: 2

upd: blabla.com is a real domain (replaced), pointed to vesta and working fine
upd2: can't see ".well-known" rewrite in nginx configs. is it correct?

Re: Let's Encrypt - How to use

Posted: Mon Jan 16, 2017 11:47 pm
by baijianpeng
balinese wrote:when try via vesta panel - Error code: 2


I have exactly the same issue when trying to generate Lets Encryypt certificate for my domain via the VestaCP GUI.

My server OS: Ubuntu 16.04.1 LTS 64-bit
My VestaCP version: 0.98-17

Anyone here to check this and fix it?

Thank you.

Re: Let's Encrypt - How to use

Posted: Thu Mar 02, 2017 3:47 pm
by dev7
Same issue with Error Code 2, any fixes/suggestions?

Re: Let's Encrypt - How to use

Posted: Thu Mar 09, 2017 4:45 pm
by danberlyoung
skurudo wrote:
Spheerys wrote:One question : is the renew is automatically done by vesta or should we add a daily cron with "v-update-letsencrypt-ssl" ?


In .17 version when you add domain with LE support from GUI, cron task will be added automaticly.
If you used CLI from .16 version, then I doubt about auto cron task.


I added some domains with the CLI and some with the GUI. By doing at least one via the GUI, will that take care of adding the cron task?

Re: Let's Encrypt - How to use

Posted: Thu Mar 09, 2017 4:50 pm
by SS88
danberlyoung wrote:
skurudo wrote:
Spheerys wrote:One question : is the renew is automatically done by vesta or should we add a daily cron with "v-update-letsencrypt-ssl" ?


In .17 version when you add domain with LE support from GUI, cron task will be added automaticly.
If you used CLI from .16 version, then I doubt about auto cron task.


I added some domains with the CLI and some with the GUI. By doing at least one via the GUI, will that take care of adding the cron task?


If you are on version .17 - yes, if you are on .16 then no.

Re: Let's Encrypt - How to use

Posted: Fri Mar 31, 2017 8:28 am
by Daimko
Hi,

Same problem, on panel, error 2 and with SSH :
Invalid response from http://www.domain.com/.well-known/acme- ... TIIc21_wyk: \

Edit : The problem only occurs when I want to add a domain alias.
v-check-letsencrypt-domain user domain.com --> works
v-check-letsencrypt-domain user domain www.domain.com --> does not work

Re: Let's Encrypt - How to use

Posted: Fri Mar 31, 2017 9:33 am
by skurudo
Daimko wrote:Edit : The problem only occurs when I want to add a domain alias.
v-check-letsencrypt-domain user domain.com --> works
v-check-letsencrypt-domain user domain http://www.domain.com --> does not work


Check www A record for your domain.

Re: Let's Encrypt - How to use

Posted: Fri Mar 31, 2017 9:55 am
by Daimko
The problem came from that. I don't have the error 2 on the panel so it's perfect, thank you !