VestaCP PHP Selector for Centos add php 7, 5.6 and 5.5.

Section with additional software for Vesta
skamasle
Posts: 355
Joined: Mon Feb 29, 2016 6:36 pm

Re: VestaCP PHP Selector for Centos add php 7, 5.6 and 5.5.

Postby skamasle » Mon Aug 15, 2016 5:30 pm

pdcpl wrote:Hi,

I have installed php selector on centos 7 and it went fine but when we select respective version it doesn't work it show still the old version of php. Even after updating the domain.sh file it's the same issue.

Regards,

Harsha



This isnt compatible whit v16

baijianpeng
Posts: 289
Joined: Tue Dec 22, 2015 2:06 pm

Re: VestaCP PHP Selector for Centos add php 7, 5.6 and 5.5.

Postby baijianpeng » Tue Aug 16, 2016 12:25 am

skamasle wrote:This isnt compatible whit v16


Maybe you can consider to join the VestaCP official team and merge this script as a built-in feature of VestaCP.

Thank you.

skurudo
VestaCP Team
Posts: 7642
Joined: Fri Dec 26, 2014 2:23 pm
Location: Moscow
Contact:

Re: VestaCP PHP Selector for Centos add php 7, 5.6 and 5.5.

Postby skurudo » Tue Aug 16, 2016 12:32 pm

baijianpeng wrote:Maybe you can consider to join the VestaCP official team and merge this script as a built-in feature of VestaCP.


It's up to skamasle and skid ^_^
-> DigitalOcean competition - please, support us
-> fix for phpmyadmin - nice and sweet now

skamasle
Posts: 355
Joined: Mon Feb 29, 2016 6:36 pm

Re: VestaCP PHP Selector for Centos add php 7, 5.6 and 5.5.

Postby skamasle » Tue Aug 16, 2016 1:34 pm

baijianpeng wrote:
skamasle wrote:This isnt compatible whit v16


Maybe you can consider to join the VestaCP official team and merge this script as a built-in feature of VestaCP.

Thank you.



I think vestacp do something more stable in future and if they not do it yet is because need a lot of work to do it compatible in all systems, all ubuntu versions and debian is more dificult than centos.

in any way you can install all this manually using yum and generate your own template you not spend more than 10 minutes on this.

pradeepsharma
Posts: 6
Joined: Wed Nov 25, 2015 2:02 am

Re: VestaCP PHP Selector for Centos add php 7, 5.6 and 5.5.

Postby pradeepsharma » Fri Aug 19, 2016 10:48 am

Hi i want to use Mysqlnd_ms plugin to split read & write query for my application.
i am using your php7 selector in vesta.

Kindly help us or guide us.

Regards

Pradeep

skamasle
Posts: 355
Joined: Mon Feb 29, 2016 6:36 pm

Re: VestaCP PHP Selector for Centos add php 7, 5.6 and 5.5.

Postby skamasle » Fri Aug 19, 2016 10:28 pm

pradeepsharma wrote:Hi i want to use Mysqlnd_ms plugin to split read & write query for my application.
i am using your php7 selector in vesta.

Kindly help us or guide us.

Regards

Pradeep


Hi,

In first post aresome information about how can you install new modules.

rbrownell
Posts: 7
Joined: Tue Aug 16, 2016 1:03 pm

Re: VestaCP PHP Selector for Centos add php 7, 5.6 and 5.5.

Postby rbrownell » Tue Aug 23, 2016 11:55 pm

I just wanted to contribute to the discussion.

I currently have a CentOS 7 VM running VESTA 0.9.8-16
While I am aware that this script is not compatible with -16, I went through all the the templates and scripts and manually modified all of the files that were called in the scripts so that PHP 5.4 could be called for a specific domain name.

fcgi-starter:

Code: Select all

#!/bin/sh
PHPRC=/opt/remi/php54/root/etc/
export PHPRC
export PHP_FCGI_MAX_REQUESTS=500
export PHP_FCGI_CHILDREN=10
exec  /usr/bin/php54-cgi


shttpd.conf:

Code: Select all

<VirtualHost 45.XXX.XXX.XXX:443>

    ServerName SUBDOMAIN.DOMAIN.com
    ServerAlias www.SUBDOMAIN.DOMAIN.com
    ServerAdmin info@SUBDOMAIN.DOMAIN.com
    DocumentRoot /home/MYUSER/web/SUBDOMAIN.DOMAIN.com/public_html
    ScriptAlias /cgi-bin/ /home/MYUSER/web/SUBDOMAIN.DOMAIN.com/cgi-bin/
    Alias /vstats/ /home/MYUSER/web/SUBDOMAIN.DOMAIN.com/stats/
    Alias /error/ /home/MYUSER/web/SUBDOMAIN.DOMAIN.com/document_errors/
    #SuexecUserGroup MYUSER MYUSER
    CustomLog /var/log/httpd/domains/SUBDOMAIN.DOMAIN.com.bytes bytes
    CustomLog /var/log/httpd/domains/SUBDOMAIN.DOMAIN.com.log combined
    ErrorLog /var/log/httpd/domains/SUBDOMAIN.DOMAIN.com.error.log
    <Directory /home/MYUSER/web/SUBDOMAIN.DOMAIN.com/public_html>
        AllowOverride All
        SSLRequireSSL
        Options +Includes -Indexes +ExecCGI
        php_admin_value open_basedir /home/MYUSER/web/SUBDOMAIN.DOMAIN.com/public_html:/home/MYUSER/tmp
        php_admin_value upload_tmp_dir /home/MYUSER/tmp
        php_admin_value session.save_path /home/MYUSER/tmp
        <Files *.php>
          SetHandler fcgid-script
        </Files>
        FCGIWrapper /home/MYUSER/web/SUBDOMAIN.DOMAIN.com/cgi-bin/fcgi-starter .php
    </Directory>
    <Directory /home/MYUSER/web/SUBDOMAIN.DOMAIN.com/stats>
        AllowOverride All
    </Directory>
    SSLEngine on
    SSLVerifyClient none
    SSLCertificateFile /home/MYUSER/conf/web/ssl.SUBDOMAIN.DOMAIN.com.crt
    SSLCertificateKeyFile /home/MYUSER/conf/web/ssl.SUBDOMAIN.DOMAIN.com.key
    SSLCertificateChainFile /home/MYUSER/conf/web/ssl.SUBDOMAIN.DOMAIN.com.ca

    <IfModule mod_ruid2.c>
        RMode config
        RUidGid MYUSER MYUSER
        RGroups apache
    </IfModule>
    <IfModule itk.c>
        AssignUserID MYUSER MYUSER
    </IfModule>

    IncludeOptional /home/MYUSER/conf/web/shttpd.SUBDOMAIN.DOMAIN.com.conf*

</VirtualHost>


All sites on the server stopped functioning with the log reporting following error:

Code: Select all

[Tue Aug 23 23:36:23.869169 2016] [fcgid:emerg] [pid 21515] (13)Permission denied: [client 142.XXX.XXX.XXX:58592] mod_fcgid: can't lock process table in pid 21515


I am really looking forward to this working in the next version of Vesta as I have a critical piece of open source software that was abandoned by its developers that is only compatible with PHP 5.4 with no suitable alternatives in existence.

pradeepsharma
Posts: 6
Joined: Wed Nov 25, 2015 2:02 am

Re: VestaCP PHP Selector for Centos add php 7, 5.6 and 5.5.

Postby pradeepsharma » Thu Sep 01, 2016 5:38 pm

Hi @ skamasle

i have installed it on vestacp previous version and eventually i updated my vestacp.
now this script is not working at all
httpd is not restarting even if i switch to php5.4 version.

i request you to kindly provide a solution of this bug or make it compatible to the current version of vestacp. 9.16

We know that current version of Vesta is not very stable in current version but you can provide us a temporary solution to fix it.

i had alomot 500+ sites were online using this script. all are down.

please consider our request and update it to the latest version of vesta.

skamasle
Posts: 355
Joined: Mon Feb 29, 2016 6:36 pm

Re: VestaCP PHP Selector for Centos add php 7, 5.6 and 5.5.

Postby skamasle » Thu Sep 01, 2016 7:22 pm

pradeepsharma wrote:Hi @ skamasle

i have installed it on vestacp previous version and eventually i updated my vestacp.
now this script is not working at all
httpd is not restarting even if i switch to php5.4 version.

i request you to kindly provide a solution of this bug or make it compatible to the current version of vestacp. 9.16

We know that current version of Vesta is not very stable in current version but you can provide us a temporary solution to fix it.

i had alomot 500+ sites were online using this script. all are down.

please consider our request and update it to the latest version of vesta.


Hi

You can fix fastcgi issue -> https://bugs.vestacp.com/issues/287 this is a fix https://github.com/serghey-rodin/vesta/pull/759

Is a bug whit fastcgi template on vestacp, if you apply that patch and rebuild vhost that should working fine.

If you cant solve it you need change all website templates to default or almost latest added websites

skamasle
Posts: 355
Joined: Mon Feb 29, 2016 6:36 pm

Re: VestaCP PHP Selector for Centos add php 7, 5.6 and 5.5.

Postby skamasle » Wed Sep 14, 2016 9:15 pm

I test whit some fix and add support for php 7.1 as remi add support for this versión and also option to select which php install.

Wait vesta v17 :)


Return to “3rd Party Software”



Who is online

Users browsing this forum: No registered users and 1 guest