VestaCP MultiPHP (Debian/Ubuntu) Topic is solved

Section with additional software for Vesta
petkoo12
Posts: 41
Joined: Thu Feb 04, 2016 10:19 pm

Re: VestaCP MultiPHP (Debian/Ubuntu)

Postby petkoo12 » Wed Sep 27, 2017 1:04 pm

hello,

i am installing it on ubuntu 14.04 but i have errors by using this line

Code: Select all

root@servisujem:/home/servisujem# sudo phpbrew install 7.1 +default +openssl=shared -- --with-openssl-dir=/usr/include/openssl --with-mysql-sock=/var/run/mysqld/mysqld.sock --with-mysql=mysqlnd --with-mysqli=mysqlnd --enable-pdo --with-pdo-mysql=mysqlnd --enable-exif --with-jpeg-dir=/usr --with-png-dir=/usr --with-freetype-dir=/usr --with-zlib-dir=/usr --with-mcrypt=/usr --with-mhash --with-xsl=/usr --enable-zip --enable-cgi --with-curl --with-gd --enable-pcntl --enable-mbregex --enable-gd-native-ttf --with-libdir=lib64 --enable-dba=shared --enable-intl --with-readline=/usr --enable-simplexml \--enable-soap --enable-zip --with-mhash=yes --enable-shmop --enable-sockets --enable-wddx --enable-calendar --enable-sysvsem --enable-sysvshm --enable-sysvmsg --enable-bcmath --with-bz2 --enable-ctype --with-cdb --with-iconv --enable-exif --enable-ftp --with-gettext --with-pic
*WARNING* You're runing phpbrew as root/sudo. Unless you're going to install
system-wide phpbrew or this might cause problems.
Downloading https://secure.php.net/releases/index.php?json&version=7&max=100 via php stream
Downloading https://secure.php.net/releases/index.php?json&version=5&max=100 via php stream
===> phpbrew will now build 7.1.9
===> Loading and resolving variants...
Downloading http://www.php.net/get/php-7.1.9.tar.bz2/from/this/mirror via php stream
===> Extracting /root/.phpbrew/distfiles/php-7.1.9.tar.bz2 to /root/.phpbrew/build/tmp.1506513268/php-7.1.9
===> Moving /root/.phpbrew/build/tmp.1506513268/php-7.1.9 to /root/.phpbrew/build/php-7.1.9
===> Checking patches...
Checking patch for replace apache php module name with custom version name
===> Configuring 7.1.9...


Use tail command to see what's going on:
   $ tail -F /root/.phpbrew/build/php-7.1.9/build.log


Error: Configure failed:
The last 5 lines in the log file:
checking for gettimeofday... (cached) yes

checking whether to enable LIBXML support... yes

checking libxml2 install dir... no

checking for xml2-config path...

configure: error: xml2-config not found. Please check your libxml2 installation.

Please checkout the build log file for more details:
         tail /root/.phpbrew/build/php-7.1.9/build.log


and i dont know why i get this error

this is from build.log

Code: Select all

checking for sys/types.h... (cached) yes
checking for inttypes.h... (cached) yes
checking for stdint.h... (cached) yes
checking for string.h... (cached) yes
checking for stdlib.h... (cached) yes
checking for strtoll... yes
checking for atoll... yes
checking for strftime... (cached) yes
checking for gettimeofday... (cached) yes
checking whether to enable LIBXML support... yes
checking libxml2 install dir... no
checking for xml2-config path...
configure: error: xml2-config not found. Please check your libxml2 installation.

ScIT
Posts: 265
Joined: Mon Feb 23, 2015 4:13 pm

Re: VestaCP MultiPHP (Debian/Ubuntu)

Postby ScIT » Wed Sep 27, 2017 1:46 pm

configure: error: xml2-config not found. Please check your libxml2 installation.

Please check your log, the error above says all about it :).

Try to install, and then rerun the command: apt-get install libxml2-dev libxml2

petkoo12
Posts: 41
Joined: Thu Feb 04, 2016 10:19 pm

Re: VestaCP MultiPHP (Debian/Ubuntu)

Postby petkoo12 » Tue Oct 10, 2017 11:01 am

Hello,

i tryed apt get install libxml2-dev libxml2 and i get this

Code: Select all

Reading package lists... Done
Building dependency tree
Reading state information... Done
libxml2 is already the newest version.
libxml2-dev is already the newest version.
The following packages were automatically installed and are no longer required:
  libapache2-mod-php7.1 linux-headers-4.4.0-93 linux-headers-4.4.0-93-generic
  php5-sqlite
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 23 not upgraded.


From the tail /root/.phpbrew/build/php-7.1.9/build.log i have

Code: Select all

checking for string.h... (cached) yes
checking for stdlib.h... (cached) yes
checking for strtoll... yes
checking for atoll... yes
checking for strftime... (cached) yes
checking for gettimeofday... (cached) yes
checking whether to enable LIBXML support... yes
checking libxml2 install dir... no
checking for xml2-config path...
configure: error: xml2-config not found. Please check your libxml2 installation.


When i reading this steps https://git.scit.ch/rs/VestaCP-MultiPHP/blob/master/README.md i get error in this statements

Code: Select all

apt-get install build-essential libssl-dev libxml2-dev pkg-config libssl-dev libsslcommon2-dev libbz2-dev libcurl4-openssl-dev libmysqlclient-dev libgdbm-dev libjpeg62 libjpeg62-dev libpng12-0 libpng12-dev libxml2 libxml2-dev libmcrypt4 libmcrypt-dev libmhash2 libmhash-dev libmm-dev libmm14 libtidy-dev libtidy-0.99-0 libxslt1-dev libxslt1.1 libfreetype6 libfreetype6-dev libicu-dev libreadline-dev
ouput is

Code: Select all

Reading package lists... Done
Building dependency tree
Reading state information... Done
libmcrypt4 is already the newest version.
libmcrypt4 set to manually installed.
libfreetype6 is already the newest version.
libfreetype6 set to manually installed.
libpng12-0 is already the newest version.
libxml2 is already the newest version.
libxml2-dev is already the newest version.
libxslt1.1 is already the newest version.
libxslt1.1 set to manually installed.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libtidy-dev : Breaks: libtidy-0.99-0 but 20091223cvs-1.2ubuntu1.1 is to be installed
E: Unable to correct problems, you have held broken packages.

What i am doing wrong ?

mehargags
Moderators
Posts: 786
Joined: Sat Sep 06, 2014 9:58 pm
Contact:

Re: VestaCP MultiPHP (Debian/Ubuntu)

Postby mehargags » Tue Oct 10, 2017 1:25 pm

force apt to install dependant software

Code: Select all

apt-get install -f


Return to “3rd Party Software”



Who is online

Users browsing this forum: Bing [Bot] and 2 guests