[HOWTO] Install CSF + Use it's GUI in VestaCP Topic is solved

Section with modification and patches for Vesta
amitz
Posts: 49
Joined: Mon Nov 09, 2015 10:52 am

Re: [HOWTO] Install CSF + Use it's GUI in VestaCP

Postby amitz » Fri May 12, 2017 12:43 pm

Thanks, it installed now :)

ServerHost
Posts: 15
Joined: Fri May 05, 2017 12:18 am

Re: [HOWTO] Install CSF + Use it's GUI in VestaCP

Postby ServerHost » Sat May 27, 2017 5:54 pm

Is there a regex for vesta, dovecot, exim, imap, pop3, smtp?

SS88
Posts: 298
Joined: Thu Nov 19, 2015 12:40 pm

Re: [HOWTO] Install CSF + Use it's GUI in VestaCP

Postby SS88 » Sat May 27, 2017 6:05 pm

ServerHost wrote:Is there a regex for vesta, dovecot, exim, imap, pop3, smtp?


Vesta = no .I can make one after memorial day.

Dovecot, exim, imap, pop3, smtp already installed.

ServerHost
Posts: 15
Joined: Fri May 05, 2017 12:18 am

Re: [HOWTO] Install CSF + Use it's GUI in VestaCP

Postby ServerHost » Thu Jun 01, 2017 12:00 am

SS88 wrote:
ServerHost wrote:Is there a regex for vesta, dovecot, exim, imap, pop3, smtp?


Vesta = no .I can make one after memorial day.

Dovecot, exim, imap, pop3, smtp already installed.



Where I find?

moucho
Posts: 6
Joined: Tue Jun 28, 2016 5:32 pm

Re: [HOWTO] Install CSF + Use it's GUI in VestaCP

Postby moucho » Sun Aug 06, 2017 2:55 pm

Firstly, you have to edit /etc/csf/csf.conf with the right log file for VestaCP:

Code: Select all

CUSTOM1_LOG = "/var/log/vesta/auth.log"

Then, if you want to block that IP for 1 hour (3 attemps):

Code: Select all

# vestacp
if (($globlogs{CUSTOM1_LOG}{$lgfile}) and ($line =~ /(\S+) failed to login/)) {
  return ("Login attempt to VestaCP from",$1,"VESTAloginAttempt","3","8083","3600");
}

Or if you want to block that IP permanently (5 attemps):

Code: Select all

# vestacp
if (($globlogs{CUSTOM1_LOG}{$lgfile}) and ($line =~ /(\S+) failed to login/)) {
  return ("Login attempt to VestaCP from",$1,"VESTAloginAttempt","5","8083","1");
}

bdacus01
Posts: 5
Joined: Mon Aug 28, 2017 6:21 pm

Re: [HOWTO] Install CSF + Use it's GUI in VestaCP

Postby bdacus01 » Tue Aug 29, 2017 3:52 pm

I added Blocklists in LFD. Looks like perl-LWP-Protocol-https is not in the default install. You might want to add this to the install script.


In the mean time the fix this error is :

yum install perl-LWP-Protocol-https


Return to “Modification & Patches”



Who is online

Users browsing this forum: No registered users and 2 guests

cron