Reinstallation of vestacp

General questions about VestaCP
Jenni
Posts: 5
Joined: Thu Oct 12, 2017 7:04 am

Reinstallation of vestacp

Postby Jenni » Thu Oct 12, 2017 7:13 am

Hello all,
I installed vestacp on vps with centos 7.0 and it was working fine. Yesterday i found that i was not able to access the webmail for the emails on my domain which i had set and were earlier working. So, i tried to reinstall vesta cp, after removing it using below commands.
      service vesta stop
      yum remove vesta*
      rm -f /etc/yum.repos.d/vesta.repo
      rm -rf /usr/local/vesta

But it is giving the below error. Pls help.
--> Finished Dependency Resolution
Error: php-mysql conflicts with php-mysqlnd-5.6.31-1.el7.remi.x86_64
Error: Package: php-mysql-5.4.16-42.el7.x86_64 (C7.3.1611-base)
Requires: php-pdo(x86-64) = 5.4.16-42.el7
Installed: php-pdo-5.6.31-1.el7.remi.x86_64 (@remi-php56)
php-pdo(x86-64) = 5.6.31-1.el7.remi
Available: php-pdo-5.4.16-21.el7.x86_64 (C7.0.1406-base)
php-pdo(x86-64) = 5.4.16-21.el7
Available: php-pdo-5.4.16-23.el7_0.x86_64 (C7.0.1406-updates)
php-pdo(x86-64) = 5.4.16-23.el7_0
Available: php-pdo-5.4.16-23.el7_0.1.x86_64 (C7.0.1406-updates)
php-pdo(x86-64) = 5.4.16-23.el7_0.1
Available: php-pdo-5.4.16-23.el7_0.3.x86_64 (C7.0.1406-updates)
php-pdo(x86-64) = 5.4.16-23.el7_0.3
Available: php-pdo-5.4.16-36.el7_1.x86_64 (C7.1.1503-updates)
php-pdo(x86-64) = 5.4.16-36.el7_1
Available: php-pdo-5.4.16-36.1.el7_2.1.x86_64 (C7.2.1511-updates)
php-pdo(x86-64) = 5.4.16-36.1.el7_2.1
Available: php-pdo-5.4.16-36.3.el7_2.x86_64 (C7.2.1511-updates)
php-pdo(x86-64) = 5.4.16-36.3.el7_2
Available: php-pdo-5.4.16-42.el7.x86_64 (C7.3.1611-base)
php-pdo(x86-64) = 5.4.16-42.el7
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
Error: yum install failed

pipoy
Posts: 17
Joined: Mon Sep 11, 2017 8:02 am

Re: Reinstallation of vestacp

Postby pipoy » Thu Oct 12, 2017 8:01 am

This is related to this

viewtopic.php?f=10&t=15264

Jenni
Posts: 5
Joined: Thu Oct 12, 2017 7:04 am

Re: Reinstallation of vestacp

Postby Jenni » Thu Oct 12, 2017 12:36 pm

pipoy wrote:This is related to this

viewtopic.php?f=10&t=15264

The solution there doesnt work for me. I had already checked all the posts in the forum. Pls suggest any alternate. Do consider that it was working fine. I need to understand the correct way to reinstall Vestacp and how to set the port to access the mails in webmail. How to solve "Error: php-mysql conflicts with php-mysqlnd-5.6.31-1.el7.remi.x86_64" and therefor "Error: yum install failed"

Thx

skamasle
Collaborator
Posts: 375
Joined: Mon Feb 29, 2016 6:36 pm

Re: Reinstallation of vestacp

Postby skamasle » Thu Oct 12, 2017 6:04 pm

The problem here is than you not know how system working

Why reinstalling vesta if webmail fails ?

You need fix webmail problem, because vesta is just a package, webmail is orther package and not depends of vesta

So, now easiest solution is :

Backup all your data
Reinstall your vps, install vesta.

Your php-mysql conflicts maybe come because you try install php-mysql and not use remi repo for that and this conflict with your acctual php-mysql installed from remi repo.

You need use correct repo.

I think the easy solution is that, start from 0 in new vesta install, of course your problem can be fixed, but you need have some system administration skils, first fix repos issue then reinstall vesta, then fix webmail issue.
Patch your ubuntu 16 or mysq5.7 -> viewtopic.php?f=20&t=13239
Transfer accounts from cPanel -> viewtopic.php?f=19&t=11075

Jenni
Posts: 5
Joined: Thu Oct 12, 2017 7:04 am

Re: Reinstallation of vestacp

Postby Jenni » Fri Oct 13, 2017 4:30 am

Hi Skamasle, Thanks for your answer.
"Why reinstalling vesta if webmail fails ?

You need fix webmail problem, because vesta is just a package, webmail is orther package and not depends of vesta"
You are absolutely right and i made a mistake there.

Thanks for showing me the path. I will do as suggested and get back if i succeed or if any issues too. You have explained well.

Jenni
Posts: 5
Joined: Thu Oct 12, 2017 7:04 am

Re: Reinstallation of vestacp

Postby Jenni » Fri Oct 13, 2017 5:18 am

Hi,
SO on installing VestaCP with remi yes ,it is giving below errors:-
(98)Address already in use: AH00072: make_sock: could not bind to address xx.xxx.x.x:8080

no listening sockets available, shutting down

AH00015: Unable to open logs

Failed to start The Apache HTTP Server.
Unit httpd.service entered failed state.
httpd.service failed

What needs to be done here


Return to “General Discussion”



Who is online

Users browsing this forum: Google [Bot] and 12 guests