error 15 v-check-letsencrypt-domain Topic is solved

General questions about VestaCP
locus
Posts: 54
Joined: Thu May 05, 2016 6:43 am

error 15 v-check-letsencrypt-domain

Postby locus » Sun Feb 05, 2017 11:14 am

When "v-check-letsencrypt-domain" is run via cron or cli I get the following error

Error 15

Code: Select all

Error: Invalid response from http://domain.com.au/.well-known/acme-challenge/pfiGhWhFRrTfpTsueAwbbEVm0bssnoAFGrV6KEnzs2k: \


Where does it log to?

locus
Posts: 54
Joined: Thu May 05, 2016 6:43 am

Re: error 15 v-check-letsencrypt-domain

Postby locus » Sun Feb 05, 2017 11:14 am

/usr/local/vesta/log/error.log
has minimal info about it - just error 15

edica
Posts: 101
Joined: Tue May 26, 2015 7:31 pm

Re: error 15 v-check-letsencrypt-domain

Postby edica » Mon Feb 06, 2017 1:32 pm

Same mistake here too. :(

skurudo
VestaCP Team
Posts: 7791
Joined: Fri Dec 26, 2014 2:23 pm
Location: Moscow
Contact:

Re: error 15 v-check-letsencrypt-domain

Postby skurudo » Thu Feb 09, 2017 8:59 am

Try to ping something outside vps.

error 15
E_CONNECT
Connection failed. Host is unreachable

via https://vestacp.com/docs/api/#return_codes
-> DigitalOcean competition - please, support us
-> fix for phpmyadmin - nice and sweet now

JuzaoftheClouds
Posts: 12
Joined: Thu Feb 09, 2017 3:41 pm

Re: error 15 v-check-letsencrypt-domain

Postby JuzaoftheClouds » Thu Feb 09, 2017 4:31 pm

locus wrote:When "v-check-letsencrypt-domain" is run via cron or cli I get the following error

Error 15

Code: Select all

Error: Invalid response from http://domain.com.au/.well-known/acme-challenge/pfiGhWhFRrTfpTsueAwbbEVm0bssnoAFGrV6KEnzs2k: \


Where does it log to?




Hi
i had the same error, in my case the error was:

Code: Select all

Error: Invalid response from http://*******.******.***/.well-known/acme-challenge/dpJUMXB9Uf1_94R4yA-bBoX310MB8wsU7eRPGzt7d4Q:


I found that the source of the problem was that customer added another domain on his hosting (with lets encrypt enabled).
This caused a bug where "proxy support" switches to off.
I have already opened another thread here about this issue:
viewtopic.php?f=16&t=13841

Solved temporarily, manually re-arming "proxy support", but i hope in a better fix :)

locus
Posts: 54
Joined: Thu May 05, 2016 6:43 am

Re: error 15 v-check-letsencrypt-domain  Topic is solved

Postby locus » Thu Feb 09, 2017 11:53 pm

All my sites that display this issue use Apache with Nginx proxy (hosting & force-https template).
Switching off LE support and saving, then going back in and switching on generally fixes the issue. I dont disable nginx proxy support but I do select the "hosting" template for nginx when disabling SSL.
Just glad I dont have hundreds of domains on this server!

skurudo
VestaCP Team
Posts: 7791
Joined: Fri Dec 26, 2014 2:23 pm
Location: Moscow
Contact:

Re: error 15 v-check-letsencrypt-domain

Postby skurudo » Tue Feb 21, 2017 12:10 pm

-> DigitalOcean competition - please, support us
-> fix for phpmyadmin - nice and sweet now

locus
Posts: 54
Joined: Thu May 05, 2016 6:43 am

Re: error 15 v-check-letsencrypt-domain

Postby locus » Sun Feb 26, 2017 7:38 am

I noticed that the error has

Code: Select all

Invalid response from http://


I use force-ssl template so Ill change that in case the error is due to the redirect.

skurudo
VestaCP Team
Posts: 7791
Joined: Fri Dec 26, 2014 2:23 pm
Location: Moscow
Contact:

Re: error 15 v-check-letsencrypt-domain

Postby skurudo » Wed Mar 29, 2017 9:13 am

locus wrote:I noticed that the error has

Code: Select all

Invalid response from http://

I use force-ssl template so Ill change that in case the error is due to the redirect.


Check this topic, let's find out:
viewtopic.php?f=11&t=13955&p=58495#p58495
-> DigitalOcean competition - please, support us
-> fix for phpmyadmin - nice and sweet now


Return to “General Discussion”



Who is online

Users browsing this forum: Bing [Bot] and 10 guests

cron