Using the WHMCS module - getting error 500

General questions about VestaCP
Forum rules
Before creating a new topic or reply on the forum you should fill out additional fields "Os" and "Web" in your profile section.
In case of violation, the topic can be closed or response from the support will not be received.
chrismetalrock
Posts: 2
Joined: Tue May 16, 2017 2:51 am

Using the WHMCS module - getting error 500

Postby chrismetalrock » Tue May 16, 2017 11:22 pm

Hey guys. I have a new Centos 7.3 x64 installation (droplet from digitalocean).

I have installed VestaCP with nginx and php-fpm (i used this installer command for reference):
bash vst-install.sh --nginx yes --phpfpm yes --apache no --named yes --remi yes --vsftpd yes --proftpd no --iptables yes --fail2ban yes --quota no --exim yes --dovecot yes --spamassassin yes --clamav no --mysql yes --postgresql no

After I got VestaCP setup, i enabled Letsencrypt SSL for my domain, which worked without issue.

After that i installed WHMCS and updated it. I added the vesta module and this is where the issues start.
When i manually accept an order from within WHMCS (just testing asdfasf.com for example) i get a 500 error page.
When i go back to WHMCS the order is pending.
WHen i check in vesta the account is successfully created.
When i try to accept the order again in WHMCS it says error client exists (because it did go through originally)

I also checked on the client side - when i try to buy hosting when i get to the paypal checkout part i get a 500 error.

So i backtracked a bit and tried setting up a cpanel module (as i have a cpanel server elsewhere). When using the cpanel, both setting up the new server and the client trying to pay for the hosting are working 100%. So the issue is somewhere in the vesta module (i am convinced at least) and i am trying to figure out where the issue may be.

PHP-FPM error.log: issue that comes up when i try to accept the order in whmcs
16-May-2017 21:00:07] NOTICE: Terminating ...
[16-May-2017 21:00:07] NOTICE: exiting, bye-bye!
[16-May-2017 21:00:07] NOTICE: fpm is running, pid 7189
[16-May-2017 21:00:07] NOTICE: ready to handle connections
[16-May-2017 21:00:07] NOTICE: systemd monitor interval set to 10000ms

NGINX error.log for my domain (nginix error generic log is blank):
2017/05/16 21:00:07 [error] 5550#5550: *113 recv() failed (104: Connection reset by peer) while reading response header from upstream, client: MY-PUBLIC-IP, server: DOMAIN-IN-QUESTION-DOT-COM, request: "POST /account/admin/orders.php?action=view&id=1&activate=true HTTP/1.1", upstream: "fastcgi://127.0.0.1:9001", host: "DOMAIN-IN-QUESTION-DOT-COM", referrer: "https://DOMAIN-IN-QUESTION-DOT-COM/account/admin/orders.php?action=view&id=1"

Any ideas? Much appreciated.

ServerHost
Posts: 15
Joined: Fri May 05, 2017 12:18 am

Re: Using the WHMCS module - getting error 500

Postby ServerHost » Wed May 24, 2017 2:55 am

Hi,

I have the same problem, exactly the same. Did you solve it?


Return to “General Discussion”



Who is online

Users browsing this forum: No registered users and 9 guests

cron