Page 1 of 1

Awstats stoped working [with solution]

Posted: Fri Nov 03, 2017 8:35 am
by Felix
[devs, please read on. Possible bug at the end]

Hello community.

In one Ubuntu 14.04 server with VESTA 0.9.8 (amd64) R17, I'm hosting some domains. One of the domains only is facing the following problem when trying to view awstats at http://domain.tld/vstats/ :

Code: Select all

Error: SiteDomain parameter not defined in your config/domain file. You must edit it for using this version of AWStats.

Setup ('/etc/awstats/awstats.conf' file, web server or permissions) may be wrong.
Check config file, permissions and AWStats documentation (in 'docs' directory). 
At the top of the page, there is the drop-down selection. If I select April 2016 the stats appear OK. But selecting any month after April 2016, is showing the same error.

I have already tried running v-update-web-domain-stat [user] [domain.tld] but although it finishes without errors, the above problem is still there.

SOLUTION and possibly a bug somewhere
The symbolic link in /etc/awstats was pointing at the wrong directory. Instead of pointing at

Code: Select all

it was pointing at

Code: Select all

which of course didn't exist any more.

As far as I remember, I had moved this domain from user1 to user2 using the command v-change-domain-owner. If this is the case, then the command v-change-domain-owner didn't update the symbolic link, causing this problem.