Page 1 of 1

Unable to install on fresh CentOS 7

Posted: Wed Aug 08, 2018 10:12 am
by Konfuzed
Hi there,

I've just tried to install VestaCP to a freshly installed version of CentOS 7, running on a dedicated machine with 2x Xeon E5-2670, 64GB RAM and 6x256GB SSD's in RAID10. At the end of the installation it tries to start all the services, but it fails to start the service 'httpd.service'. The error message is below.
Job for httpd.service failed because a fatal signal was delivered to the control process. See "systemctl status httpd.service" and "journalctl -xe" for details.
Error: httpd start failed
If I type the command "systemctl status httpd.service", it gives me an error output, but I honestly don't know what to do with it.
● httpd.service - The Apache HTTP Server
Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
Drop-In: /etc/systemd/system/httpd.service.d
Active: failed (Result: signal) since Wed 2018-08-08 05:54:14 EDT; 11min ago
Process: 3404 ExecStart=/usr/sbin/httpd $OPTIONS -DFOREGROUND (code=killed, signal=KILL)
Main PID: 3404 (code=killed, signal=KILL)
Status: "Total requests: 0; Current requests/sec: 0; Current traffic: 0 B/sec"

Aug 08 05:51:14 sub.domain.ext systemd[1]: Starting The Apache HTTP Server...
Aug 08 05:51:14 sub.domain.ext httpd[3404]: [Wed Aug 08 05:51:14.409097 2018] [so:warn] [pid 3404] AH01574: module ruid2_module is already loaded, skipping
Aug 08 05:52:44 sub.domain.ext systemd[1]: httpd.service start operation timed out. Terminating.
Aug 08 05:54:14 sub.domain.ext systemd[1]: httpd.service stop-final-sigterm timed out. Killing.
Aug 08 05:54:14 sub.domain.ext systemd[1]: httpd.service: main process exited, code=killed, status=9/KILL
Aug 08 05:54:14 sub.domain.ext systemd[1]: Failed to start The Apache HTTP Server.
Aug 08 05:54:14 sub.domain.ext systemd[1]: Unit httpd.service entered failed state.
Aug 08 05:54:14 sub.domain.ext systemd[1]: httpd.service failed.
I've used the following commandline to install VestaCP.
bash --nginx yes --apache yes --phpfpm no --named yes --remi yes --vsftpd no --proftpd yes --iptables yes --fail2ban yes --quota no --exim yes --dovecot yes --spamassassin yes --clamav yes --softaculous no --mysql yes --postgresql no --hostname sub.domain.ext --email postmaster@domain.ext --password p@ssw0rd
Rebooting the system doesn't do anything. Never received an e-mail that the installation is complete (which I received before on a VPS). Anyone knows how to fix this?

Re: Unable to install on fresh CentOS 7

Posted: Thu Aug 09, 2018 6:12 pm
by canoodle
i just did that today.

Code: Select all

hostnamectl; # give us some details
Operating System: CentOS Linux 7 (Core)
       CPE OS Name: cpe:/o:centos:centos:7
            Kernel: Linux 4.17.12
and it worked just fine:

try to download the install script manually.

Code: Select all

chmod +x

# which will download another os type dependant install script
# same game
chmod +x;
# just use the default settings
same result?

no customization options, it makes things too complex = untestable, if you really want to customize vestacp - do it on your own - release a howto for others to follow.

example: i don't want roundcube, webmail is cool, but i am not using it, (without SSL nobody should use it) less software = more secure system.

here is how to do it: ... e-webmail/

Re: Unable to install on fresh CentOS 7

Posted: Sun Aug 26, 2018 6:06 am
by dstamatoiu
You need to uninstall httpd.

sudo yum erase httpd httpd-tools apr apr-util

Then do a restart.