Page 1 of 1

Problem with Backups and Filenames with accents (UTF-8 ENCODING)

Posted: Fri Dec 21, 2018 8:47 am
by gcasas
Hi, I use VestaCP and I want to check backups in a secondary Server. When I do it I have a problem, in upload folder of one of my domains (wp-content/uploads/) there are a few files with accents in filename. When I check restored website I lose some images links because backup job change this accents with special characters using UTF-8 encoding.

For example, original filename:

Code: Select all

wp-content/uploads/Gestión.jpg
Filename in backup:

Code: Select all

wp-content/uploads/Gestión.jpg
Result:

Code: Select all

ó	=   ó	
There is some option to make backup and keep the original filename?

Thanks in advance!

Re: Problem with Backups and Filenames with accents (UTF-8 ENCODING)

Posted: Sat Dec 22, 2018 8:15 am
by grayfolk
This is not a Vesta issue, this is php/wordpress issue.

Re: Problem with Backups and Filenames with accents (UTF-8 ENCODING)

Posted: Fri Dec 28, 2018 8:34 am
by gcasas
grayfolk wrote:
Sat Dec 22, 2018 8:15 am
This is not a Vesta issue, this is php/wordpress issue.
Hi, thanks for your answer, but I think that this is not php/wordpress issue,.. I also tested with vestacp default domain.

Yourself can make a site backup of some of your sites and check if the file (with accent) have the same name.

I don't know how vestacp make backups, so I think that there is some option to solve this. I make backups with rsync and I have no problems with accents.

thanks,

Re: Problem with Backups and Filenames with accents (UTF-8 ENCODING)

Posted: Fri Jan 11, 2019 12:11 pm
by gcasas
Hello, has anyone checked if same thing happens? Thank you!

Re: Problem with Backups and Filenames with accents (UTF-8 ENCODING)

Posted: Tue Jan 15, 2019 1:24 pm
by skamasle
Hi

This issue happen in a lot of ways.

You can get this issue also if you download from FTP in incorrect format and upload to orther server, this is not a panel problem, happen in cpanel, plesk, directadmin and webservers without panel, the big problem here is than people upload file names with special characters.

You can try download afected files with FTP in binary mode or forcing utf8 and upload it to new server to fix, also take a look locales and charset setup in both server.

May you think is a vesta issue, but vesta just run a tar / gz, so is a tar / gz issue or your server charset.

You also can try rsync your files rsync, should handle this problem in most cases.

----------

Mire comendación, no suba archivos con caracteres especiales, genera muchos problemas en muchos sitios y muchos paneles, creame que no es un problema de vestacp.