Page 3 of 5

Re: [1.1 Beta] VestaCP x AdminLTE (a Theme for VestaCP)

Posted: Sun Jul 31, 2016 1:34 pm
by imperio
Can you make some screenshots?
I think this theme not working after refactoring, which was in the 0.9.8-16

Re: [1.1 Beta] VestaCP x AdminLTE (a Theme for VestaCP)

Posted: Sun Jul 31, 2016 1:54 pm
by puls
There is nothing to shot, because its just blank, but i can see the source.
Tried with Firefox 44 and newest Opera, something is missing, i did not install with this bower thing, just download and extract the build 1.2, should i better git checkout?

Server is running Debian 7.11, PHP 5.5, nginx

*edit:
so i have tried to resolve the error, looking each log i could find, but no error at all.
enabled error debug level on php-fpm.conf in vesta dir (should be right?) and also set short_open_tag in the conf, but nothing works.
on a new private window i see the login form, i can login, but then just blank page.

will reinstall with debian 8 and try again (which i also want), hope it will work then.

Re: [1.1 Beta] VestaCP x AdminLTE (a Theme for VestaCP)

Posted: Sun Jul 31, 2016 6:30 pm
by imperio
you should waiting solution from author of this theme

Re: [1.1 Beta] VestaCP x AdminLTE (a Theme for VestaCP)

Posted: Sun Jul 31, 2016 7:01 pm
by puls
No, i am testing and try to figure out what's the problem, its a new server and i also want to test the new distributions, which performs best and bring best results.

It's strange that there are no error logs, even PHP brings no error up, when i switch the output on.

Re: [1.1 Beta] VestaCP x AdminLTE (a Theme for VestaCP)

Posted: Sun Jul 31, 2016 11:18 pm
by imperio
puls wrote:Not working with newest -16 version, just got a blank screen.

Can someone confirm or is on my side something wrong?

Normal interface works when i copy the backup.
Confirmed

Re: [1.1 Beta] VestaCP x AdminLTE (a Theme for VestaCP)

Posted: Fri Aug 05, 2016 11:25 am
by suassive
I must say, you beat me to it. I was too, developing my very own personal template for VestaCP. Although, yours looks 100 times better.

Re: [1.1 Beta] VestaCP x AdminLTE (a Theme for VestaCP)

Posted: Tue Aug 09, 2016 7:26 pm
by puls
imperio wrote:
puls wrote:Not working with newest -16 version, just got a blank screen.

Can someone confirm or is on my side something wrong?

Normal interface works when i copy the backup.
Confirmed
Thanks! Too bad that themes can break, would be good for future updates if the can get seperated, but default also working ;).

Re: [1.1 Beta] VestaCP x AdminLTE (a Theme for VestaCP)

Posted: Sat Aug 13, 2016 7:25 am
by lugisec
Hello,

First thing, I want to thank you Louis and Vesta Team for your hard work to get VestaCP to be better. I was tried to install this theme, and it really show blank! I see some JS error on console log, after a while trying to fix, it was succeed!

Here are solution that I was found to make it work:

1. Change header file as below:

Code: Select all

<!doctype html>
<html lang="en">
<head>
  <meta charset="utf-8">
  <link rel="icon" href="/images/favicon.ico" type="image/x-icon">
  <title>Vesta - <?="$TAB"?> </title>

<link rel="stylesheet" href="/css/styles.min.css?1446554103">
<link type="text/css" href="/css/jquery-custom-dialogs.css?1446554103" rel="stylesheet" />

    <!-- AdminLTE Start -->
    <meta content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=no" name="viewport">
    <meta name="theme-color" content="#1f2738">

    <link rel="stylesheet" type="text/css" href="/bower_components/bootstrap/dist/css/bootstrap.min.css" />
    <link rel="stylesheet" type="text/css" href="/bower_components/AdminLTE/dist/css/skins/_all-skins.min.css">
    <link rel="stylesheet" type="text/css" href="/bower_components/AdminLTE/dist/css/AdminLTE.min.css" />
    <link rel="stylesheet" type="text/css" href="/bower_components/font-awesome/css/font-awesome.min.css" />
    <link rel="stylesheet" type="text/css" href="/bower_components/AdminLTE/dist/css/skins/_all-skins.min.css" />
    <link rel="stylesheet" type="text/css" href="/bower_components/sweetalert/dist/sweetalert.css" />
    
    <link rel="stylesheet" type="text/css" href="/louislam/css/main.css?1446554" />

    <script src="/bower_components/jquery/dist/jquery.min.js"></script>
    <script src="/bower_components/bootstrap/dist/js/bootstrap.min.js"></script>
    <script src="/bower_components/sweetalert/dist/sweetalert.min.js"></script>
    <!-- AdminLTE End -->


	<!-- jQuery too old, comment out this -->
	<!--<script type="text/javascript" src="/js/jquery-1.7.2.min.js?1446554103"></script>-->
	<script type="text/javascript" src="/js/jquery.cookie.js?1446554103"></script>
	<script type="text/javascript" src="/js/jquery-ui-1.8.20.custom.min.js?1446554103"></script>
	<script type="text/javascript" src="/js/hotkeys.js?1446554103"></script>
	<script type="text/javascript" src="/js/events.js?1446554103"></script>
	<!-- script type="text/javascript" src="/js/i18n.js.php"></script -->

	<script language="text/javascript" type="text/javascript">
		var checked = false;
		var frmname = '';

		function checkedAll(frmname) {
			if ($('.l-unit.selected').length > 0) {
				$('.l-unit').removeClass("selected");
				$('.ch-toggle').attr("checked", false);
				$('.toggle-all').removeClass('clicked-on');
			}
			else {
				$('.l-unit').addClass("selected");
				$('.ch-toggle').attr("checked", true);
				$('.toggle-all').addClass('clicked-on');
			}
		}

		function doSearch(url) {
			var url = url || '/search/';
			var loc = url + '?q=' + $('.search-input').val();

			location.href = loc;
			return false;
		}

		$(document).ready(function(){
			if($('.body-login')[0]){
			  $('input').first().focus();
			}

			$(".submenu-select-dropdown").each(function(){
				$(this).wrap("<span class='submenu-select-wrapper'></span>");
				$(this).after("<span class='holder'></span>");
			});
			$(".submenu-select-dropdown").change(function(){
				var selectedOption = $(this).find(":selected").text();
				$(this).next(".holder").text(selectedOption);
			}).trigger('change');
			$('.to-top').bind('click', function(evt) {
				$("html, body").animate({ scrollTop: 0 }, "normal");
			});
		});
		
		//
		//  GLOBAL SETTINGS
		//
		GLOBAL = {};
		GLOBAL.FTP_USER_PREFIX  = 'admin_';
		GLOBAL.DB_USER_PREFIX   = 'admin_';
		GLOBAL.DB_DBNAME_PREFIX = 'admin_';
		GLOBAL.AJAX_URL = '';
	</script>

	<script type="text/javascript" src="/js/app.js?1446554103"></script>
	<script type="text/javascript" src="/js/templates.js?1446554103"></script>
	<script src="/bower_components/AdminLTE/dist/js/app.js"></script>
	<script src="/louislam/js/app.js"></script>

</head>
<body class="body-<?=strtolower($TAB)?> lang-<?=$_SESSION['language']?>">
The problem in this file if missing GLOBAL variable. After added GLOBAL variable, we need to change loading order of some JS script file below <script> block.

2. Open file /usr/local/vesta/web/js/jquery-1.7.2.min.js and empty it's content. Because reload jQuery again make all $.AdminLTE variable destroy (jQuery was loaded at <head> block).

3. You need to use theme package contains these 3 folder: bower_components, louislam, templates (source from GitHub don't have bower_components). You can find full download package on post in this thread.

I hope these trick can help you make AdminLTE theme working on your server!

Have a nice day!

Re: [1.1 Beta] VestaCP x AdminLTE (a Theme for VestaCP)

Posted: Sat Aug 13, 2016 6:30 pm
by elysiumservers
Installed, looks amazing !

The file explorer works perfectly, it just takes the standard template without any problems so you can update your information reflecting that file explorer just works out of the box too.

Re: [1.1 Beta] VestaCP x AdminLTE (a Theme for VestaCP)

Posted: Sat Aug 13, 2016 6:55 pm
by elysiumservers
When listing DNS entries, nothing shows up :( all empty space

Adding this shows up again:

.l-unit__stats {
display: block !important;
float: left;
}

I don't know why that class has a "display:none", that will blank all the entries.