Page 4 of 5

Re: [1.1 Beta] VestaCP x AdminLTE (a Theme for VestaCP)

Posted: Sun Aug 14, 2016 5:39 am
by lugisec
As Louis was said, he use Javascript to transform default html structure to AdminLTE html structure. So, I think display:none attribute is used to hide content before transform completed.
elysiumservers wrote:When listing DNS entries, nothing shows up :( all empty space

Adding this shows up again:

.l-unit__stats {
display: block !important;
float: left;
}

I don't know why that class has a "display:none", that will blank all the entries.

Re: [1.1 Beta] VestaCP x AdminLTE (a Theme for VestaCP)

Posted: Tue Aug 16, 2016 1:31 pm
by LukeKniep
Have you built a theme system for Vestacp or are you editing the admin template? If your editing the template it will be over written when Vesta updates unfortunately and will need to add the template files again manually [delete by moderator:spam] acording to spell each template.

Re: [1.1 Beta] VestaCP x AdminLTE (a Theme for VestaCP)

Posted: Tue Aug 16, 2016 6:44 pm
by lugisec
LukeKniep wrote:Have you built a theme system for Vestacp or are you editing the admin template? If your editing the template it will be over written when Vesta updates unfortunately and will need to add the template files again manually [delete by moderator:spam] acording to spell each template.
I think this is not a big problem with this template. I think we just need to backup header, footer template files and reupload after updated. Because all other things is processed by JS, and these JS, CSS files was separated to their folder.

But, if Vesta changes all HTML structure and this theme can't handle any more. I will go back to default :)

Re: [1.1 Beta] VestaCP x AdminLTE (a Theme for VestaCP)

Posted: Thu Aug 18, 2016 1:40 pm
by duy13
Please check it not work on "Latest update Vesta 0.9.8-16 from June 27 2016"

Re: [1.1 Beta] VestaCP x AdminLTE (a Theme for VestaCP)

Posted: Sun Aug 21, 2016 5:45 am
by lugisec
Hello everybody,

I was packed a full template in compressed file below. With every modificated files, I was preserved original file with ".backup" name. I was tested it on my server without any problem. Just extract and upload it into /usr/local/vesta/web directory.

Google Drive link: https://drive.google.com/open?id=0B_vUv ... 1VHRmRjRDQ

Have a nice weekend!

Re: [1.1 Beta] VestaCP x AdminLTE (a Theme for VestaCP)

Posted: Sat Sep 03, 2016 7:15 am
by buracat
Thanks for sharing. But, dns not showing.

Image

Re: [1.1 Beta] VestaCP x AdminLTE (a Theme for VestaCP)

Posted: Sat Nov 26, 2016 10:17 pm
by elysiumservers
Thanks Louis.

Would it be possible to update the Theme to support the newest features of Vesta such as Lets Encrypt support?


I tried to copy my backup again to the new vesta update but Lets Encrypt wont show up and it's a big feature for my customers, but so was this beautiful theme.

Re: [1.1 Beta] VestaCP x AdminLTE (a Theme for VestaCP)

Posted: Mon Dec 19, 2016 11:06 pm
by elysiumservers
So no news?

I am so sad, this was by far the best thing that happened to my Vesta service, any news if this is ever gonna get fixed to work with the new Vesta with Lets Encrypt?

Re: [1.1 Beta] VestaCP x AdminLTE (a Theme for VestaCP)

Posted: Thu Dec 22, 2016 10:46 am
by cboursinos
Very nice

Re: [1.1 Beta] VestaCP x AdminLTE (a Theme for VestaCP)

Posted: Fri Dec 23, 2016 11:36 am
by pandabb
this looks good i hope it supports the new vesta update.