Look for php 5.3

Questions regarding the Web Server
Apache + Nginx, Nginx + PHP5-FPM
Forum rules
Before creating a new topic or reply on the forum you should fill out additional fields "Os" and "Web" in your profile section.
In case of violation, the topic can be closed or response from the support will not be received.
odies
Posts: 10
Joined: Thu Dec 19, 2013 2:15 pm

Look for php 5.3

Postby odies » Wed May 17, 2017 1:01 pm

Hey. I read all the forum topics. All available instructions no longer work. Someone, share a working instruction on how to install PHP 5.3 on VestaCP. I do not need a multi version! I'm looking for version 5.3. Thank you in advance

skurudo
VestaCP Team
Posts: 7808
Joined: Fri Dec 26, 2014 2:23 pm
Contact:

Re: Look for php 5.3

Postby skurudo » Wed May 17, 2017 3:44 pm

Which OS do you use?
-> DigitalOcean competition - please, support us
-> fix for phpmyadmin - nice and sweet now

odies
Posts: 10
Joined: Thu Dec 19, 2013 2:15 pm

Re: Look for php 5.3

Postby odies » Wed May 17, 2017 3:49 pm

skurudo wrote:Which OS do you use?

i can use any OS.

skurudo
VestaCP Team
Posts: 7808
Joined: Fri Dec 26, 2014 2:23 pm
Contact:

Re: Look for php 5.3

Postby skurudo » Wed May 17, 2017 3:51 pm

-> DigitalOcean competition - please, support us
-> fix for phpmyadmin - nice and sweet now

odies
Posts: 10
Joined: Thu Dec 19, 2013 2:15 pm

Re: Look for php 5.3

Postby odies » Thu May 18, 2017 9:55 pm

Both version not work

First -
/usr/bin/env: php: No such file or directory


Second:
root@vps378755:~# apt-get build-dep -y php5
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: You must put some 'source' URIs in your sources.list
root@vps378755:~# apt-get install libt1-dev libonig-dev libmcrypt-dev libreadline-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package libt1-dev
E: Unable to locate package libonig-dev
E: Unable to locate package libmcrypt-dev
E: Unable to locate package libreadline-dev


OVH VPS, Ubuntu 14.04/Debian7,8

UPD:
If you get tis errors, add to you /etc/apt/sources.list this
deb-src http://archive.ubuntu.com/ubuntu trusty main restricted #Added by software-properties
deb-src http://gb.archive.ubuntu.com/ubuntu/ trusty restricted main universe multiverse #Added by software-properties
deb-src http://gb.archive.ubuntu.com/ubuntu/ trusty-updates restricted main universe multiverse #Added by software-properties
deb-src http://gb.archive.ubuntu.com/ubuntu/ trusty-backports main restricted universe multiverse #Added by software-properties
deb-src http://security.ubuntu.com/ubuntu trusty-security restricted main universe multiverse #Added by software-properties
deb-src http://gb.archive.ubuntu.com/ubuntu/ trusty-proposed restricted main universe multiverse #Added by software-properties

After editing sources.list, run sudo apt-get update

Now, fine work 5.4 - 7.0:
https://anikin.pw/all/multiversionnost- ... s-vestacp/

But i need php 5.3 + ionCube loader >= 4.4


Return to “Web Server”



Who is online

Users browsing this forum: No registered users and 2 guests

cron