Page 1 of 1

[HowTo]Upgrade PHP 5.6 to PHP 7.2 on CentOS VestaCP

Posted: Tue Sep 11, 2018 6:27 pm
by xorro
In this tutorial I’ll show you how to upgrade PHP 5.6.xx which is by default installed by Vesta CP during installation to PHP 7.2.xx latest, I’ve tested on many server before writing this tutorial and its just working fine without any issue hence it is safe to upgrade to PHP 7.2, part of this tutorial is copied from remi repository.

Why upgrade to php 7.2 – Because it will give you security & performance boost + KICK, since WordPress will load much faster and uses less resources.

STEP 1 :

Install Remi Repository and EPEL Repository on your server :

RHEL 7

Code: Select all

wget https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm
wget http://rpms.remirepo.net/enterprise/remi-release-7.rpm
rpm -Uvh remi-release-7.rpm epel-release-latest-7.noarch.rpm
subscription-manager repos --enable=rhel-7-server-optional-rpms
RHEL 6

Code: Select all

wget https://dl.fedoraproject.org/pub/epel/epel-release-latest-6.noarch.rpm
wget http://rpms.remirepo.net/enterprise/remi-release-6.rpm
rpm -Uvh remi-release-6.rpm epel-release-latest-6.noarch.rpm
rhn-channel --add --channel=rhel-$(uname -i)-server-optional-6
CentOS 7

Code: Select all

wget https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm
wget http://rpms.remirepo.net/enterprise/remi-release-7.rpm
rpm -Uvh remi-release-7.rpm epel-release-latest-7.noarch.rpm
CentOS 6

Code: Select all

wget https://dl.fedoraproject.org/pub/epel/epel-release-latest-6.noarch.rpm
wget http://rpms.remirepo.net/enterprise/remi-release-6.rpm
rpm -Uvh remi-release-6.rpm epel-release-latest-6.noarch.rpm
STEP 2 :

After you have installed repository you need to follow some extra configurations :
Run this command one by one for RHEL or CentOS

Code: Select all

yum install yum-utils
yum-config-manager --enable remi-php72
STEP 3 :

Now just run this command :

Code: Select all

yum update -y
You’ll see php packages are getting updated, After the update process you need to restart Apache server/php-fpm-(nginx) and check the php version from by below mentioned command:

Code: Select all

php -v

Code: Select all

[root@server ~]# php -v
PHP 7.2.7 (cli) (built: Jun 20 2018 08:21:26) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.2.7, Copyright (c) 1999-2018, by Zend Technologies
Troubleshoot

If php upgrade process fails (no update/nothing happens) or you upgraded previously from 5.6 to 7.0/7.1 then you need to run this commands to disable php 5.6/7.0/7.1 :

Code: Select all

yum-config-manager --disable remi-php56
yum-config-manager --disable remi-php70
yum-config-manager --disable remi-php71
After that follow the tutorial from STEP 2 again.

Re: [HowTo]Upgrade PHP 5.6 to PHP 7.2 on CentOS VestaCP

Posted: Thu Sep 13, 2018 2:16 am
by valentine

Re: [HowTo]Upgrade PHP 5.6 to PHP 7.2 on CentOS VestaCP

Posted: Wed Sep 19, 2018 12:03 am
by pipoy
Wow thank you!

Re: [HowTo]Upgrade PHP 5.6 to PHP 7.2 on CentOS VestaCP

Posted: Tue Nov 27, 2018 10:27 pm
by pro100ssk
.

Re: [HowTo]Upgrade PHP 5.6 to PHP 7.2 on CentOS VestaCP

Posted: Sat Dec 29, 2018 7:43 pm
by sandy

Re: [HowTo]Upgrade PHP 5.6 to PHP 7.2 on CentOS VestaCP

Posted: Mon Apr 08, 2019 5:07 am
by lex0013
According to this manual there will be an update from 7.2 to 7.3

Re: [HowTo]Upgrade PHP 5.6 to PHP 7.2 on CentOS VestaCP

Posted: Sat Oct 26, 2019 9:57 am
by zzmaster
I'm stuck with (CentOS 6)

Code: Select all

[root@celebraza ~]# rhn-channel --add --channel=rhel-$(uname -i)-server-optional-6
-bash: rhn-channel: command not found
It's strange that topic starter didn't face this since rhn-channel not in standard configuration. The only googled related page
https://support.nagios.com/forum/viewto ... =6&t=50150
has solutions that don't work for me.

Can anybody help?

Re: [HowTo]Upgrade PHP 5.6 to PHP 7.2 on CentOS VestaCP

Posted: Mon Nov 04, 2019 3:33 pm
by lokutus
Hello,

i followed your desc and PHP is 7.4.0RC5 version now, but i have some issue in PHPmyadmin. How can i solve this Problem?
need i downgrade PHP or anything else?

Image

Image