Page 4 of 6

Re: Error Code: 15 - SSL - Lets Encrypt

Posted: Mon May 06, 2019 3:47 pm
by droidman
Still suffering from this today.

Re: Error Code: 15 - SSL - Lets Encrypt

Posted: Mon May 06, 2019 10:23 pm
by pepsi
The aforementioned fix in v-add-letsencrypt-domain should address the issue. It has already been committed to the GitHub repo and will be included in the next release. Make sure you're on the latest version of VestaCP.

Re: Error Code: 15 - SSL - Lets Encrypt

Posted: Thu May 09, 2019 10:22 am
by fanok
I have same problem.
v-add-letsencrypt-domain file is right $domain and I did reinstallation.
The problem same still.

Re: Error Code: 15 - SSL - Lets Encrypt

Posted: Wed May 15, 2019 2:07 pm
by Mariop
fanok wrote:
Thu May 09, 2019 10:22 am
I have same problem.
v-add-letsencrypt-domain file is right $domain and I did reinstallation.
The problem same still.
I have exactly the same problem. Can not decide.
Did you succeed? .

Re: Error Code: 15 - SSL - Lets Encrypt

Posted: Wed May 15, 2019 2:27 pm
by droidman
No, still waiting for an update. Sometimes it works on new vesta installations, sometimes i make a new server and fails and never works, same datacenter, same configuration, very weird

Re: Error Code: 15 - SSL - Lets Encrypt

Posted: Wed May 15, 2019 2:31 pm
by Mariop
droidman wrote:
Wed May 15, 2019 2:27 pm
No, still waiting for an update. Sometimes it works on new vesta installations, sometimes i make a new server and fails and never works, same datacenter, same configuration, very weird
I'm also waiting for the update. Why then do it for a very long time.
This is a global problem ...

Re: Error Code: 15 - SSL - Lets Encrypt

Posted: Wed May 15, 2019 2:36 pm
by droidman
yeah, free projects like vesta save us every day but they look a lot slower than paid solutions for obvious reasons, i would love to be able to help them fix the problem but unfortunately that is not my area of expertise

Re: Error Code: 15 - SSL - Lets Encrypt

Posted: Thu May 16, 2019 11:28 am
by sansansan
Hi!

Have the same problem.
Os:Ubuntu 16.04
Web:nginx + php-fpm

Nothing helps. I have error 15 when are I'm trying to add the Lets Encrypt to a domain and click Save.

Re: Error Code: 15 - SSL - Lets Encrypt

Posted: Thu May 16, 2019 11:52 pm
by dsystem
Some updates have occurred on this subject after the release of version 0.9.8-24

You can do direct update of github -> https://github.com/serghey-rodin/vesta

Backup existing

Code: Select all

zip -r /root/vesta-back.zip /usr/local/vesta
Get latest version from Git

Code: Select all

git clone https://github.com/serghey-rodin/vesta.git /root/vestaNew
yes | cp -rf /root/vestaNew/* /usr/local/vesta

Re: Error Code: 15 - SSL - Lets Encrypt

Posted: Fri May 17, 2019 1:05 am
by m0ze
Faced the same problem today, after several attempts and two reinstalls I've fixed this error by disabling two options for my domain on CloudFlare account: "force HTTPS" and "fix HTTP" (later I've tested this steps for two other domains - all the same things). Maybe this will help someone.