Page 1 of 1

php ini settings

Posted: Mon Jul 06, 2020 1:01 pm
by aiweller
Hi.

I have changed the max_execution_time and max_input_time setting in the php.ini configuration file but it is not reflecting in the site. I've set 60 as the max_execution_time, but when I check in phpinfo, it's showing 20. I'm changing it at VestaCP > Server > Apache2 > Configure PHP.ini. Is there any other place that I need to change the value?

Thanks,
Ashley

Re: php ini settings

Posted: Mon Jul 06, 2020 1:26 pm
by tlozano
Has you restarted the php service after changes?
Do you have more than one php.ini?

Re: php ini settings

Posted: Tue Jul 07, 2020 12:30 pm
by aiweller
tlozano wrote:
Mon Jul 06, 2020 1:26 pm
Has you restarted the php service after changes?
Do you have more than one php.ini?
Hi,

Yes, I have. Even restarted the server many times. phpinfo shows the php file is located in /etc/php/7.4/fpm/. I've manually changed the values in the php.ini file directly, but it does not take effect.

Re: php ini settings

Posted: Tue Jul 07, 2020 1:03 pm
by aiweller
Hi,

I've found it.. Seems the settings are in another file located at /etc/php/7.4/fpm/pool.d/<<domain>>.conf. The file is being created when I create a domain in the panel. Is there any way I could change the original values so that next time I create a domain, I don't have to come to this file and change the values? Or better still, remove the overriding values?

Re: php ini settings

Posted: Thu Jul 09, 2020 12:45 am
by dpeca
What Linux distribution do you use?
And is php7.4 automaticaly installed or you additionaly installed it?

These are very important questions.