Page 1 of 1

SMTP server login fails - passwd-file

Posted: Thu Mar 09, 2017 12:05 pm
by starter
I am no longer able to send emails with my server, there is an issue with Dovecot's login.


Code: Select all

auth: Error: passwd-file(copier,123.456.123.456): stat(/etc/exim4/domains//passwd) failed: No such file or directory
As you can see a directory name is missing in the path.
In the Dovecot configuration this missing string seems to be the %d variable.


Code: Select all

passdb {
  driver = passwd-file
  args = scheme=MD5-CRYPT username_format=%n /etc/exim4/domains/%d/passwd

userdb {
  driver = passwd-file
  args = username_format=%n /etc/exim4/domains/%d/passwd
Any idea ? I tried to rebuild the user, but that did not fix the issue.

Re: SMTP server login fails - passwd-file

Posted: Sun Mar 25, 2018 5:04 am
by Francis
I'm going to respond to this because I ran into the same issue after a recent Dovecot upgrade. If you choose to rebuild the certificate, the file permissions need touched. The following command fixed this issue for me.

Code: Select all

chmod 640 /usr/local/vesta/ssl/*