Roundcube: relay not permitted Topic is solved

Questions regarding the Mail Server
Dovecot, Exim, RoundCube
Forum rules
Before creating a new topic or reply on the forum you should fill out additional fields "Os" and "Web" in your profile section.
In case of violation, the topic can be closed or response from the support will not be received.
Posts: 4
Joined: Mon Dec 19, 2016 7:20 am

Roundcube: relay not permitted

Postby b79 » Wed Sep 13, 2017 5:05 am

Hello Vesta Community!

I have tried to search the forum for the issue I'm having but haven't been able to find anything to help.

Currently, I can't send e-mail from the Roundcube installation on the server. A box appears when I hit send on a message and says "SMTP Error (550): Failed to add recipient "any@email.address" (relay not permitted)."

In the exim reject log I see:
reject.log:2017-09-13 14:59:09 H=( [::1] F=<sending@email.address> rejected RCPT <to@external.domain>: relay not permitted

I don't often use Roundcube unless I'm testing something quickly. So I'm not sure when this started, I do recall a Roundcube update that yum installed a while ago.

If I setup the sending account in an e-mail client (like Thunderbird) with STARTTLS, I can send and receive, no problem.

I have a feeling something in exim might not be letting Roundcube send mail, but the settings I tried to alter made no difference.

Any suggestions would be appreciated, thanks!


Posts: 4
Joined: Mon Dec 19, 2016 7:20 am

Re: Roundcube: relay not permitted

Postby b79 » Fri Oct 20, 2017 5:25 am


No one else has this problem? I still haven't resolved it!


Posts: 4
Joined: Mon Dec 19, 2016 7:20 am

Re: Roundcube: relay not permitted  Topic is solved

Postby b79 » Sat Oct 21, 2017 3:26 am


Roundcube was connecting to exim using the IPv6 localhost ::1

The exim config only had the IPv4 localhost address as an allowed relay.

hostlist relay_from_hosts = : ::::1/128

I added the underlined to the exim config and now I can send mail from Roundcube again.


Return to “Mail Server”

Who is online

Users browsing this forum: No registered users and 3 guests