Page 1 of 1

problem sending mail to outlook

Posted: Wed Feb 06, 2019 2:31 pm
by verus001
Hi,

I can send mail to gmail, other addresses, but not outlook and there is nothing to see in the logs (queued for delivery).
No problem sending mail from gmail to outlook.
How can I solve this please?
thanks.
V.

Re: problem sending mail to outlook

Posted: Wed Feb 06, 2019 5:36 pm
by fasttrackhost
If you can send emails to Gmail it means your server its ok.

If messages dont go through Outlook in the mailbox of the receiver you must get a automated return message from Outlook to your "sender@yourdomain.com" being "sender" the email address you used to send the messages.

If you dont see any messages from Outlook automated system maybe you dont receive emails. Try sending yourself a email from Gmail and then from Outlook. If you get it from Gmail your server its OK and you must get it from Outlook.

EDIT: for testing sending and receiving emails always do it directly from your server (in vestacp go to "EMAILS" and "Open Webmail"), and only afterwards try sending emails from other external aplications. Thats because sometimes you must allow external senders to reroute emails thorugh your server in the "SPF" record in DNS settings. Normaly Vestacp default configuration wont reroute externall emails coming from other domains (and thats a very good thing). You must allow each external sender to send emails using your server in your SPF record. Dont create severral SPF records, just add each external domain/ip before the " ~all"

Re: problem sending mail to outlook

Posted: Thu Feb 07, 2019 8:32 am
by verus001
Thank you for your answer and helping, I could send to and receive from all domains that I tested except outlook.com
Because of your spf remark I checked the spf record I have and I found a mistake.
Now I corrected it and it is (there was a fault in the ip address):

"v=spf1 a mx ip4:x.x.x.x a:spf.spamexperts.axc.nl ~all"

(I changed the ip number with the X's which is my ip address).

Now I can send to outlook to! So thanks again for helping, I owe you a beer!

One question about the current record, what does the spf.spamexperts.axc.nl mean? Is it wrong?
When I generate a spf on internet I get this:

"v=spf1 mx a ip4:x.x.x.x ~all"

(I changed my ip number with the X's).
Which one should I use?

Thanks,
V.

Re: problem sending mail to outlook

Posted: Fri Feb 08, 2019 11:56 am
by fasttrackhost
If you dont recongnize "spf.spamexperts.axc.nl" u should delete it

every IP and url in the SPF record its allowed to send emails using your server remotely. So you are right now allowing spf.spamexperts.axc.nl to send emails using your system and in your name.

For example using SPF records you can allow google.com to send emails using your server like this: "v=spf1 a mx ip4:x.x.x.x google.com ~all"

if you want to allow "example.com" too, just add it: "v=spf1 a mx ip4:x.x.x.x google.com example.com ~all"

so maybe you should delete "a:spf.spamexperts.axc.nl"

check if u have A type Records with "spamexperts.axc.nl" and delete them too.

That SPF record its not by default in Vestacp so if you didnt put it there you should find out how it got there.

Re: problem sending mail to outlook

Posted: Fri Feb 08, 2019 11:59 am
by verus001
Thanks, it is on my DNS hosting.
I don't use VESTA dns options, should I use them instead of my provider?