Page 1 of 1

Fix Exim in VestaCP

Posted: Sun Jul 07, 2019 10:04 am
by tom256
Today I've tried to update my server with below command:

Code: Select all

sudo apt-get update && time sudo apt-get dist-upgrade
But it returns below error about Exim, How Can I fix it?

Code: Select all

The following package was automatically installed and is no longer required:
  libpq5
Use 'sudo apt autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] Y
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
  LANGUAGE = (unset),
  LC_ALL = (unset),
  LC_MONETARY = "es_X...",
    are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("en_US.UTF-8").
locale: Cannot set LC_ALL to default locale: No such file or directory
Setting up exim4-daemon-light (4.86.2-2ubuntu2.3) ...
locale: Cannot set LC_ALL to default locale: No such file or directory
Job for exim4.service failed because the control process exited with error code. See "systemctl status exim4.service" and "journalctl -xe" for details.
invoke-rc.d: initscript exim4, action "start" failed.
‚óŹ exim4.service - LSB: exim Mail Transport Agent
   Loaded: loaded (/etc/init.d/exim4; bad; vendor preset: enabled)
   Active: failed (Result: exit-code) since Sun 2019-07-07 13:33:38 +0430; 4ms ago
     Docs: man:systemd-sysv-generator(8)
  Process: 2834 ExecStart=/etc/init.d/exim4 start (code=exited, status=1/FAILURE)

Jul 07 13:33:38 mypanel.site.com systemd[1]: Starting LSB: exim Mail Transport Agent...
Jul 07 13:33:38 mypanel.site.com exim4[2834]:  * Starting MTA
Jul 07 13:33:38 mypanel.site.com exim4[2834]: 2019-07-07 13:33:38 Exim configuration error in line 40 of /var/lib/exim....tmp:
Jul 07 13:33:38 mypanel.site.com exim4[2834]:   main option "acl_smtp_mime" unknown
Jul 07 13:33:38 mypanel.site.com exim4[2834]: Invalid new configfile /var/lib/exim4/config.autogenerated.tmp, not installing
Jul 07 13:33:38 mypanel.site.com exim4[2834]: /var/lib/exim4/config.autogenerated.tmp to /var/lib/exim4/config.autogenerated
Jul 07 13:33:38 mypanel.site.com systemd[1]: exim4.service: Control process exited, code=exited status=1
Jul 07 13:33:38 mypanel.site.com systemd[1]: Failed to start LSB: exim Mail Transport Agent.
Jul 07 13:33:38 mypanel.site.com systemd[1]: exim4.service: Unit entered failed state.
Jul 07 13:33:38 mypanel.site.com systemd[1]: exim4.service: Failed with result 'exit-code'.
Hint: Some lines were ellipsized, use -l to show in full.
dpkg: error processing package exim4-daemon-light (--configure):
 subprocess installed post-installation script returned error exit status 1
E: Sub-process /usr/bin/dpkg returned an error code (1)

real  2m34.638s
user  0m4.896s
sys  0m4.180s

Re: Fix Exim in VestaCP

Posted: Sun Jul 07, 2019 7:04 pm
by dreiggy
Hi,

seems error is with your exim configuration:

Code: Select all

Jul 07 13:33:38 mypanel.site.com exim4[2834]: 2019-07-07 13:33:38 Exim configuration error in line 40 of /var/lib/exim....tmp:
Jul 07 13:33:38 mypanel.site.com exim4[2834]:   main option "acl_smtp_mime" unknown
Jul 07 13:33:38 mypanel.site.com exim4[2834]: Invalid new configfile /var/lib/exim4/config.autogenerated.tmp, not installing
Try to comment out ACL block: acl_smtp_mime

Re: Fix Exim in VestaCP

Posted: Tue Jul 09, 2019 10:21 am
by tom256
tried to comment that from VestaCP web panel, after saving the configuration editor, the server hanged out and rebooted!
It didn't work

Re: Fix Exim in VestaCP

Posted: Tue Jul 09, 2019 11:35 am
by tom256
If I want to "reinstall" Exim, How can I do this? I mean removing it, and then installing it again.

Please give me the re-installation commands for Ubuntu 16.04 and then if I need some configurations that Exim4 can work properly with VestaCP again like before, please give me those configuration/ububtu commands too.
Thanks anyone who will help!

Re: Fix Exim in VestaCP

Posted: Tue Jul 09, 2019 1:56 pm
by dreiggy
You should just remove remove exim with apt tool and then install back it.

Default exim configuration you can find here: https://github.com/serghey-rodin/vesta/ ... 16.04/exim

Re: Fix Exim in VestaCP

Posted: Sat Jul 13, 2019 9:27 pm
by tom256

Code: Select all

apt-get install exim4-daemon-heavy

That's whatworked for me.