Page 1 of 1

Error prevents sending by Exim (Broken pipe)

Posted: Tue May 19, 2020 9:28 pm
by raapcoelho
Hello,

I use VestaCP daily on several servers for a little over a year, but this week I started to face this error:

Code: Select all

2020-05-19 18:23:08 cwd=/root 6 args: send-mail -i -r "Contato <contato@myserver.com>" -- myemail@gmail.com
2020-05-19 18:23:08 1jb9hc-000667-Hq <= contato@myserver.com U=root P=local S=541 id=5ec44e3c.hWZXxWtx0Bnb9xH+%contato@myserver.com T="E-mail de teste" from <contato@myserver.com> for myemail@gmail.com
2020-05-19 18:23:08 cwd=/var/spool/exim 3 args: /usr/sbin/exim -Mc 1jb9hc-000667-Hq
2020-05-19 18:23:08 1jb9hc-000667-Hq H=gmail-smtp-in.l.google.com [108.177.15.27] Broken pipe
2020-05-19 18:23:08 1jb9hc-000667-Hq H=alt1.gmail-smtp-in.l.google.com [209.85.233.27] Broken pipe
2020-05-19 18:23:08 1jb9hc-000667-Hq H=alt2.gmail-smtp-in.l.google.com [142.250.4.27] Broken pipe
2020-05-19 18:23:08 1jb9hc-000667-Hq H=alt3.gmail-smtp-in.l.google.com [64.233.189.26] Broken pipe
2020-05-19 18:23:08 1jb9hc-000667-Hq H=alt4.gmail-smtp-in.l.google.com [74.125.28.27] Broken pipe
2020-05-19 18:23:08 1jb9hc-000667-Hq == myemail@gmail.com R=rota_vt T=remote_smtp defer (32): Broken pipe
I have no idea what this error may be, I did nothing different on the servers. Can someone help me?

O.S.: CentOS Linux release 7.8.2003 (Core)
Exim: exim-4.93-2.el7.x86_64

Thank you.

Re: Error prevents sending by Exim (Broken pipe)

Posted: Thu May 21, 2020 6:51 am
by vpsops
I'm having the right same problem on various servers

Re: Error prevents sending by Exim (Broken pipe)

Posted: Thu May 21, 2020 2:09 pm
by pcready.cl
seems to be a blocking or timeout problem

Re: Error prevents sending by Exim (Broken pipe)

Posted: Thu May 21, 2020 2:50 pm
by raapcoelho
I formatted the server, installed Exim without VestaCP, it works normal, so I believe I can rule out that it is a problem in OpenVZ...
I still have no solution.

Re: Error prevents sending by Exim (Broken pipe)

Posted: Fri May 22, 2020 4:29 pm
by raapcoelho
I dowgrade exim to: exim-4.92.3-1.el7.x86_64.rpm

And apparently it worked for me!

Re: Error prevents sending by Exim (Broken pipe)

Posted: Fri May 22, 2020 4:32 pm
by pcready.cl
raapcoelho wrote:
Fri May 22, 2020 4:29 pm
I dowgrade exim to: exim-4.92.3-1.el7.x86_64.rpm

And apparently it worked for me!
How do this?

Re: Error prevents sending by Exim (Broken pipe)

Posted: Fri May 22, 2020 5:35 pm
by raapcoelho
pcready.cl wrote:
Fri May 22, 2020 4:32 pm
raapcoelho wrote:
Fri May 22, 2020 4:29 pm
I dowgrade exim to: exim-4.92.3-1.el7.x86_64.rpm

And apparently it worked for me!
How do this?
Download this file and send it to the server:
http://rpm.pbone.net/index.php3/stat/4/ ... 4.rpm.html

Run the commands:

yum remove exim -y
yum localinstall exim-4.92.3-1.el7.x86_64.rpm -y
rm -Rf /etc/exim/exim.conf
mv /etc/exim/exim.conf.rpmsave /etc/exim/exim.conf
rm -Rf /etc/logrotate.d/exim
mv /etc/logrotate.d/exim.rpmsave /etc/logrotate.d/exim

It worked perfect!

Re: Error prevents sending by Exim (Broken pipe)

Posted: Fri May 22, 2020 5:47 pm
by pcready.cl
raapcoelho wrote:
Fri May 22, 2020 5:35 pm
pcready.cl wrote:
Fri May 22, 2020 4:32 pm
raapcoelho wrote:
Fri May 22, 2020 4:29 pm
I dowgrade exim to: exim-4.92.3-1.el7.x86_64.rpm

And apparently it worked for me!
How do this?
Download this file and send it to the server:
http://rpm.pbone.net/index.php3/stat/4/ ... 4.rpm.html

Run the commands:

yum remove exim -y
yum localinstall exim-4.92.3-1.el7.x86_64.rpm -y
rm -Rf /etc/exim/exim.conf
mv /etc/exim/exim.conf.rpmsave /etc/exim/exim.conf
rm -Rf /etc/logrotate.d/exim
mv /etc/logrotate.d/exim.rpmsave /etc/logrotate.d/exim

It worked perfect!
You can paste your exim.conf please!

Re: Error prevents sending by Exim (Broken pipe)

Posted: Sat May 23, 2020 8:48 am
by vpsops
Yes, i confirm that downgrading exim fixed the problem.

Please keep in mind to disable yum auto updates for exim otherwise it will be updated bringing back the bug once again.

Re: Error prevents sending by Exim (Broken pipe)

Posted: Sat May 23, 2020 11:40 pm
by raapcoelho
pcready.cl wrote:
Fri May 22, 2020 5:47 pm

You can paste your exim.conf please!
I didn't make any modifications to exim, just restarted it and created an email box.

Here is the configuration I use:
https://github.com/serghey-rodin/vesta/ ... /exim.conf