cannot create user preferences file /nonexistent/.sp

Questions regarding the Mail Server
Dovecot, Exim, RoundCube
photographer
Posts: 13
Joined: Thu Jul 24, 2014 7:43 pm

cannot create user preferences file /nonexistent/.sp

Postby photographer » Sat Jul 26, 2014 8:57 pm

Hello,
У меня в конфиге
config: cannot create user preferences file /nonexistent/.spamassassin/user_prefs: No such file or directory

плиз, подскажите направление что исправлять :)

rocky123xo
Posts: 28
Joined: Wed Aug 20, 2014 9:53 pm

Re: cannot create user preferences file /nonexistent/.sp

Postby rocky123xo » Sat Jan 03, 2015 3:36 am

Having the same issue...

ScIT
Posts: 171
Joined: Mon Feb 23, 2015 4:13 pm

Re: cannot create user preferences file /nonexistent/.sp

Postby ScIT » Fri Mar 06, 2015 2:19 pm

Hello

Just if someone other does have the same issue:

Modify /etc/default/spamassassin

Code: Select all

OPTIONS="--create-prefs --max-children 5 --helper-home-dir"

to

Code: Select all

OPTIONS="--create-prefs --max-children 5 --helper-home-dir -u debian-spamd"

also create folder and set permission:

Code: Select all

mkdir -p /nonexistent/.spamassassin
chown debian-spamd: /nonexistent/.spamassassin


last but not least restart spamassassin

Code: Select all

service spamassassin restart


Regards
Raphael

donat
Posts: 16
Joined: Thu Jul 30, 2015 1:42 pm

Re: cannot create user preferences file /nonexistent/.sp

Postby donat » Fri Apr 15, 2016 8:59 am

having the same issue. Hope that your suggest now works.

oobydoo
Posts: 9
Joined: Thu Jan 14, 2016 2:10 pm

Re: cannot create user preferences file /nonexistent/.sp

Postby oobydoo » Thu May 05, 2016 8:01 pm

Whats the setup for Centos to fix this error please

Do we just put

Code: Select all

OPTIONS="--create-prefs --max-children 5 --helper-home-dir -u centos-spamd"

zdi
Posts: 6
Joined: Fri May 06, 2016 5:34 pm

Re: cannot create user preferences file /nonexistent/.sp

Postby zdi » Fri Oct 07, 2016 9:44 am

Basically the error are the permissions on: //.spamassassin/user_prefs

To fix it follow the next steps:

– Create the user spamd, in order to avoid to run spamassassin with the user nobody (ignore errors that folders exist):

Code: Select all

groupadd -g 1001 spamd
useradd -u 1001 -g spamd -s /sbin/nologin -d /var/lib/spamassassin spamd
mkdir /var/lib/spamassassin
chown spamd:spamd /var/lib/spamassassin



– Edit the file /etc/exim/exim.conf.

Code: Select all

nano /etc/exim/exim.conf



Change the line:
spam = nobody:true/defer_ok
to

Code: Select all

      spam           = spamd:true/defer_ok



– Restart exim and spamassassin

Code: Select all

service exim restart
service spamassassin restart



After awhile that verify that the files bayes_seen, bayes_toks and user_prefs exists on the spamd home (In this case /var/lib/spamassassin/.spamassassin)


Return to “Mail Server”



Who is online

Users browsing this forum: No registered users and 3 guests