DNS no glue

Questions regarding the DNS Server
BIND
BBuchanan1013
Posts: 139
Joined: Thu Jan 07, 2016 12:01 am

DNS no glue

Postby BBuchanan1013 » Mon Jun 12, 2017 3:17 am

So I have no clue why it's working or how, but I'm troubled:

Site1:
site.com = child-ns
ns1 NS ip-address
ns2 NS ip-address
ns2 A ip-address
ns1 A ip-address
@ A ip-address
@ NS ns1.site1.com
@ NS ns2.site1.com

Site2:
@ NS ns1.site1.com
@ NS ns2.site1.com

Both site1 and site2 resolve and are completely useable, however, intodns.com tells me that there are no glue records for ns1.site1.com and ns2.site1.com.

Godaddy has:
Hosts: ns1 and ns2 pointing to ip-address
Both Site1 and Site2 are pointing to the hosts (ns1 and ns2)

BBuchanan1013
Posts: 139
Joined: Thu Jan 07, 2016 12:01 am

Re: DNS no glue

Postby BBuchanan1013 » Mon Jun 12, 2017 6:07 pm

If anyone wants to look at the dns issues,
site1 is host-true.com
site2 is podmunity.space

BBuchanan1013
Posts: 139
Joined: Thu Jan 07, 2016 12:01 am

Re: DNS no glue

Postby BBuchanan1013 » Tue Jun 13, 2017 12:38 am

Ubuntu 16.04
Apache 2.4
PHP 7
Bind9

All update to date. Even ran v-rebuild-dns-domains admin then restarted server. Then ran v-rebuild-dns-domain host-true.com then restarted. Still the same.
https://intodns.com/host-true.com

BBuchanan1013
Posts: 139
Joined: Thu Jan 07, 2016 12:01 am

Re: DNS no glue

Postby BBuchanan1013 » Tue Jun 13, 2017 12:45 am

I had to destroy (delete) the host-true.com and re-add it for DNS to show correctly for that one. Now all the others are working fine. No clue what happened.


Return to “DNS Server”



Who is online

Users browsing this forum: No registered users and 3 guests