Cannot unsuspend domains Topic is solved

Questions regarding the DNS Server
Posts: 103
Joined: Tue Aug 04, 2015 7:15 pm

Cannot unsuspend domains

Postby Felix » Fri Sep 08, 2017 1:44 pm


I have 2 VPS with VestCP. I've followed the Slave DNS Cluster guide and the second acts as a SLAVE DNS, so lets call the servers MASTER and SLAVE. This setups has been working OK for 2 years.

Recently, I suspended some domains in MASTER server and after some weeks I completely removed them from MASTER (unsuspend the domains in MASTER and then delete the domains). The problem is that I can still see the deleted domains in the SLAVE server, under DNS of the dns-cluster user account. Moreover, I cannot unsuspend the domains and so I cannot delete them.

I tried using the command line at the SLAVE server:

Code: Select all

v-unsuspend-domain dns-cluster domain.tld

but that failed with error:

Code: Select all

/usr/local/vesta/func/ line 293: 27:DOMAIN=domain.tld: command not found

There must be a bug somewhere...? Has anyone else faced this?

Posts: 103
Joined: Tue Aug 04, 2015 7:15 pm

Re: Cannot unsuspend domains  Topic is solved

Postby Felix » Fri Sep 08, 2017 7:41 pm

OK, this was tricky but I have found fix that worked in my case. I'm sharing it here so it might help others.

Reading through the code of v-unsuspend-domain I found that the info about DNS domains is saved in the file: /usr/local/vesta/data/users/dns-cluster/dns.conf

So I opened this file and found that there were 2 entries for each domain I coulnd't unsuspend. I deleted one of the two entries for each domain and then managed to unsusped using VESTA GUI. After that deleting was a breeze.

Return to “DNS Server”

Who is online

Users browsing this forum: No registered users and 2 guests