(Jan 22) Release 0.9.8-19 with bug fixes available now. Run this command for update v-update-sys-vesta-all

Own DNS server configuration for domain.

Questions regarding the DNS Server
BIND
Forum rules
Before creating a new topic or reply on the forum you should fill out additional fields "Os" and "Web" in your profile section.
In case of violation, the topic can be closed or response from the support will not be received.
cybercoder
Posts: 1
Joined: Wed Oct 11, 2017 12:30 am

Own DNS server configuration for domain.

Postby cybercoder » Wed Oct 11, 2017 12:45 am

I did login to my domain handler panel and set my domain DNS server to my new VESTACP centOS7 server, only with IPv4 address (no FQDN).
Then i did read this topic: viewtopic.php?t=3990 and do step by steps it said.

The domain address was pointed to an old server and i know sometimes needed to DNS servers resolve new IP information.
So i decided to test DNS with nslookup command. When i did use " nslookup mydomain.com 127.0.0.1 (or public IP address) on the server itself, it will resolve and show correct new IP address. But when i use nslookup domain.com x.x.x.x from another computer which is in the internet, (x.x.x.x is VESTACP server's public IPv4 address), It shows old IP address !!! as non-authoritative answer.

I got suspicious to BIND so i changed named.conf to:
listen-on port 53 { any; };
allow-query { any; };

But when i get query with nslookup outside of the server self, will show old IP address!

I did flush caches both sides.
I did disable another DNS servers on local machine.
and i did add server public IPv4 address as first nameserver in /etc/resolve.conf

But i can't find what is the problem!

Return to “DNS Server”



Who is online

Users browsing this forum: No registered users and 1 guest