Page 1 of 1

DNS Configuration Problem. - SOLVED -

Posted: Sun Jan 19, 2020 1:41 pm
by robert2000
Hi, The only reason I'm starting this thread is because I've followed countless tutorials about to how to properly set the nameservers on vistacp, disregard everything I tried I keep getting this same error, as I can't find a logical explanation of why this is happening I'm hoping anyone in here can help me get it fixed as I'm, by now, at a total loss.

I have no idea what's wrong, hope someone can shed some light on this.

1) Named won't start because it complains about the following:

zone NS '' has no address records (a or AAA)
zone NS '' has no address records (a or AAA)

zone not loaded due to errors.
_default/ bad zone

2) I've set up the A records for both NS but named won't start and keeps displaying the same exact error, disregarding the fact that I ALREADY SETUP A RECORDS FOR NS1 AND NS2.

Registrar config:


NS A records on vistacp user/domain:


Error on the console:


DNS Server conf (VestaCP admin)

options {
directory "/var/named";
dump-file "/var/named/data/cache_dump.db";
pid-file "/var/run/named/";
statistics-file "/var/named/data/named_stats.txt";
version "get lost";
allow-transfer {"none";};
recursion no;


include "/etc/rndc.key";

zone "" {type master; file "/home/syndicate/conf/dns/";};


So, basicly, I was stupid and had set the record wrong, instead of just typing "ns1" I was stupidly typing the ENTIRE domain, so the record was invalid:


I think the preview text on the right should be more noticeable, it's varely noticeable in that light-gray color. Also there should be an indication like " PREVIEW" for stupid people like me.