Page 1 of 1

Phpadmin PHP 5.5+ is required.

Posted: Fri Nov 15, 2019 1:54 pm
by techtuga
Hi Folks,

Thanks for this great SW, have been using it for long time.
Have a problem with my phpmyadmin login:

After updating php i get the following when trying to access phpmyadmin:

Code: Select all

PHP 5.5+ is required.
Currently installed version is: 5.4.45

Code: Select all

[root@localhost web]# php -v
PHP 7.3.11 (cli) (built: Oct 22 2019 08:11:04) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.3.11, Copyright (c) 1998-2018 Zend Technologies
Where can i update Vesta environment variables to reflect the current php version?

This is also what i get in WordPress system variables:

Code: Select all

Apache/2.4.6 (CentOS) OpenSSL/1.0.1e-fips mod_fcgid/2.3.9 PHP/5.4.45
OS is:

Code: Select all

CentOS Linux release 7.6.1810 (Core)
Thanks in advance

Re: Phpadmin PHP 5.5+ is required.

Posted: Thu Dec 12, 2019 3:56 pm
by galiean251
I'm not sure Vesta is your issue is this looks like CentOS isn't looking at the new version over the older EOL PHP 5.x version it shipped/updated with... I ran into a similar issue on an older Debian server, vented frustrations when I thought it was Vesta's fault but ended up migrating everything to a newer server. The backup/restore functionality of Vesta made it relatively painless (compared to other panels) and now I'm rocking PHP 7.x on the new server/distro.

This probably isn't the answer you were seeking but hopefully a little helpful.