Page 1 of 1

Не работает phpMyAdmin

Posted: Thu Apr 09, 2015 9:58 am
by Konstantinus
1. Установил минимальную CentOS 6.6 x64
2. Установил VestCP
3. Создал сайт. Создал БД.
4. Пытаюсь автооризироваться в phpMyAdmin - http://85.159.6.61/phpmyadmin/ - чистая страница.

По совету в другой теме этого форума поставил 777 на /var/lib/php/session - и страница отобразилась.
Но в панель попасть не могу, так как "Cannot log in to the MySQL server"

Re: Не работает phpMyAdmin

Posted: Sat Apr 11, 2015 10:45 pm
by skurudo
Создайте базу, пользователя, пароль и попробуйте войти.
Или же под пользователем root.

Перед этим проверьте, работает ли mysql:

Code: Select all

service mysql status

Re: Не работает phpMyAdmin

Posted: Thu Apr 30, 2015 11:47 am
by Konstantinus
Спасибо. Помог рестарт.

Re: Не работает phpMyAdmin

Posted: Thu Apr 30, 2015 12:14 pm
by skurudo
Как-то не спортивно, но главное - заработало! :)

Re: Не работает phpMyAdmin

Posted: Fri Feb 14, 2020 9:34 am
by Aleksander
Приветствую. Я сегодня столкнулся с неработающим phpmyadmin.
Установлено Centos 7. Обновил. Установил Весту в конфигурации
WEB - nginx+php-fpm.
DNS - no
Additional Repository - remi
FTP - vsftpd
Firewall - iptables+fail2ban
File System Quota - no
MAIL - no
SOFTACULOUS - yes
DB - MySQL
Создал пользователя. Под пользователем создал домен, создал базу данных. Но при нажатии на phpmyadmin страница не открывается.
При открытии браузер пишет - попытка соединения не удалась. Под админом аналогично.

Re: Не работает phpMyAdmin

Posted: Sat Apr 18, 2020 10:10 pm
by Vester88
Такая же история.
В какой-то момент перестал работать myphpadmin
А потом и бэкапы перестали создаваться.
Нашел решение проблемы
viewtopic.php?t=3693&sid=632d66ffce81f0 ... 12403a82eb

Что в файле

Code: Select all

/usr/local/vesta/conf/mysql.conf
каким-то образом прописался левый пароль и рекомендацию сменить его от рута.

Сменил, но толку нет. В логе по бэкапам - "невозможно подключиться к базе данных".
Может там не от рута пароль должен быть?