Page 1 of 1

phpMyAdmin 400 not found

Posted: Mon Mar 16, 2020 10:00 pm
by mohsinamer
Hello,

I updated my PHP version from 5.6 to 7.3 by removing the 5.5 and 5.6 remi repos and enabling remi-php73 repo. The installation required me to remove TWIG as it was interfering with the installation. I removed twig and it remove phpMyAdmin along with it. Now I am trying to install and it is giving me this error
Loaded plugins: fastestmirror, refresh-packagekit, security
Setting up Install Process
Loading mirror speeds from cached hostfile
* base: repo.isra.edu.pk
* epel: mirror.yer.az
* extras: repo.isra.edu.pk
* remi-php73: remi.schlundtech.de
* remi-safe: remi.schlundtech.de
* updates: repo.isra.edu.pk
Resolving Dependencies
--> Running transaction check
---> Package phpMyAdmin.noarch 0:4.0.10.20-1.el6 will be installed
--> Processing Dependency: php(language) < 7 for package: phpMyAdmin-4.0.10.20-1.el6.noarch
--> Processing Dependency: php-php-gettext for package: phpMyAdmin-4.0.10.20-1.el6.noarch
--> Processing Dependency: php-tcpdf for package: phpMyAdmin-4.0.10.20-1.el6.noarch
--> Processing Dependency: php-tcpdf-dejavu-sans-fonts for package: phpMyAdmin-4.0.10.20-1.el6.noarch
--> Running transaction check
---> Package php-php-gettext.noarch 0:1.0.12-1.el6 will be installed
---> Package php-tcpdf.noarch 0:6.2.26-1.el6 will be installed
---> Package php-tcpdf-dejavu-sans-fonts.noarch 0:6.2.26-1.el6 will be installed
---> Package phpMyAdmin.noarch 0:4.0.10.20-1.el6 will be installed
--> Processing Dependency: php(language) < 7 for package: phpMyAdmin-4.0.10.20-1.el6.noarch
--> Finished Dependency Resolution
Error: Package: phpMyAdmin-4.0.10.20-1.el6.noarch (epel)
Requires: php(language) < 7
Installed: php-common-7.3.13-1.el6.remi.x86_64 (@remi-php73)
php(language) = 7.3.13
Available: php-common-5.3.3-49.el6.x86_64 (base)
php(language) = 5.3.3
Available: php-common-5.3.3-50.el6_10.x86_64 (updates)
php(language) = 5.3.3
Available: php-common-7.3.12-1.el6.remi.x86_64 (remi-php73)
php(language) = 7.3.12
You could try using --skip-broken to work around the problem
Now from what I realized is that EPEL has only phpMyAdmin version 4.0.10 and 4.0.10 requires a lower language pack. I also tried manually extracting the files to /usr/share/phpMyAdmin but it still does not recognizes the files.

Please help me.