Lets Encrypt - sed pipe error Topic is solved

Questions regarding the Command Line Interface
CLI
ThA-LaN-LaW
Posts: 12
Joined: Mon Jan 25, 2016 2:25 pm

Lets Encrypt - sed pipe error

Postby ThA-LaN-LaW » Fri Nov 25, 2016 2:50 pm

Hi Vesta-Team,

folloing error will be shown after a Let's Encrypt certificate will be (successfully!) installed:

Code: Select all

[root@web web]# v-add-letsencrypt-domain USER DOMAIN ALIAS
sed: can't read /usr/local/vesta/data/queue/letsencrypt.pipe: No such file or directory
[root@web web]# ls -l /usr/local/vesta/data/queue/
total 8
-rwxr-x---  1 root root   0 Nov 25 05:13 backup.pipe
-rwxr-x---  1 root root 365 Sep  5 19:34 disk.pipe
-rwxr-x---  1 root root   0 Nov 25 15:39 restart.pipe
-rwxr-x---  1 root root 110 Sep  5 19:35 traffic.pipe
-rwxr-x---. 1 root root   0 Dec 18  2015 webstats.pipe


should we ignore this one?

best regards

huloza
Posts: 22
Joined: Thu Jul 28, 2016 5:15 am

Re: Lets Encrypt - sed pipe error

Postby huloza » Mon Nov 28, 2016 2:29 am

same error, the certificate generated but got error.

Regards!

jamesblackvn
Posts: 2
Joined: Mon Nov 28, 2016 7:48 am

Re: Lets Encrypt - sed pipe error

Postby jamesblackvn » Mon Nov 28, 2016 8:10 am

same error, the certificate generated but got error.

Regards!

ScIT
Posts: 267
Joined: Mon Feb 23, 2015 4:13 pm

Re: Lets Encrypt - sed pipe error

Postby ScIT » Tue Nov 29, 2016 3:20 pm

+1

ThA-LaN-LaW
Posts: 12
Joined: Mon Jan 25, 2016 2:25 pm

Re: Lets Encrypt - sed pipe error

Postby ThA-LaN-LaW » Thu Dec 01, 2016 3:26 pm

on a fresh install there is a /usr/local/vesta/data/queue/letsencrypt.pipe !

Code: Select all

[root@web]# ls -l /usr/local/vesta/data/queue/
total 12
-rwxr-x---  1 root root   0 Dec  1 05:10 backup.pipe
-rwxr-x---  1 root root 365 Sep 20 16:10 disk.pipe
-rw-r--r--  1 root root   1 Dec  1 15:55 letsencrypt.pipe
-rwxr-x---  1 root root   0 Dec  1 15:39 restart.pipe
-rwxr-x---  1 root root 110 Sep 20 16:10 traffic.pipe
-rwxr-x---. 1 root root   0 Sep 13 11:58 webstats.pipe

ScIT
Posts: 267
Joined: Mon Feb 23, 2015 4:13 pm

Re: Lets Encrypt - sed pipe error  Topic is solved

Postby ScIT » Thu Dec 01, 2016 7:36 pm

Easy way to fix:

Code: Select all

sudo touch /usr/local/vesta/data/queue/letsencrypt.pipe

locus
Posts: 54
Joined: Thu May 05, 2016 6:43 am

Re: Lets Encrypt - sed pipe error

Postby locus » Wed Feb 01, 2017 2:44 am

I just got this issue too on 0.9.8r17

Fleuv
Posts: 11
Joined: Thu May 28, 2015 4:27 pm
Location: Netherlands

Re: Lets Encrypt - sed pipe error

Postby Fleuv » Wed Jun 07, 2017 12:56 pm

Don't forget to setup the right file permissions:

Code: Select all

touch /usr/local/vesta/data/queue/letsencrypt.pipe
chmod 750 /usr/local/vesta/data/queue/letsencrypt.pipe


Return to “CLI”



Who is online

Users browsing this forum: No registered users and 1 guest