(Dec 29) New version 0.9.8-18 has been released

v-delete-sys-ip "Error: IP is in use" even if it's not Topic is solved

Questions regarding the Command Line Interface
CLI
Forum rules
Before creating a new topic or reply on the forum you should fill out additional fields "Os" and "Web" in your profile section.
In case of violation, the topic can be closed or response from the support will not be received.
andrea.gobetti
Posts: 2
Joined: Thu Oct 20, 2016 12:42 pm

v-delete-sys-ip "Error: IP is in use" even if it's not

Postby andrea.gobetti » Sat Jun 24, 2017 8:19 am

Hi, in Vesta I have two IP addresses configured, the first one was created automatically at installation time (and was wrong), so I created another IP address (the second one) which is correct, now I'm trying to delete the first one, but I get a message like:

Error: IP is in use / WEB_DOMAINS = 4


Each time I add a new domain the counter WEB_DOMAINS increases, but when I delete one of that domains the counter does not decrease, so I'm not able to delete that IP address!

skamasle
Collaborator
Posts: 384
Joined: Mon Feb 29, 2016 6:36 pm

Re: v-delete-sys-ip "Error: IP is in use" even if it's not  Topic is solved

Postby skamasle » Mon Jun 26, 2017 8:45 pm

I think is not posible delete main IP

Try rebuild counters

And maybe you need remote it manully first from vesta config file in /usr/local/vesta/*

I change some IPs in that way and works fine

andrea.gobetti
Posts: 2
Joined: Thu Oct 20, 2016 12:42 pm

Re: v-delete-sys-ip "Error: IP is in use" even if it's not

Postby andrea.gobetti » Tue Jun 27, 2017 1:06 pm

Thanks skamasle, I've deleted the file corrisponding to the IP that I wanted to remove in /usr/local/vesta/data/ips and it seems that it worked without problems!


Return to “CLI”



Who is online

Users browsing this forum: No registered users and 1 guest

cron