Page 1 of 1

is there any thing wrong with my vesta cli?

Posted: Sat Sep 07, 2019 7:33 am
by niceboy
Just tried my first cli command v-change-user-password ( I know it expects username/password as arguments and i left them intentionally ).

Baffled with errors shown. Is this the way cli vesta commands work or there is something wrong with my vesta install?

Code: Select all

# v-change-user-password
/usr/local/vesta/bin/v-change-user-password: line 17: /func/main.sh: No such file or directory
/usr/local/vesta/bin/v-change-user-password: line 18: /conf/vesta.conf: No such file or directory
/usr/local/vesta/bin/v-change-user-password: line 25: check_args: command not found
/usr/local/vesta/bin/v-change-user-password: line 26: is_format_valid: command not found
/usr/local/vesta/bin/v-change-user-password: line 27: is_object_valid: command not found
/usr/local/vesta/bin/v-change-user-password: line 28: is_object_unsuspended: command not found
/usr/local/vesta/bin/v-change-user-password: line 29: is_password_valid: command not found
chpasswd: line 1: user '' does not exist
chpasswd: error detected, changes ignored
/usr/local/vesta/bin/v-change-user-password: line 50: generate_password: command not found
/usr/local/vesta/bin/v-change-user-password: line 50: update_user_value: command not found
/usr/local/vesta/bin/v-change-user-password: line 51: update_user_value: command not found
/usr/local/vesta/bin/v-change-user-password: line 54: log_history: command not found
/usr/local/vesta/bin/v-change-user-password: line 55: log_event: command not found

Re: is there any thing wrong with my vesta cli?

Posted: Sat Sep 07, 2019 8:05 am
by niceboy
My bad. Seems that I need to reboot vista after install.