parking domain api not work return code 1

Questions regarding the API
Application Programming Interface
pavel
Posts: 4
Joined: Sun Jul 24, 2016 1:15 am

parking domain api not work return code 1

Postby pavel » Fri Oct 28, 2016 1:02 am

hi I try this code for park domain
<?php

// Server credentials
$vst_hostname = 'mydomain.com';
$vst_username = 'admin';
$vst_password = 'mypassword';
$vst_returncode = 'yes';
$vst_command = 'v-add-web-domain-alias';

// New Domain
$username = 'admin';
$domain = 'mydomain';
$aliases = 'park domain';

// Prepare POST query
$postvars = array(
'user' => $vst_username,
'password' => $vst_password,
'returncode' => $vst_returncode,
'cmd' => $vst_command,
'arg1' => $username,
'arg2' => $domain
);
$postdata = http_build_query($postvars);

// Send POST query via cURL
$postdata = http_build_query($postvars);
$curl = curl_init();
curl_setopt($curl, CURLOPT_URL, 'https://' . $vst_hostname . ':8083/api/');
curl_setopt($curl, CURLOPT_RETURNTRANSFER,true);
curl_setopt($curl, CURLOPT_SSL_VERIFYPEER, false);
curl_setopt($curl, CURLOPT_SSL_VERIFYHOST, false);
curl_setopt($curl, CURLOPT_POST, true);
curl_setopt($curl, CURLOPT_POSTFIELDS, $postdata);
$answer = curl_exec($curl);

// Check result
if($answer == 0) {
echo "Domain has been successfuly created\n";
} else {
echo "Query returned error code: " .$answer. "\n";
}
?>


but this give me return code 1. what field I missing there?

li41
Posts: 1
Joined: Tue May 09, 2017 1:34 am

Re: parking domain api not work return code 1

Postby li41 » Tue May 09, 2017 1:36 am

$postvars = array(
'user' => $vst_username,
'password' => $vst_password,
'returncode' => $vst_returncode,
'cmd' => $vst_command,
'arg1' => $username,
'arg2' => $domain,
'arg3' => $aliases //here

);


Return to “Scripting / API”



Who is online

Users browsing this forum: No registered users and 2 guests