Page 21 of 22

Re: VestaCP PHP Selector for Centos add php 7, 5.6 and 5.5.

Posted: Tue May 29, 2018 9:06 pm
by altayevrim
PHP codes not running. Including the phpinfo();

Firstly I used your codes. But then after, I realized that I couldn't install php 7.1 so I installed them from the github version.

Re: VestaCP PHP Selector for Centos add php 7, 5.6 and 5.5.

Posted: Mon Jun 04, 2018 9:46 pm
by altayevrim
Hi,

Still I have problems. I installed a fresh VestaCP too. I am using CentOS 7 and I can't use any php version that installed with this system.
The error is;

Code: Select all

[Mon Jun 04 21:24:57.183939 2018] [fcgid:warn] [pid 9390] (104)Connection reset by peer: [client xxxxx] mod_fcgid: error reading data from FastCGI server
[Mon Jun 04 21:24:57.184021 2018] [core:error] [pid 9390] [client xxxxx] End of script output before headers: info.php
[Mon Jun 04 21:33:53.821619 2018] [fcgid:warn] [pid 3981] (104)Connection reset by peer: [client xxxxx] mod_fcgid: error reading data from FastCGI server
[Mon Jun 04 21:33:53.822071 2018] [core:error] [pid 3981] [client xxxxx] End of script output before headers: info.php
I tried to change the fcgid.conf file to fix the issue but still the same.

Code: Select all

# This is the Apache server configuration file for providing FastCGI support
# through mod_fcgid
#
# Documentation is available at
# http://httpd.apache.org/mod_fcgid/mod/mod_fcgid.html

# Use FastCGI to process .fcg .fcgi & .fpl scripts
AddHandler fcgid-script fcg fcgi fpl

FcgidIdleTimeout 40
FcgidProcessLifeTime 30
FcgidMaxProcesses 20
FcgidMaxProcessesPerClass 8
FcgidMinProcessesPerClass 0
FcgidConnectTimeout 30
FcgidIOTimeout 3800
FcgidBusyTimeout 3600
FcgidIdleScanInterval 10

# Sane place to put sockets and shared memory file
FcgidIPCDir /run/mod_fcgid
FcgidProcessTableFile /run/mod_fcgid/fcgid_shm
I can't run any php code.

Code: Select all

<?php phpinfo();
too.

Re: VestaCP PHP Selector for Centos add php 7, 5.6 and 5.5.

Posted: Fri Jun 15, 2018 6:34 pm
by dpeca
This post is not related with this script.
I just want to inform people that I made a tutorial for PHP-switcher for Debian9.
viewtopic.php?f=41&t=17129

Re: VestaCP PHP Selector for Centos add php 7, 5.6 and 5.5.

Posted: Mon Sep 10, 2018 10:34 am
by Kumigy
Hello.
I've successfully installed this script.
I've changed web template to sk-php70.
Try to open http://site.ru/phpinfo.php and nothing (white screen).
/home/admin/web/site.ru/logs/site.ru.error.log - empty

Any ideas?

CentOS 7

Re: VestaCP PHP Selector for Centos add php 7, 5.6 and 5.5.

Posted: Mon Oct 15, 2018 6:20 am
by AlexFlexo
Hi.
I installed the modification, everything worked out and it worked, but there is a problem (sk-php71). When I try to install something (add-ons for CMS), I get error 500.
In the logs the following

Code: Select all

[Sun Oct 14 23:35:48.667401 2018] [fcgid:warn] [pid 26120] [client 192.168.1.233:32926] mod_fcgid: HTTP request length 138080 (so far) exceeds MaxRequestLen (131072), referer: https://xxxxxx.ru/administrator/index.php?option=com_installer
The engine itself is installed without problems.
Where to look for a problem?
Sorry for my english...

UPDATE!

This decision helped!

viewtopic.php?f=19&t=10854&start=70#p43749

Re: VestaCP PHP Selector for Centos add php 7, 5.6 and 5.5.

Posted: Thu Oct 18, 2018 5:03 pm
by popers
Hi
I have a problem with httpd default template (nginx+apache), php -v shows PHP 7.2.11 but real version is 5.4.45. How to back to PHP 7.2.11? phpmyadmin also not works.
Thanks

Re: VestaCP PHP Selector for Centos add php 7, 5.6 and 5.5.

Posted: Sat Dec 08, 2018 3:28 pm
by tanquang
Can I use it on apache + nginx web server?

Re: VestaCP PHP Selector for Centos add php 7, 5.6 and 5.5.

Posted: Sat Dec 08, 2018 3:59 pm
by Alex Connor
yes, you can

Re: VestaCP PHP Selector for Centos add php 7, 5.6 and 5.5.

Posted: Sat Dec 15, 2018 1:29 pm
by Tonop
Hi there and skamasle thanks for the script.

I successully intalled the script with php7.1 version. Before that I used php5.6 and now there are both.
I use Magento which require php7.1 and other joomla websites on php5.6.
For Magento I need to use mod_ruid2 module but it is not compatible with mod_fcgid (combination causes error, see post 49363.

I didnt find any solution and would like to ask you for help. My quesions are:
1) How is posible to use mod_ruid2 features with mod_fcgid?
2) How to use php7.1 as Server API-Apache 2.0 Handler, not as Server API-CGI/FastCGI.
3) If I insatall php7.1 as default, and php5.6 as option, will php7.1 use Server API-Apache 2.0 Handler? If not, how to change handler from FastCGI to Apache handler?

Looking forward for your assistant.
BR,
Boris

PHP Version 5.6.38
System Linux swinestudio.ru 2.6.32-754.6.3.el6.x86_64 #1 SMP Tue Oct 9 17:27:49 UTC 2018 x86_64
Build Date Oct 24 2018 12:58:58
Server API Apache 2.0 Handler
Virtual Directory Support disabled
Configuration File (php.ini) Path /etc
Loaded Configuration File /etc/php.ini
Scan this dir for additional .ini files /etc/php.d

PHP Version 7.1.25
System Linux swinestudio.ru 2.6.32-754.6.3.el6.x86_64 #1 SMP Tue Oct 9 17:27:49 UTC 2018 x86_64
Build Date Dec 8 2018 13:40:23
Server API CGI/FastCGI
Virtual Directory Support disabled
Configuration File (php.ini) Path /etc/opt/remi/php71
Loaded Configuration File /etc/opt/remi/php71/php.ini
Scan this dir for additional .ini files /etc/opt/remi/php71/php.d

Re: VestaCP PHP Selector for Centos add php 7, 5.6 and 5.5.

Posted: Sat Jan 12, 2019 8:42 pm
by skamasle
Tonop wrote:
Sat Dec 15, 2018 1:29 pm
Hi there and skamasle thanks for the script.

I successully intalled the script with php7.1 version. Before that I used php5.6 and now there are both.
I use Magento which require php7.1 and other joomla websites on php5.6.
For Magento I need to use mod_ruid2 module but it is not compatible with mod_fcgid (combination causes error, see post 49363.

I didnt find any solution and would like to ask you for help. My quesions are:
1) How is posible to use mod_ruid2 features with mod_fcgid?
2) How to use php7.1 as Server API-Apache 2.0 Handler, not as Server API-CGI/FastCGI.
3) If I insatall php7.1 as default, and php5.6 as option, will php7.1 use Server API-Apache 2.0 Handler? If not, how to change handler from FastCGI to Apache handler?

Looking forward for your assistant.
BR,
Boris

PHP Version 5.6.38
System Linux swinestudio.ru 2.6.32-754.6.3.el6.x86_64 #1 SMP Tue Oct 9 17:27:49 UTC 2018 x86_64
Build Date Oct 24 2018 12:58:58
Server API Apache 2.0 Handler
Virtual Directory Support disabled
Configuration File (php.ini) Path /etc
Loaded Configuration File /etc/php.ini
Scan this dir for additional .ini files /etc/php.d

PHP Version 7.1.25
System Linux swinestudio.ru 2.6.32-754.6.3.el6.x86_64 #1 SMP Tue Oct 9 17:27:49 UTC 2018 x86_64
Build Date Dec 8 2018 13:40:23
Server API CGI/FastCGI
Virtual Directory Support disabled
Configuration File (php.ini) Path /etc/opt/remi/php71
Loaded Configuration File /etc/opt/remi/php71/php.ini
Scan this dir for additional .ini files /etc/opt/remi/php71/php.d
I not test mod_ruid2 so I cant help you for now, but, in any case you can run php 7.1 in default version with any orther handler supported by vesta, but in selector isnt posible