Page 26 of 26

Re: VestaCP PHP Selector for Centos add php 7, 5.6 and 5.5.

Posted: Fri Apr 17, 2020 7:45 am
by Bez
Hello guys! I install sk-php-selector2.sh to fresh VestaCP (was installed to clean Centos 7)
I use command

Code: Select all

bash sk-php-selector2.sh all
Everything is good but ip/phpmyadmin/ page after server reboot - just blank page. With no code.

OK. SOLVED!

What to do:
Step 1. Install selector

Code: Select all

bash sk-php-selector2.sh all
Step 2. before reboot - backup all files from
/etc/httpd/conf.d

Step 3. reboot

Step 4. back all files from backup to
/etc/httpd/conf.d

Step 5. reboot and check that you have blank page

Step 6. go and install new phpmyadmin from here https://devanswers.co/manually-upgrade-phpmyadmin/
I just install version 4.9.5.

Step 7. change in file phpMyAdmin.conf from folder /etc/httpd/conf.d
from
/usr/share/phpMyAdmin
to
/usr/share/phpmyadmin

Step 8. reboot and check. I have

Code: Select all

phpMyAdmin PHP 5.5+ is required. Currently installed version is: 5.4.45
It's good.

Step 9. Go to folder
/etc/httpd/conf.modules.d
and backup files
10-php54-php.conf
10-php55-php.conf

Step 10. Reboot and check. All works for me!

Re: VestaCP PHP Selector for Centos add php 7, 5.6 and 5.5.

Posted: Wed May 27, 2020 5:49 pm
by bagishared1
today i have tested ubuntu 16.04 using the latest vestacp version.

my question is: how do i set maxchildren vestacp in ubuntu 16.04.

thank you

Re: VestaCP PHP Selector for Centos add php 7, 5.6 and 5.5.

Posted: Tue Jun 09, 2020 2:11 pm
by Lordbl4
@skamasle

please, check source code storage for your scripts.
i got html timeout error during installation and generation sk-php74.sh (and all other sk-php**.sh) on centos 7 today.
i cant show broken script, i just replaced it for work, but in "body" of sh script i was seen html code.

Image
SpoilerShow
Image

Re: VestaCP PHP Selector for Centos add php 7, 5.6 and 5.5.

Posted: Sat Jul 25, 2020 11:04 pm
by CamdenJaxx
Hello,

After using this, I have found that the PHP variables (max input time, memory limit, upload max file size, etc.) I have set in Vesta CP -> Server -> HTTPD -> PHP.ini are not applying to any of the websites using one of the newly installed templates. I've tried using overrides in my .htaccess files, but to no avail.

Any ideas on what I can do to set these variables using this PHP selector setup? I don't want to lose the functionality of it, but can't even upload an image in WordPress at the moment because of the issue.

Thanks for any and all input!

Update
After using the steps described here (/viewtopic.php?f=19&t=10854&p=43843#p43749) I was able to get my WordPress to accept uploads within the 2MB (default) max-size, though I have my options in the .htaccess, which has never failed me with Vesta, as well as in the configuration files that I can locate (plus Vesta's configuration page as mentioned) all set to 32MB.

Re: VestaCP PHP Selector for Centos add php 7, 5.6 and 5.5.

Posted: Sat Aug 22, 2020 7:09 pm
by alnux
hi i just made a php-fpm implementation you can see here
viewtopic.php?f=19&t=20128

Re: VestaCP PHP Selector for Centos add php 7, 5.6 and 5.5.

Posted: Sat Sep 19, 2020 2:56 pm
by Bez
Please, help me what do to for add php 7.4?
I already have installed selector - on image FTP folders and selector inside Vesta admin page.
Image

Re: VestaCP PHP Selector for Centos add php 7, 5.6 and 5.5.

Posted: Fri Oct 02, 2020 2:02 pm
by Bez
Hello for all!
After new Centos 7 install I have:
CentOS Linux release 7.8.2003 (Core) / PHP Version 7.4.11 / Apache 2.0 Handler
I have install the selector

Code: Select all

bash /var/tmp/sk-php-selector3.sh php71 php56
and next delete (copy to local) files

Code: Select all

	10-php56-php.conf
	15-php71-php.conf
from the folder

Code: Select all

/etc/httpd/conf.modules.d
Before delete files I have had php 56 by default, because file /etc/httpd/conf.modules.d/ has name 15-php.conf
After delete files I have again PHP Version 7.4.11 by default.
I'm not sure is it good way, but it works for me.

Re: VestaCP PHP Selector for Centos add php 7, 5.6 and 5.5.

Posted: Sat Oct 03, 2020 8:23 pm
by skamasle
CamdenJaxx wrote:
Sat Jul 25, 2020 11:04 pm
Hello,

After using this, I have found that the PHP variables (max input time, memory limit, upload max file size, etc.) I have set in Vesta CP -> Server -> HTTPD -> PHP.ini are not applying to any of the websites using one of the newly installed templates. I've tried using overrides in my .htaccess files, but to no avail.

Any ideas on what I can do to set these variables using this PHP selector setup? I don't want to lose the functionality of it, but can't even upload an image in WordPress at the moment because of the issue.

Thanks for any and all input!

Update
After using the steps described here (/viewtopic.php?f=19&t=10854&p=43843#p43749) I was able to get my WordPress to accept uploads within the 2MB (default) max-size, though I have my options in the .htaccess, which has never failed me with Vesta, as well as in the configuration files that I can locate (plus Vesta's configuration page as mentioned) all set to 32MB.
Hi, you need manually modify all vesta configuration, because vestacp just modify default php.ini, so, this script isnt supported officially by vestacp

For each php version you need modify diferent php.ini

Re: VestaCP PHP Selector for Centos add php 7, 5.6 and 5.5.

Posted: Sat Oct 03, 2020 8:26 pm
by skamasle
Bez wrote:
Fri Oct 02, 2020 2:02 pm
Hello for all!
After new Centos 7 install I have:
CentOS Linux release 7.8.2003 (Core) / PHP Version 7.4.11 / Apache 2.0 Handler
I have install the selector

Code: Select all

bash /var/tmp/sk-php-selector3.sh php71 php56
and next delete (copy to local) files

Code: Select all

	10-php56-php.conf
	15-php71-php.conf
from the folder

Code: Select all

/etc/httpd/conf.modules.d
Before delete files I have had php 56 by default, because file /etc/httpd/conf.modules.d/ has name 15-php.conf
After delete files I have again PHP Version 7.4.11 by default.
I'm not sure is it good way, but it works for me.
This script just add new php versions to use as aditional, if you want to have main php version as default, you just need to upgrade your php version,

But yes, your solution will work, but in any case you can have default php 5.6 and all orders as aditional is my recomendation, in orther way you can broke phpmyadmin or webmail

Re: VestaCP PHP Selector for Centos add php 7, 5.6 and 5.5.

Posted: Sat Oct 03, 2020 8:28 pm
by skamasle
Lordbl4 wrote:
Tue Jun 09, 2020 2:11 pm
@skamasle

please, check source code storage for your scripts.
i got html timeout error during installation and generation sk-php74.sh (and all other sk-php**.sh) on centos 7 today.
i cant show broken script, i just replaced it for work, but in "body" of sh script i was seen html code.

Image
SpoilerShow
Image
HI

I will fix it, just need change links, to download from github, now this was downloaded from my own server, some times get down for maintance.