Page 1 of 1

How to enable WSGI support on a Debian or Ubuntu

Posted: Mon Mar 07, 2016 2:09 am
by dragonmaster
I found a bug in the WSGI templates when Using Ubuntu.
After followin the steps here - ... ian-ubuntu
There are some changes that you need to do to the templates

Code: Select all

cd /usr/local/vesta/data/templates/web/apache2
ls wsgi.*
This should show you 3 files

Code: Select all  wsgi.stpl  wsgi.tpl
Edit wsgi.stpl
Find the line starting with:

Code: Select all

WSGIDaemonProcess apx-idea user=%user% group=%user% 
Modify it as follows:

Code: Select all

WSGIDaemonProcess apx-s$domain% user=%user% group=%user%
Next, just before the closing VirtualHost, there is a line starting with

Code: Select all

Include %home%/%user%/conf/web/
Change this line to:

Code: Select all

IncludeOptional %home%/%user%/conf/web/
Do similar changes for the wsgi.tmpl file, except use

Code: Select all

in the WSGIDaemonProcess line.

That should be it, and you should be able to successfully run multi-domain wsgi templates now.
I havn't had a chance to test this on Centos yet, but I'm going to guess the templates are fairly similar


Re: How to enable WSGI support on a Debian or Ubuntu

Posted: Wed May 01, 2019 10:54 am
by skamasle

Thanks you