VestaCP MultiPHP (Debian/Ubuntu) Topic is solved

Section with additional software for Vesta
ScIT
Posts: 252
Joined: Mon Feb 23, 2015 4:13 pm

Re: VestaCP MultiPHP (Debian/Ubuntu)

Postby ScIT » Tue Nov 08, 2016 9:41 pm

pligin wrote:Yes
I think this script is not working

Code: Select all

wrapper_script='#!/usr/local/php/php53/bin/php-cgi -c/usr/local/php/php53/etc/php.ini'
wrapper_file="/home/$user/web/$domain/cgi-bin/php"

echo "$wrapper_script" > $wrapper_file
chown $user:$user $wrapper_file
chmod -f 751 $wrapper_file


in the folder "home/$user/web/$domain/cgi-bin/php" does not create any files

P.S. nginx + apache2


Hmm, the script is "Vesta Based" (check /usr/local/vesta/data/templates/web/apache2/phpcgi.sh) with small modification. Try to use the "phpcgi" template, then rebuild your user and check if you have a file in /home/$user/web/$domain/cgi-bin/.

If you want, you can provide me your login informations to your server (pn), will check it tomorrow morning.

pligin
Posts: 32
Joined: Tue Jun 21, 2016 5:32 am

Re: VestaCP MultiPHP (Debian/Ubuntu)

Postby pligin » Tue Nov 08, 2016 9:59 pm

ScIT wrote:
pligin wrote:Yes
I think this script is not working

Code: Select all

wrapper_script='#!/usr/local/php/php53/bin/php-cgi -c/usr/local/php/php53/etc/php.ini'
wrapper_file="/home/$user/web/$domain/cgi-bin/php"

echo "$wrapper_script" > $wrapper_file
chown $user:$user $wrapper_file
chmod -f 751 $wrapper_file


in the folder "home/$user/web/$domain/cgi-bin/php" does not create any files

P.S. nginx + apache2


Hmm, the script is "Vesta Based" (check /usr/local/vesta/data/templates/web/apache2/phpcgi.sh) with small modification. Try to use the "phpcgi" template, then rebuild your user and check if you have a file in /home/$user/web/$domain/cgi-bin/.

If you want, you can provide me your login informations to your server (pn), will check it tomorrow morning.


I don't have a file in /home/$user/web/$domain/cgi-bin/. I reviewed all of the templates - all uniformly

ScIT
Posts: 252
Joined: Mon Feb 23, 2015 4:13 pm

Re: VestaCP MultiPHP (Debian/Ubuntu)

Postby ScIT » Tue Nov 08, 2016 10:49 pm

pligin wrote:I don't have a file in /home/$user/web/$domain/cgi-bin/. I reviewed all of the templates - all uniformly


As I wrote already, if you do the manual "step by step" it will work :-). Your problem was the inside of the wrapper script:

Code: Select all

...
wrapper_script='#!/usr/local/php/php53/bin/php-cgi -c/usr/local/php/php53/etc/php.ini'
-> wrapper_file="$home_dir/$user/web/$domain/cgi-bin/php"
...

my line:

Code: Select all

..
wrapper_script='#!/usr/local/php/php53/bin/php-cgi -c/usr/local/php/php53/etc/php.ini'
-> wrapper_file="/home/$user/web/$domain/cgi-bin/php"
...


It is now fixed on your server, seems to be a bug in existing phpcgi.sh file.

EDIT: Ok, also a bit missdocumentation in on myside. Linked the wget to github site, not to raw files: https://git.scit.ch/rs/VestaCP-MultiPHP ... f2212114d5

pligin
Posts: 32
Joined: Tue Jun 21, 2016 5:32 am

Re: VestaCP MultiPHP (Debian/Ubuntu)

Postby pligin » Wed Nov 09, 2016 11:06 am

ScIT wrote:
pligin wrote:I don't have a file in /home/$user/web/$domain/cgi-bin/. I reviewed all of the templates - all uniformly


As I wrote already, if you do the manual "step by step" it will work :-). Your problem was the inside of the wrapper script:

Code: Select all

...
wrapper_script='#!/usr/local/php/php53/bin/php-cgi -c/usr/local/php/php53/etc/php.ini'
-> wrapper_file="$home_dir/$user/web/$domain/cgi-bin/php"
...

my line:

Code: Select all

..
wrapper_script='#!/usr/local/php/php53/bin/php-cgi -c/usr/local/php/php53/etc/php.ini'
-> wrapper_file="/home/$user/web/$domain/cgi-bin/php"
...


It is now fixed on your server, seems to be a bug in existing phpcgi.sh file.

# PHP 5.3
wget http://git.scit.ch/rs/VestaCP-MultiPHP/ ... r/php53.sh -O /usr/local/vesta/data/templates/web/apache2/php53.sh
wget http://git.scit.ch/rs/VestaCP-MultiPHP/ ... er/php.tpl -O /usr/local/vesta/data/templates/web/apache2/php53.tpl
wget http://git.scit.ch/rs/VestaCP-MultiPHP/ ... r/php.stpl -O /usr/local/vesta/data/templates/web/apache2/php53.stpl

this string copied the html code for the page in vesta templates, so I had to download the template files from the site https://git.scit.ch/rs/VestaCP-MultiPHP/tree/master

... "step by step"...

ScIT
Posts: 252
Joined: Mon Feb 23, 2015 4:13 pm

Re: VestaCP MultiPHP (Debian/Ubuntu)

Postby ScIT » Wed Nov 09, 2016 11:49 am

pligin wrote:this string copied the html code for the page in vesta templates, so I had to download the template files from the site https://git.scit.ch/rs/VestaCP-MultiPHP/tree/master

... "step by step"...


already noted and fixed:

ScIT wrote:EDIT: Ok, also a bit missdocumentation in on myside. Linked the wget to github site, not to raw files: https://git.scit.ch/rs/VestaCP-MultiPHP ... f2212114d5


And as information: It's not a payed solution, it's provided as it is. If you like to contribute, you can do it. But it seems to be hard to just say "thanks" for a free solution :-)

skamasle
Collaborator
Posts: 360
Joined: Mon Feb 29, 2016 6:36 pm

Re: VestaCP MultiPHP (Debian/Ubuntu)

Postby skamasle » Wed Nov 16, 2016 9:13 pm

if file was not created maybe is afected for bug

https://bugs.vestacp.com/issues/287

v16 bug, fastcgi template not working property, miss some arguments and not check correct path

You can check this solution https://github.com/serghey-rodin/vesta/pull/759

krok
Posts: 61
Joined: Wed Oct 01, 2014 10:58 am

Re: VestaCP MultiPHP (Debian/Ubuntu)

Postby krok » Thu Nov 17, 2016 3:01 pm

I have a problem when compiling with this command in debian

Code: Select all

phpbrew install 7.0 +default +openssl=shared -- --with-openssl-dir=/usr/include/openssl --with-mysql-sock=/var/run/mysqld/mysqld.sock --with-mysql=mysqlnd --with-mysqli=mysqlnd --enable-pdo --with-pdo-mysql=mysqlnd --enable-exif --with-jpeg-dir=/usr --with-png-dir=/usr --with-freetype-dir=/usr --with-t1lib --with-zlib-dir=/usr --with-mcrypt=/usr --with-mhash --with-xsl=/usr --enable-zip --enable-cgi --with-curl --with-gd --enable-pcntl --enable-mbregex --enable-gd-native-ttf --with-libdir=lib64 --enable-dba=shared --enable-intl --with-readline=/usr --enable-simplexml \--enable-soap --enable-zip --with-mhash=yes --enable-shmop --enable-sockets --enable-wddx --enable-calendar --enable-sysvsem --enable-sysvshm --enable-sysvmsg --enable-bcmath --with-bz2 --enable-ctype --with-cdb --with-iconv --enable-exif --enable-ftp --with-gettext --with-pic


its not installing all necessary streams such as https, ftps..

In phpinfo it shows this in configure command

Code: Select all

'./configure' '--cache-file='''/usr/local/php/cache/config.cache'''' '--prefix=/usr/local/php/php/php-7.0.13' '--with-config-file-path=/usr/local/php/php/php-7.0.13/etc' '--with-config-file-scan-dir=/usr/local/php/php/php-7.0.13/var/db' '--disable-all' '--enable-session' '--enable-short-tags' '--with-zlib=/usr' '--with-libdir=lib/x86_64-linux-gnu' '--with-openssl=shared' '--enable-libxml' '--enable-xml' '--enable-xmlreader' '--enable-xmlwriter' '--with-xsl' '--with-libxml-dir=/usr' '--enable-opcache' '--with-bz2=/usr' '--enable-cli' '--enable-dom' '--enable-fileinfo' '--enable-filter' '--enable-json' '--enable-mbstring' '--with-mhash=/usr' '--with-pcre-regex' '--enable-phar' '--enable-posix' '--enable-tokenizer' '--with-curl=/usr' '--with-pear=/usr/local/php/php/php-7.0.13/lib/php' '--with-openssl-dir=/usr/include/openssl' '--with-mysql-sock=/var/run/mysqld/mysqld.sock' '--with-mysql=mysqlnd' '--with-mysqli=mysqlnd' '--enable-pdo' '--with-pdo-mysql=mysqlnd' '--enable-exif' '--with-jpeg-dir=/usr' '--with-png-dir=/usr' '--with-freetype-dir=/usr' '--with-t1lib' '--with-zlib-dir=/usr' '--with-mcrypt=/usr' '--with-mhash' '--with-xsl=/usr' '--enable-zip' '--enable-cgi' '--with-curl' '--with-gd' '--enable-pcntl' '--enable-mbregex' '--enable-gd-native-ttf' '--with-libdir=lib64' '--enable-dba=shared' '--enable-intl' '--with-readline=/usr' '--enable-simplexml' '--enable-soap' '--with-mhash=yes' '--enable-shmop' '--enable-sockets' '--enable-wddx' '--enable-calendar' '--enable-sysvsem' '--enable-sysvshm' '--enable-sysvmsg' '--enable-bcmath' '--with-bz2' '--enable-ctype' '--with-cdb' '--with-iconv' '--enable-ftp' '--with-gettext' '--with-pic'


any idea how i can compile it?

ScIT
Posts: 252
Joined: Mon Feb 23, 2015 4:13 pm

Re: VestaCP MultiPHP (Debian/Ubuntu)

Postby ScIT » Thu Nov 17, 2016 9:00 pm

krok wrote:its not installing all necessary streams such as https, ftps..


Don't know what you exactly mean with https/ftps streams. Normaly if you need something additional, you can adjust the phpbrew compilation string.

krok
Posts: 61
Joined: Wed Oct 01, 2014 10:58 am

Re: VestaCP MultiPHP (Debian/Ubuntu)

Postby krok » Fri Nov 18, 2016 12:14 am

ScIT wrote:
krok wrote:its not installing all necessary streams such as https, ftps..


Don't know what you exactly mean with https/ftps streams. Normaly if you need something additional, you can adjust the phpbrew compilation string.


It was user fault, i mixed up the workspace and edited the wrong files... solved now. thanks!

nik00726
Posts: 3
Joined: Thu Dec 01, 2016 3:38 am

Re: VestaCP MultiPHP (Debian/Ubuntu)

Postby nik00726 » Thu Dec 01, 2016 3:40 am

It is working fine but What about PHP CLI version ? It is still shown old PHP version not host set php CLI.

Please let me know how do i set host specific CLI version ?


Return to “3rd Party Software”



Who is online

Users browsing this forum: No registered users and 3 guests