(Jan 22) Release 0.9.8-19 with bug fixes available now. Run this command for update v-update-sys-vesta-all

VestaCP MultiPHP (Debian/Ubuntu) Topic is solved

Section with additional software for Vesta
Forum rules
Before creating a new topic or reply on the forum you should fill out additional fields "Os" and "Web" in your profile section.
In case of violation, the topic can be closed or response from the support will not be received.
ScIT
Posts: 335
Joined: Mon Feb 23, 2015 4:13 pm

Os: Ubuntu 16x
Web: apache + nginx

Re: VestaCP MultiPHP (Debian/Ubuntu)

Postby ScIT » Thu Dec 01, 2016 9:27 am

nik00726 wrote:It is working fine but What about PHP CLI version ? It is still shown old PHP version not host set php CLI.

Please let me know how do i set host specific CLI version ?


I do not have any solution to change php on cli atm. Also noted this problem with Magento 2 installation, whitch is impossible on multiphp envroiment. But feel free, if you find a solution, to post it here.

nik00726
Posts: 3
Joined: Thu Dec 01, 2016 3:38 am

Re: VestaCP MultiPHP (Debian/Ubuntu)

Postby nik00726 » Thu Dec 01, 2016 6:19 pm

Can you help me on that.When I complie/Build php adn after that PHPinfo it it show openssl disbale

OpenSSL support disabled (install ext/openssl)

I have try to figured it but could not get why it is disabled.

ScIT
Posts: 335
Joined: Mon Feb 23, 2015 4:13 pm

Os: Ubuntu 16x
Web: apache + nginx

Re: VestaCP MultiPHP (Debian/Ubuntu)

Postby ScIT » Thu Dec 01, 2016 7:38 pm

nik00726 wrote:Can you help me on that.When I complie/Build php adn after that PHPinfo it it show openssl disbale

OpenSSL support disabled (install ext/openssl)

I have try to figured it but could not get why it is disabled.

Can you check if you have any files in openssl (dev) dir?

Code: Select all

ls /usr/include/openssl


Also provide more information about your os, Ubuntu or Debian? Version?

nik00726
Posts: 3
Joined: Thu Dec 01, 2016 3:38 am

Re: VestaCP MultiPHP (Debian/Ubuntu)

Postby nik00726 » Fri Dec 02, 2016 2:49 am

Hello,

Here is output of command you have given

Code: Select all

root@mail:~# ls /usr/include/openssl
aes.h       camellia.h  des.h      ec.h        kssl.h     opensslv.h  rc2.h        srtp.h      ts.h
asn1.h      cast.h      des_old.h  ecdh.h      lhash.h    ossl_typ.h  rc4.h        ssl.h       txt_db.h
asn1_mac.h  cmac.h      dh.h       ecdsa.h     md4.h      pem.h       ripemd.h     ssl2.h      ui.h
asn1t.h     cms.h       dsa.h      engine.h    md5.h      pem2.h      rsa.h        ssl23.h     ui_compat.h
bio.h       comp.h      dso.h      err.h       modes.h    pkcs12.h    safestack.h  ssl3.h      whrlpool.h
blowfish.h  conf.h      dtls1.h    evp.h       obj_mac.h  pkcs7.h     seed.h       stack.h     x509.h
bn.h        conf_api.h  e_os2.h    hmac.h      objects.h  pqueue.h    sha.h        symhacks.h  x509_vfy.h
buffer.h    crypto.h    ebcdic.h   krb5_asn.h  ocsp.h     rand.h      srp.h        tls1.h      x509v3.h



I am using VPS and I have following info.Also I am using latest vestacp with that there us default php 5.6.4 and have no problem in openssl.If I use phpbrew's php 5.6.28 then problem in open ssl show OpenSSL support==>disabled (install ext/openssl)

Code: Select all


Distributor ID: Ubuntu
Description:    Ubuntu 15.04
Release:        15.04
Codename:       vivid


ang3lx
Posts: 12
Joined: Sun Nov 02, 2014 12:20 am

Re: VestaCP MultiPHP (Debian/Ubuntu)

Postby ang3lx » Tue Dec 06, 2016 12:01 am

Hello,
Installation works fine, but i've some timeout problems on nginx+apache installation

when I execute some script I receive

504 Gateway Timeout

The gateway did not receive a timely response from the upstream server or application.

i've tried to increase some timeout limit, but after 60 seconds.. webserver give me this 504 :(

PS. with distro default 5.5 all works fine

ScIT
Posts: 335
Joined: Mon Feb 23, 2015 4:13 pm

Os: Ubuntu 16x
Web: apache + nginx

Re: VestaCP MultiPHP (Debian/Ubuntu)

Postby ScIT » Tue Dec 06, 2016 12:02 pm

ang3lx wrote:Hello,
Installation works fine, but i've some timeout problems on nginx+apache installation

when I execute some script I receive

504 Gateway Timeout

The gateway did not receive a timely response from the upstream server or application.

i've tried to increase some timeout limit, but after 60 seconds.. webserver give me this 504 :(

PS. with distro default 5.5 all works fine


Check your php.ini file, they are for each version different. Normaly they should be under the folowing path:

Code: Select all

/usr/local/php/php-[version]/etc/php.ini

You don't have to restart your apache2 service, because they will be reloaded on every php requested.

ang3lx
Posts: 12
Joined: Sun Nov 02, 2014 12:20 am

Re: VestaCP MultiPHP (Debian/Ubuntu)

Postby ang3lx » Wed Dec 07, 2016 1:30 am

ScIT wrote:Check your php.ini file, they are for each version different. Normaly they should be under the folowing path:

Code: Select all

/usr/local/php/php-[version]/etc/php.ini

You don't have to restart your apache2 service, because they will be reloaded on every php requested.


thanks for reply

i've already edited /usr/local/php/php56/etc/php.ini

Code: Select all

max_execution_time = 1200
max_input_time = 1200
max_input_vars = 99000
memory_limit = 1024M


but the timeout is always there. There is any option to update?

ScIT
Posts: 335
Joined: Mon Feb 23, 2015 4:13 pm

Os: Ubuntu 16x
Web: apache + nginx

Re: VestaCP MultiPHP (Debian/Ubuntu)

Postby ScIT » Wed Dec 07, 2016 9:30 am

ang3lx wrote:You don't have to restart your apache2 service, because they will be reloaded on every php requested.


thanks for reply

i've already edited /usr/local/php/php56/etc/php.ini

Code: Select all

max_execution_time = 1200
max_input_time = 1200
max_input_vars = 99000
memory_limit = 1024M


but the timeout is always there. There is any option to update?[/quote]

Can you check with phpinfo, if the values are correctly displayed in configuration for your webpage?

Code: Select all

<?php

echo phpinfo();

?>

ang3lx
Posts: 12
Joined: Sun Nov 02, 2014 12:20 am

Re: VestaCP MultiPHP (Debian/Ubuntu)

Postby ang3lx » Wed Dec 07, 2016 9:39 am

ScIT wrote:Can you check with phpinfo, if the values are correctly displayed in configuration for your webpage?

Code: Select all

<?php

echo phpinfo();

?>


yes, values are correctly displayed

ktanev
Posts: 1
Joined: Fri Mar 31, 2017 12:28 pm

Re: VestaCP MultiPHP (Debian/Ubuntu)

Postby ktanev » Fri Mar 31, 2017 12:31 pm

nik00726 wrote:Can you help me on that.When I complie/Build php adn after that PHPinfo it it show openssl disbale

OpenSSL support disabled (install ext/openssl)

I have try to figured it but could not get why it is disabled.


In my case, the file php_openssl.so is missing from the extension directory. But when I go to the dir, there have few files and openssl.so, so basically I just create symlink to the file openssl.so with filename php_openssl.so :)

If you are using 5.5.38 PHP, you need to do this:

1. go to

Code: Select all

/usr/local/php/php/php-5.5.38/lib/php/extensions/no-debug-non-zts-20121212

2. create symlink

Code: Select all

ln -s openssl.so php_openssl.so


Probably this will work for other versions of php... Just change the dir


Return to “3rd Party Software”



Who is online

Users browsing this forum: No registered users and 2 guests