Page 1 of 1

Vestacp and bitwarden

Posted: Wed Mar 10, 2021 1:17 pm
by sakalsk
Hello all,

i have one VPS server where is running VestaCP and some websites already. But after Lastpass new policie i find out i need to migrate to other better platform suitable for my needs. So i start installing Bitwarden as docker container on my system by official manual:
Problem is when i am on step :
(!) Enter your email address (Let’s Encrypt will send you certificate expiration reminders): lukas.xxx@gmail.com
Using default tag: latest
latest: Pulling from certbot/certbot
Digest: sha256:b12bbd09b41b091abb2937721512e534c5e5aecbe2f100900afd7b3424545529
Status: Image is up to date for certbot/certbot:latest
docker.io/certbot/certbot:latest
docker: Error response from daemon: driver failed programming external connectivity on endpoint certbot (ce4969c3f6d82e8f8dffcae7a014ea48c68fa93acdf35d260cb352806eea02ab): Error starting userland proxy: listen tcp4 0.0.0.0:80: bind: address already in use.
Of course problem is there is already running Vesta Control Panel on that port but how i can change installation to other port.
When i dig in forum i find out the should be folder and file : ./bwdata/config.yml file
but there is none in my system, is it not build after successful installation?
But how can i do installation when is on port 80 and 443 already running apache services for other multi websites???

Error on what i am stuck is:

driver failed programming external connectivity on endpoint certbot (ce4969c3f6d82e8f8dffcae7a014ea48c68fa93acdf35d260cb352806eea02ab): Error starting userland proxy: listen tcp4 0.0.0.0:80: bind: address already in use.

Please any idea how to install it when there is apache running on port 80 and 443 ?
Anyone implement bitwarden on server where is also VestaCP ?