[Question] Replacing default Let's Encrypt plugin or enhancing it? (ECC / ECC+RSA)

Section with modification and patches for Vesta
Somebodysh
Posts: 2
Joined: Mon Jun 05, 2017 11:35 pm

[Question] Replacing default Let's Encrypt plugin or enhancing it? (ECC / ECC+RSA)

Postby Somebodysh » Wed Jul 12, 2017 10:23 pm

Hello everyone! As some of you could already know, Let's Encrypt now supports ECC-keys based certificates, and the support coverage of ECC-256 is almost the same as RSA-4096, excluding very-very old clients. Also, there is a way to serve both RSA and ECC certificates for nginx depending on client's abilities.
But Let's Encrypt in current VestaCP version can only generate and manage RSA-based keys, is there any mod to add/replace ECC keys?
I even found acme.sh - bash-based implementation of Certbot with ECC support, can any Linux-guru make a tutorial of replacing default LE plugin with this one? Pls :3

Return to “Modification & Patches”



Who is online

Users browsing this forum: No registered users and 2 guests