Page 2 of 2

Re: Выбор версии php

Posted: Sun Dec 08, 2019 1:59 pm
by grayfolk
Skorsa wrote:
Sun Dec 08, 2019 1:57 pm
Команды посоветуете ?
Сто раз тут обсуждалось, в гугле наверняка тоже найдется.
Поищите хотя бы в моей истории.

Re: Выбор версии php

Posted: Sun Dec 08, 2019 2:10 pm
by Skorsa
Так пойдёт ? Или при установке просто добавить remi в команду установки и всё ?
yum remove php
yum install yum-utils
yum-config-manager --enable remi-php72
yum install php

Re: Выбор версии php

Posted: Sun Dec 08, 2019 2:21 pm
by grayfolk
Skorsa wrote:
Sun Dec 08, 2019 2:10 pm
Так пойдёт ? Или при установке просто добавить remi в команду установки и всё ?
yum remove php
yum install yum-utils
yum-config-manager --enable remi-php72
yum install php
Я бы запретил все ненужные версии, разрешил нужную. И после этого yum update.

Re: Выбор версии php

Posted: Sun Dec 08, 2019 2:27 pm
by Skorsa
Если нетрудно, напишите/допишите пожалуйста команды.

Re: Выбор версии php

Posted: Sun Dec 08, 2019 3:26 pm
by grayfolk

Code: Select all

 yum-config-manager --disable remi-php5*
 yum-config-manager --disable remi-php7*
 yum-config-manager --enable remi-php72
 yum update

Re: Выбор версии php

Posted: Fri Jan 10, 2020 10:57 pm
by qwaros
Забыл отписаться (
В общем для решения проблемы с 7 пхп вместо 5 достаточно отключить remi репозитории при установке.

Code: Select all

--remi no
тогда пыха ставится из репов ОС нормальная. Иначе ставит последнюю возможную (

p/s запрет и переустановка версий пыхи тянет за собой целый паровоз гемороя. Мне так и не удалось ни понизить версию нормально чтобы все приложения работали ни установить мультиверсию по гайдам сети. В частности ioncube просто отказывается становится на разные шаблоны (версии пыхи) как бы я его не уговаривал )))

Re: Выбор версии php

Posted: Fri Jan 10, 2020 11:00 pm
by qwaros
grayfolk wrote:
Sun Dec 08, 2019 3:26 pm

Code: Select all

 yum-config-manager --disable remi-php5*
 yum-config-manager --disable remi-php7*
 yum-config-manager --enable remi-php72
 yum update
Вот да, это ведет к тому что все зависимости как самой весты так и приложений поплывут )))

Re: Выбор версии php

Posted: Sat Jan 11, 2020 7:55 pm
by grayfolk
qwaros wrote:
Fri Jan 10, 2020 11:00 pm
grayfolk wrote:
Sun Dec 08, 2019 3:26 pm

Code: Select all

 yum-config-manager --disable remi-php5*
 yum-config-manager --disable remi-php7*
 yum-config-manager --enable remi-php72
 yum update
Вот да, это ведет к тому что все зависимости как самой весты так и приложений поплывут )))
Ни разу ничего не плыло )

Веста тут вообще не при чем, Веста - это всего лишь инструмент для управления конфигами.