Проблема с LetsEncrypt CLI - ошибка LetsEncrypt account registration 400 Topic is solved

Вопросы по работе Веб сервера
Apache + Nginx, Nginx + PHP5-FPM
abst
Posts: 49
Joined: Mon Feb 15, 2016 6:48 am

Проблема с LetsEncrypt CLI - ошибка LetsEncrypt account registration 400

Postby abst » Fri Aug 05, 2016 11:59 am

Есть несколько вопросов относительно установки сертификата через новый CLI в Vesta.

1) Сначала нужно добавить юзера (v-add-letsencrypt-user USER [EMAIL]), а потом домен (v-add-letsencrypt-domain USER DOMAIN [ALIASES] [RESTART])?

2) При выполнении любой из команд выводилась ошибка:

Code: Select all

/usr/local/vesta/bin/v-add-letsencrypt-user: line 59: xxd: command not found
/usr/local/vesta/bin/v-add-letsencrypt-user: line 63: xxd: command not found
Error: LetsEncrypt account registration 400


Посмотрев тему viewtopic.php?t=11927 установил это:

Code: Select all

yum install vim-common


Ошибка превратилась в Error:

Code: Select all

LetsEncrypt account registration 400


Что я делаю не так?

На сервере стоит Centos7, в качестве юзера использую имя пользователя из панели и уже добавленные туда домены.

JEY70
Posts: 123
Joined: Sat May 04, 2013 8:06 pm
Location: Россия
Contact:

Re: Проблема с LetsEncrypt CLI - ошибка LetsEncrypt account registration 400

Postby JEY70 » Sat Aug 06, 2016 3:45 pm

Аналогичная проблема и в Centos и в debian. Покачто вписываю серты ручками.

JEY70
Posts: 123
Joined: Sat May 04, 2013 8:06 pm
Location: Россия
Contact:

Re: Проблема с LetsEncrypt CLI - ошибка LetsEncrypt account registration 400

Postby JEY70 » Sat Aug 06, 2016 4:07 pm

А на свежеустановленном debian

Code: Select all

root@1111:/# v-add-letsencrypt-user admin 111@gmail.com
bash: v-add-letsencrypt-user: команда не найдена


Что то 16 обновление больше бед принесло чем пользы) Ждем скорейших исправлений

imperio
VestaCP Team
Posts: 5401
Joined: Sat Dec 01, 2012 12:37 pm
Contact:

Re: Проблема с LetsEncrypt CLI - ошибка LetsEncrypt account registration 400

Postby imperio » Sat Aug 06, 2016 5:13 pm

Добавьте баг с подробным описанием проблемы.
https://bugs.vestacp.com/
-> DigitalOcean competition - please, support us
-> fix for phpmyadmin - nice and sweet now

abst
Posts: 49
Joined: Mon Feb 15, 2016 6:48 am

Re: Проблема с LetsEncrypt CLI - ошибка LetsEncrypt account registration 400

Postby abst » Sat Aug 06, 2016 6:26 pm

Создал тикет - https://bugs.vestacp.com/issues/335, но как подробнее описать проблему, к сожалению не знаю, так как просто не работает и все. Если нужны какие-то дополнительные данные - с удовольствием предоставлю.

imperio
VestaCP Team
Posts: 5401
Joined: Sat Dec 01, 2012 12:37 pm
Contact:

Re: Проблема с LetsEncrypt CLI - ошибка LetsEncrypt account registration 400

Postby imperio » Sat Aug 06, 2016 6:31 pm

Хорошо мы проверим эту проблему в понедельник, если повторится, то думаю что успеем пофиксить до выхода релиза
-> DigitalOcean competition - please, support us
-> fix for phpmyadmin - nice and sweet now

skurudo
VestaCP Team
Posts: 7776
Joined: Fri Dec 26, 2014 2:23 pm
Location: Moscow
Contact:

Re: Проблема с LetsEncrypt CLI - ошибка LetsEncrypt account registration 400

Postby skurudo » Mon Aug 08, 2016 8:14 am

Имхо дело с " команда не найдена" вот в этом:

Code: Select all

export VESTA=/usr/local/vesta/

и реконнект
или
viewtopic.php?uid=17&f=16&t=5075&start=0#p15173
-> DigitalOcean competition - please, support us
-> fix for phpmyadmin - nice and sweet now

abst
Posts: 49
Joined: Mon Feb 15, 2016 6:48 am

Re: Проблема с LetsEncrypt CLI - ошибка LetsEncrypt account registration 400

Postby abst » Mon Aug 08, 2016 9:45 am

skurudo wrote:Имхо дело с " команда не найдена" вот в этом:

Code: Select all

export VESTA=/usr/local/vesta/

и реконнект
или
https://forum.vestacp.com/viewtopic.php ... t=0#p15173

Ответ точно в эту тему?
Заменил содержимое файла как написано в теме - https://forum.vestacp.com/viewtopic.php ... t=0#p15173
Перезагрузил сервер и в итоге ничего не изменилось.

abst
Posts: 49
Joined: Mon Feb 15, 2016 6:48 am

Re: Проблема с LetsEncrypt CLI - ошибка LetsEncrypt account registration 400  Topic is solved

Postby abst » Tue Aug 09, 2016 6:27 am

Проблема была в актуальности URL на соглашение. Для фикса:
Change line 44 of: /usr/local/vesta/bin/v-add-letsencrypt-user

Code: Select all

agreement='https://letsencrypt.org/documents/LE-SA-v1.1.1-August-1-2016.pdf'

Но вопрос как пофиксить это на будущее остается открытым

skurudo
VestaCP Team
Posts: 7776
Joined: Fri Dec 26, 2014 2:23 pm
Location: Moscow
Contact:

Re: Проблема с LetsEncrypt CLI - ошибка LetsEncrypt account registration 400

Postby skurudo » Tue Aug 09, 2016 1:32 pm

abst wrote:Ответ точно в эту тему?

по этой ошибке - определенно.

Code: Select all

bash: v-add-letsencrypt-user: команда не найдена
-> DigitalOcean competition - please, support us
-> fix for phpmyadmin - nice and sweet now


Return to “Веб сервер”



Who is online

Users browsing this forum: No registered users and 6 guests